summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-16 16:26:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-16 16:26:15 +0000
commitefebf9d1b174ed7c5047d710fa12de68c5dc222a (patch)
tree04e31a6e62b94cd381ef91c87146f0a7e93d8aeb /xfce-base/xfconf
parentVersion bump. (diff)
downloadgentoo-2-efebf9d1b174ed7c5047d710fa12de68c5dc222a.tar.gz
gentoo-2-efebf9d1b174ed7c5047d710fa12de68c5dc222a.tar.bz2
gentoo-2-efebf9d1b174ed7c5047d710fa12de68c5dc222a.zip
Version bump.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/ChangeLog7
-rw-r--r--xfce-base/xfconf/xfconf-4.8.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index e3cf45c6439f..9485cbfc9e19 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.44 2011/01/02 15:25:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.45 2011/01/16 16:26:15 ssuominen Exp $
+
+*xfconf-4.8.0 (16 Jan 2011)
+
+ 16 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfconf-4.8.0.ebuild:
+ Version bump.
*xfconf-4.7.5 (02 Jan 2011)
diff --git a/xfce-base/xfconf/xfconf-4.8.0.ebuild b/xfce-base/xfconf/xfconf-4.8.0.ebuild
new file mode 100644
index 000000000000..6da57ee8f5c6
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.8.0.ebuild,v 1.1 2011/01/16 16:26:15 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's configuration storage system"
+HOMEPAGE="http://www.xfce.org/projects/xfconf/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.18:2
+ >=xfce-base/libxfce4util-4.8
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable perl perl-bindings)
+ $(xfconf_use_debug)
+ $(use_enable debug checks)
+ --with-perl-options=INSTALLDIRS=vendor
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}