summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-02-04 17:11:37 +0000
committerSamuli Suominen <drac@gentoo.org>2007-02-04 17:11:37 +0000
commit1d9cbfea49c62ccb8952b2345f8c89257ac3a0b3 (patch)
tree35de8b974720d9b1a98ec405870b8da65e6d2159 /xfce-base
parentVersion bump. Brings some small man page fixes. (diff)
downloadgentoo-2-1d9cbfea49c62ccb8952b2345f8c89257ac3a0b3.tar.gz
gentoo-2-1d9cbfea49c62ccb8952b2345f8c89257ac3a0b3.tar.bz2
gentoo-2-1d9cbfea49c62ccb8952b2345f8c89257ac3a0b3.zip
Move checks inside pkg_setup and adjust dbus dep.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog7
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.8.0-r13
-rw-r--r--xfce-base/thunar/thunar-0.8.0-r1.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 1e76219d6b0e..caf28e7f1177 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.17 2007/02/03 02:34:13 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.18 2007/02/04 17:11:37 drac Exp $
+
+*thunar-0.8.0-r1 (04 Feb 2007)
+
+ 04 Feb 2007; Samuli Suominen <drac@gentoo.org> +thunar-0.8.0-r1.ebuild:
+ Move checks to local scope and adjust dbus dep.
03 Feb 2007; Joshua Nichols <nichoj@gentoo.org>
-thunar-0.5.0_rc2-r3.ebuild:
diff --git a/xfce-base/thunar/files/digest-thunar-0.8.0-r1 b/xfce-base/thunar/files/digest-thunar-0.8.0-r1
new file mode 100644
index 000000000000..36154971d4f9
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.8.0-r1
@@ -0,0 +1,3 @@
+MD5 9f7b0945d6a235391049f6818fb4d188 Thunar-0.8.0.tar.bz2 6205993
+RMD160 95d29cca64c102b7d8bdcc0592f6fcab7198148b Thunar-0.8.0.tar.bz2 6205993
+SHA256 460484f8397a0e0e4115d1629d2ae027b5052dc2c564d4a4629a3557e4a055f9 Thunar-0.8.0.tar.bz2 6205993
diff --git a/xfce-base/thunar/thunar-0.8.0-r1.ebuild b/xfce-base/thunar/thunar-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..74113da04e7a
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.8.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0-r1.ebuild,v 1.1 2007/02/04 17:11:37 drac Exp $
+
+inherit eutils xfce44
+
+MY_P="${P/t/T}"
+S="${WORKDIR}/${MY_P}"
+
+xfce44
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc dbus debug exif gnome hal plugins pcre startup-notification"
+
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=xfce-extra/exo-0.3.2
+ >=x11-misc/shared-mime-info-0.15
+ >=dev-util/desktop-file-utils-0.10
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ dbus? ( || ( dev-libs/dbus-glib <sys-apps/dbus-1 ) )
+ hal? ( sys-apps/hal )
+ >=media-libs/freetype-2
+ gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ plugins? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif) $(use_enable gnome gnome-thumbnailers) \
+ $(use_enable dbus) $(use_enable pcre)"
+
+pkg_setup() {
+ if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+ fi
+
+ if use plugins && ! use dbus ; then
+ XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+ ewarn "Plugins requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ epause 3
+ fi
+
+ if use hal && ! use dbus ; then
+ ewarn "HAL requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ die "re-emerge with USE dbus"
+ fi
+}
+
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+xfce44_extra_package