summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-09-23 17:32:09 +0000
committerChristoph Mende <angelos@gentoo.org>2011-09-23 17:32:09 +0000
commit435902cc01c311bdaf89457a16cf1f48768576b0 (patch)
tree732bb350bf255dcf1abf6b2bb34a14e4400f0424 /xfce-base
parentVersion bump (diff)
downloadgentoo-2-435902cc01c311bdaf89457a16cf1f48768576b0.tar.gz
gentoo-2-435902cc01c311bdaf89457a16cf1f48768576b0.tar.bz2
gentoo-2-435902cc01c311bdaf89457a16cf1f48768576b0.zip
Version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog7
-rw-r--r--xfce-base/thunar/thunar-1.2.3.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index e3b82228304a..27163756ff22 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/thunar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.124 2011/08/09 11:02:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.125 2011/09/23 17:32:09 angelos Exp $
+
+*thunar-1.2.3 (23 Sep 2011)
+
+ 23 Sep 2011; Christoph Mende <angelos@gentoo.org> +thunar-1.2.3.ebuild:
+ Version bump
*thunar-1.2.2-r1 (09 Aug 2011)
diff --git a/xfce-base/thunar/thunar-1.2.3.ebuild b/xfce-base/thunar/thunar-1.2.3.ebuild
new file mode 100644
index 000000000000..0a89b91897a3
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.2.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-1.2.3.ebuild,v 1.1 2011/09/23 17:32:09 angelos Exp $
+
+EAPI=4
+inherit virtualx xfconf
+
+MY_P=${P/t/T}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/thunar/ http://thunar.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/1.2/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug exif libnotify pcre startup-notification test +xfce_plugins_trash udev"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.6.7"
+COMMON_DEPEND=">=xfce-base/exo-0.6
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=dev-lang/perl-5.6
+ dbus? ( >=dev-libs/dbus-glib-0.88 )
+ exif? ( >=media-libs/libexif-0.6.19 )
+ libnotify? ( x11-libs/libnotify )
+ pcre? ( >=dev-libs/libpcre-6 )
+ startup-notification? ( x11-libs/startup-notification )
+ udev? ( || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
+ xfce_plugins_trash? ( >=dev-libs/dbus-glib-0.88
+ >=xfce-base/xfce4-panel-4.8 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ dev-util/desktop-file-utils
+ dbus? ( ${GVFS_DEPEND} )
+ udev? ( ${GVFS_DEPEND}[gdu,udev] )
+ xfce_plugins_trash? ( ${GVFS_DEPEND} )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dbus)
+ $(use_enable startup-notification)
+ $(use_enable udev gudev)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ $(use_enable exif)
+ $(use_enable pcre)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ if use xfce_plugins_trash; then
+ XFCONF+=( --enable-dbus )
+ else
+ XFCONF+=( --disable-tpa-plugin )
+ fi
+
+ DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+}
+
+src_test() {
+ Xemake check
+}