summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-08-20 03:37:18 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-08-20 03:37:18 +0000
commit6fc8cfedd0ee4f438849108b00f17842dfc9d593 (patch)
tree4549e2f50410c00f9c212c8287360703d0235e19 /xfce-base
parentremove unused patches (diff)
downloadgentoo-2-6fc8cfedd0ee4f438849108b00f17842dfc9d593.tar.gz
gentoo-2-6fc8cfedd0ee4f438849108b00f17842dfc9d593.tar.bz2
gentoo-2-6fc8cfedd0ee4f438849108b00f17842dfc9d593.zip
remove unused patches
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog6
-rw-r--r--xfce-base/thunar/files/thunar-0.8.0-jpeg.patch162
-rw-r--r--xfce-base/thunar/files/thunar-0.8.0-uca.patch19
3 files changed, 5 insertions, 182 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index f3ef5ec35e5d..faf97e24bcd5 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/thunar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.78 2009/08/02 10:37:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.79 2009/08/20 03:37:18 darkside Exp $
+
+ 20 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
+ -files/thunar-0.8.0-jpeg.patch, -files/thunar-0.8.0-uca.patch:
+ remove unused patches
02 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> thunar-1.0.1.ebuild:
Use xfconf.eclass.
diff --git a/xfce-base/thunar/files/thunar-0.8.0-jpeg.patch b/xfce-base/thunar/files/thunar-0.8.0-jpeg.patch
deleted file mode 100644
index befd077b7f02..000000000000
--- a/xfce-base/thunar/files/thunar-0.8.0-jpeg.patch
+++ /dev/null
@@ -1,162 +0,0 @@
-diff -ur Thunar-0.8.0.orig/thunar-vfs/thunar-vfs-thumb-jpeg.c Thunar-0.8.0/thunar-vfs/thunar-vfs-thumb-jpeg.c
---- Thunar-0.8.0.orig/thunar-vfs/thunar-vfs-thumb-jpeg.c 2007-01-20 22:39:09.000000000 +0200
-+++ Thunar-0.8.0/thunar-vfs/thunar-vfs-thumb-jpeg.c 2007-02-12 20:16:29.000000000 +0200
-@@ -310,18 +310,18 @@
- {
- struct /* thumbnail JPEG */
- {
-- guint thumb_jpeg_length;
-- guint thumb_jpeg_offset;
-- };
-+ guint length;
-+ guint offset;
-+ } thumb_jpeg;
- struct /* thumbnail TIFF */
- {
-- guint thumb_tiff_length;
-- guint thumb_tiff_offset;
-- guint thumb_tiff_interp;
-- guint thumb_tiff_height;
-- guint thumb_tiff_width;
-- };
-- };
-+ guint length;
-+ guint offset;
-+ guint interp;
-+ guint height;
-+ guint width;
-+ } thumb_tiff;
-+ } thumb;
-
- gboolean big_endian;
- } TvtjExif;
-@@ -330,24 +330,24 @@
-
- static guint
- tvtj_exif_get_ushort (const TvtjExif *exif,
-- gconstpointer data)
-+ const guchar *data)
- {
- if (G_UNLIKELY (exif->big_endian))
-- return GUINT16_FROM_BE (*((const guint16 *) data));
-+ return ((data[0] << 8) | data[1]);
- else
-- return GUINT16_FROM_LE (*((const guint16 *) data));
-+ return ((data[1] << 8) | data[0]);
- }
-
-
-
- static guint
- tvtj_exif_get_ulong (const TvtjExif *exif,
-- gconstpointer data)
-+ const guchar *data)
- {
- if (G_UNLIKELY (exif->big_endian))
-- return GUINT32_FROM_BE (*((const guint32 *) data));
-+ return ((data[0] << 24) | (data[1] << 16) | (data[2] << 8) | data[3]);
- else
-- return GUINT32_FROM_LE (*((const guint32 *) data));
-+ return ((data[3] << 24) | (data[2] << 16) | (data[1] << 8) | data[0]);
- }
-
-
-@@ -415,15 +415,15 @@
-
- /* and remember it appropriately */
- if (tag == 0x0100)
-- exif->thumb_tiff_width = value;
-+ exif->thumb.thumb_tiff.width = value;
- else if (tag == 0x0100)
-- exif->thumb_tiff_height = value;
-+ exif->thumb.thumb_tiff.height = value;
- else if (tag == 0x0106)
-- exif->thumb_tiff_interp = value;
-+ exif->thumb.thumb_tiff.interp = value;
- else if (tag == 0x0111)
-- exif->thumb_tiff_offset = value;
-+ exif->thumb.thumb_tiff.offset = value;
- else
-- exif->thumb_tiff_length = value;
-+ exif->thumb.thumb_tiff.length = value;
- }
- else if (tag == 0x0201 || tag == 0x0202)
- {
-@@ -435,9 +435,9 @@
-
- /* and remember it appropriately */
- if (G_LIKELY (tag == 0x201))
-- exif->thumb_jpeg_offset = value;
-+ exif->thumb.thumb_jpeg.offset = value;
- else
-- exif->thumb_jpeg_length = value;
-+ exif->thumb.thumb_jpeg.length = value;
- }
- }
- }
-@@ -503,25 +503,25 @@
- if (G_LIKELY (exif.thumb_compression == 6)) /* JPEG */
- {
- /* check if we have a valid thumbnail JPEG */
-- if (exif.thumb_jpeg_offset > 0 && exif.thumb_jpeg_length > 0
-- && exif.thumb_jpeg_offset + exif.thumb_jpeg_length <= length)
-+ if (exif.thumb.thumb_jpeg.offset > 0 && exif.thumb.thumb_jpeg.length > 0
-+ && exif.thumb.thumb_jpeg.offset + exif.thumb.thumb_jpeg.length <= length)
- {
- /* try to load the embedded thumbnail JPEG */
-- return tvtj_jpeg_load (data + exif.thumb_jpeg_offset, exif.thumb_jpeg_length, size);
-+ return tvtj_jpeg_load (data + exif.thumb.thumb_jpeg.offset, exif.thumb.thumb_jpeg.length, size);
- }
- }
- else if (exif.thumb_compression == 1) /* Uncompressed */
- {
- /* check if we have a valid thumbnail (current only RGB interpretations) */
-- if (G_LIKELY (exif.thumb_tiff_interp == 2)
-- && exif.thumb_tiff_offset > 0 && exif.thumb_tiff_length > 0
-- && exif.thumb_tiff_offset + exif.thumb_tiff_length <= length
-- && exif.thumb_tiff_height * exif.thumb_tiff_width == exif.thumb_tiff_length)
-+ if (G_LIKELY (exif.thumb.thumb_tiff.interp == 2)
-+ && exif.thumb.thumb_tiff.offset > 0 && exif.thumb.thumb_tiff.length > 0
-+ && exif.thumb.thumb_tiff.offset + exif.thumb.thumb_tiff.length <= length
-+ && exif.thumb.thumb_tiff.height * exif.thumb.thumb_tiff.width == exif.thumb.thumb_tiff.length)
- {
- /* plain RGB data, just what we need for a GdkPixbuf */
-- return gdk_pixbuf_new_from_data (g_memdup (data + exif.thumb_tiff_offset, exif.thumb_tiff_length),
-- GDK_COLORSPACE_RGB, FALSE, 8, exif.thumb_tiff_width,
-- exif.thumb_tiff_height, exif.thumb_tiff_width,
-+ return gdk_pixbuf_new_from_data (g_memdup (data + exif.thumb.thumb_tiff.offset, exif.thumb.thumb_tiff.length),
-+ GDK_COLORSPACE_RGB, FALSE, 8, exif.thumb.thumb_tiff.width,
-+ exif.thumb.thumb_tiff.height, exif.thumb.thumb_tiff.width,
- (GdkPixbufDestroyNotify) g_free, NULL);
- }
- }
-@@ -615,7 +615,7 @@
- if (G_LIKELY (fstat (fd, &statb) == 0 && statb.st_size > 0))
- {
- /* try to mmap the file */
-- content = mmap (NULL, statb.st_size, PROT_READ, MAP_SHARED, fd, 0);
-+ content = (JOCTET *) mmap (NULL, statb.st_size, PROT_READ, MAP_SHARED, fd, 0);
-
- /* verify that the mmap was successful */
- if (G_LIKELY (content != (JOCTET *) MAP_FAILED))
-@@ -630,7 +630,7 @@
- }
-
- /* unmap the file content */
-- munmap (content, statb.st_size);
-+ munmap ((void *) content, statb.st_size);
- }
-
- /* close the file */
-@@ -638,9 +638,9 @@
- }
-
- return pixbuf;
--#endif
--
-+#else
- return NULL;
-+#endif
- }
-
-
diff --git a/xfce-base/thunar/files/thunar-0.8.0-uca.patch b/xfce-base/thunar/files/thunar-0.8.0-uca.patch
deleted file mode 100644
index 53d3dbc18852..000000000000
--- a/xfce-base/thunar/files/thunar-0.8.0-uca.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: plugins/thunar-uca/thunar-uca-editor.c
-===================================================================
---- plugins/thunar-uca/thunar-uca-editor.c (revision 25631)
-+++ plugins/thunar-uca/thunar-uca-editor.c (working copy)
-@@ -582,7 +582,13 @@
- if (gtk_dialog_run (GTK_DIALOG (chooser)) == GTK_RESPONSE_ACCEPT)
- {
- filename = gtk_file_chooser_get_filename (GTK_FILE_CHOOSER (chooser));
-- s = g_strconcat (filename, " %f", NULL);
-+
-+ /* quote the command when the filename contains spaces */
-+ if (G_LIKELY (strchr (filename, ' ') == NULL))
-+ s = g_strconcat (filename, " %f", NULL);
-+ else
-+ s = g_strconcat ("'", filename, "' %f", NULL);
-+
- gtk_entry_set_text (GTK_ENTRY (uca_editor->command_entry), s);
- g_free (filename);
- g_free (s);