summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-01 22:44:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-01 22:44:27 +0000
commitf02ce800846bdcf1ab30961167d01f2f24a0757c (patch)
tree0284cb674e2fd3f9382a2c3563d4a622ca5a50d1 /xfce-base
parentadd back mocha.xfce.org to mirror://xfce - it uses symlinks on the server sid... (diff)
downloadgentoo-2-f02ce800846bdcf1ab30961167d01f2f24a0757c.tar.gz
gentoo-2-f02ce800846bdcf1ab30961167d01f2f24a0757c.tar.bz2
gentoo-2-f02ce800846bdcf1ab30961167d01f2f24a0757c.zip
Use xfconf.eclass.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/ChangeLog5
-rw-r--r--xfce-base/xfwm4/xfwm4-4.6.1.ebuild37
2 files changed, 25 insertions, 17 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index a563654fe9b6..d245bc15f86d 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/xfwm4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.137 2009/07/27 17:42:07 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.138 2009/08/01 22:44:27 ssuominen Exp $
+
+ 01 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> xfwm4-4.6.1.ebuild:
+ Use xfconf.eclass.
27 Jul 2009; nixnut <nixnut@gentoo.org> xfwm4-4.6.1.ebuild:
ppc stable #265587
diff --git a/xfce-base/xfwm4/xfwm4-4.6.1.ebuild b/xfce-base/xfwm4/xfwm4-4.6.1.ebuild
index 7e437aba7401..f20432243d5d 100644
--- a/xfce-base/xfwm4/xfwm4-4.6.1.ebuild
+++ b/xfce-base/xfwm4/xfwm4-4.6.1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.6.1.ebuild,v 1.9 2009/07/27 17:42:07 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.6.1.ebuild,v 1.10 2009/08/01 22:44:27 ssuominen Exp $
-EAPI="1"
+EAPI=2
+inherit xfconf
-inherit xfce4
-
-xfce4_core
-
-DESCRIPTION="Window manager"
+DESCRIPTION="Window manager for Xfce4"
HOMEPAGE="http://www.xfce.org/projects/xfwm4/"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="debug startup-notification xcomposite"
RDEPEND=">=dev-libs/glib-2.10:2
@@ -25,19 +24,25 @@ RDEPEND=">=dev-libs/glib-2.10:2
x11-libs/libXpm
x11-libs/pango
>=x11-libs/libwnck-2.12
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
startup-notification? ( x11-libs/startup-notification )
xcomposite? ( x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXfixes )"
DEPEND="${RDEPEND}
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
pkg_setup() {
- XFCE_CONFIG+=" --enable-xsync --enable-render --enable-randr
- $(use_enable xcomposite compositor)"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog COMPOSITOR NEWS README TODO"
}
-
-DOCS="AUTHORS ChangeLog COMPOSITOR NEWS README TODO"