summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-24 20:05:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-24 20:05:06 +0000
commitfab77cbde084f717eccefcbad1d334033a67b2cc (patch)
tree052b4d725e69d28c7bc84e09cd96f1da237814b1 /xfce-extra/thunar-vfs
parentstable x86, bug 308379 (diff)
downloadgentoo-2-fab77cbde084f717eccefcbad1d334033a67b2cc.tar.gz
gentoo-2-fab77cbde084f717eccefcbad1d334033a67b2cc.tar.bz2
gentoo-2-fab77cbde084f717eccefcbad1d334033a67b2cc.zip
Initial commit of transition package. Separate Thunar VFS libraries from Thunar 1.0.1 to be used with unported applications.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/thunar-vfs')
-rw-r--r--xfce-extra/thunar-vfs/ChangeLog11
-rw-r--r--xfce-extra/thunar-vfs/metadata.xml5
-rw-r--r--xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild64
3 files changed, 80 insertions, 0 deletions
diff --git a/xfce-extra/thunar-vfs/ChangeLog b/xfce-extra/thunar-vfs/ChangeLog
new file mode 100644
index 000000000000..e6bccd382137
--- /dev/null
+++ b/xfce-extra/thunar-vfs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for xfce-extra/thunar-vfs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/ChangeLog,v 1.1 2010/03/24 20:05:06 ssuominen Exp $
+
+*thunar-vfs-0_p20100324 (24 Mar 2010)
+
+ 24 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +thunar-vfs-0_p20100324.ebuild:
+ Initial commit of transition package. Separate Thunar VFS libraries from
+ Thunar 1.0.1 to be used with unported applications.
+
diff --git a/xfce-extra/thunar-vfs/metadata.xml b/xfce-extra/thunar-vfs/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/thunar-vfs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild b/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild
new file mode 100644
index 000000000000..2473886d7080
--- /dev/null
+++ b/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild,v 1.1 2010/03/24 20:05:06 ssuominen Exp $
+
+EAPI=2
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="Transition package - Thunar VFS libraries for unported Xfce4 apps"
+HOMEPAGE="http://git.xfce.org/xfce/thunar-vfs/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug doc gnome hal startup-notification"
+
+RDEPEND=">=xfce-base/exo-0.5.1
+ >=dev-libs/glib-2.12:2
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=media-libs/libpng-1.2
+ >=media-libs/freetype-2
+ >=media-libs/jpeg-6b:0
+ dbus? ( dev-libs/dbus-glib )
+ gnome? ( >=gnome-base/gconf-2 )
+ hal? ( >=dev-libs/dbus-glib-0.34
+ sys-apps/hal )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ !<xfce-base/thunar-1.1.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ dev-lang/perl
+ dev-util/gtk-doc-am
+ doc? ( dev-libs/libxslt )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+ XFCONF="--enable-maintainer-mode
+ --disable-dependency-tracking
+ $(use_enable dbus)
+ $(use_enable gnome gnome-thumbnailers)
+ $(use_enable startup-notification)
+ $(use_enable doc xsltproc)
+ $(use_enable debug)
+ --with-html-dir=/usr/share/doc/${PF}/html"
+
+ if use hal; then
+ XFCONF="${XFCONF} --enable-dbus --with-volume-manager=hal"
+ else
+ XFCONF="${XFCONF} --with-volume-manager=none"
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^docdir/s:=.*:= /usr/share/doc/${PF}:" \
+ docs/Makefile.am || die
+
+ xfconf_src_prepare
+}