summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-25 08:52:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-25 08:52:26 +0000
commit5887528145b8101282feeaa506acbea5a4a25e2a (patch)
tree576435c996c8b426711009ed91fd8827bfbae876 /xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
parentInstall a simple fenv.h for newer gcc versions #266298 by Antonio Pezo. (diff)
downloadgentoo-2-5887528145b8101282feeaa506acbea5a4a25e2a.tar.gz
gentoo-2-5887528145b8101282feeaa506acbea5a4a25e2a.tar.bz2
gentoo-2-5887528145b8101282feeaa506acbea5a4a25e2a.zip
Rename xfce4-genmon to xfce4-genmon-plugin.
(Portage version: 2.2_rc40/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
new file mode 100644
index 000000000000..d67e0f41baff
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild,v 1.1 2009/08/25 08:52:26 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Cyclically spawns the executable, captures its output and displays the result into the panel."
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/3.2/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/xfce4-panel-4.3.22"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog README"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}