summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-12 16:24:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-12 16:24:32 +0000
commitd866efee4676d9cce924d7d9caa8ebef4d9a0c2c (patch)
tree1321ea5013a6ee3cc5bfb37f24f5de7d079452ca /xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild
parentStable on alpha, bug #394201 (diff)
downloadgentoo-2-d866efee4676d9cce924d7d9caa8ebef4d9a0c2c.tar.gz
gentoo-2-d866efee4676d9cce924d7d9caa8ebef4d9a0c2c.tar.bz2
gentoo-2-d866efee4676d9cce924d7d9caa8ebef4d9a0c2c.zip
Version bump.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild
new file mode 100644
index 000000000000..69b4e0674fab
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.4.0.ebuild,v 1.1 2012/05/12 16:24:32 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Cyclically spawns the executable, captures its output and displays the result into the panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${PV%.*}
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}