summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-11-24 11:36:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-11-24 11:36:22 +0000
commit4356170f7c1c542bc542ab113ccb23651c2d5680 (patch)
tree07f812bd1db330f2cd652963598b040ce2c81d43 /xfce-extra
parentppc stable wrt bug #458122 (diff)
downloadgentoo-2-4356170f7c1c542bc542ab113ccb23651c2d5680.tar.gz
gentoo-2-4356170f7c1c542bc542ab113ccb23651c2d5680.tar.bz2
gentoo-2-4356170f7c1c542bc542ab113ccb23651c2d5680.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild41
2 files changed, 49 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/ChangeLog b/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
index 60005facaa4e..bafd562eae01 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
+++ b/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-mailwatch-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/ChangeLog,v 1.15 2012/12/26 11:07:15 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/ChangeLog,v 1.16 2013/11/24 11:36:22 ssuominen Exp $
+
+*xfce4-mailwatch-plugin-1.2.0 (24 Nov 2013)
+
+ 24 Nov 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-mailwatch-plugin-1.2.0.ebuild:
+ Version bump.
26 Dec 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-mailwatch-plugin-1.1.0-r1.ebuild:
@@ -68,4 +74,3 @@
+xfce4-mailwatch-plugin-1.1.0.ebuild,
+files/xfce4-mailwatch-plugin-1.1.0-no-ssl.patch:
Rename xfce4-mailwatch to xfce4-mailwatch-plugin.
-
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild
new file mode 100644
index 000000000000..53c1b9f3f143
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild,v 1.1 2013/11/24 11:36:22 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ >=xfce-base/exo-0.7.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ ssl? (
+ dev-libs/libgcrypt
+ >=net-libs/gnutls-2
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable ssl)
+ $(use_enable ipv6)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}