summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-12 19:58:17 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-12 19:58:17 +0000
commit70020675bba5b82bf34fe4c2d8d81f687770cbf5 (patch)
treed7b7701ee69fb8d178e384401c8f17cb949b7aef /xfce-extra
parentRemove old. (diff)
downloadgentoo-2-70020675bba5b82bf34fe4c2d8d81f687770cbf5.tar.gz
gentoo-2-70020675bba5b82bf34fe4c2d8d81f687770cbf5.tar.bz2
gentoo-2-70020675bba5b82bf34fe4c2d8d81f687770cbf5.zip
Version bump with minor fixes.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-verve-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-1.0.1.ebuild35
2 files changed, 43 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-verve-plugin/ChangeLog b/xfce-extra/xfce4-verve-plugin/ChangeLog
index 35dbf6b1f3db..aa2d6e844602 100644
--- a/xfce-extra/xfce4-verve-plugin/ChangeLog
+++ b/xfce-extra/xfce4-verve-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-verve-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-verve-plugin/ChangeLog,v 1.16 2012/11/28 12:23:22 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-verve-plugin/ChangeLog,v 1.17 2015/04/12 19:58:17 mgorny Exp $
+
+*xfce4-verve-plugin-1.0.1 (12 Apr 2015)
+
+ 12 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-verve-plugin-1.0.1.ebuild:
+ Version bump with minor fixes.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-verve-plugin-1.0.0.ebuild:
@@ -71,4 +77,3 @@
25 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-verve-plugin-0.3.6.ebuild:
Rename xfce4-verve to xfce4-verve-plugin.
-
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-1.0.1.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-1.0.1.ebuild
new file mode 100644
index 000000000000..4954c23aabac
--- /dev/null
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-1.0.1.ebuild,v 1.1 2015/04/12 19:58:17 mgorny Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A comfortable command line plugin for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND=">=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/libxfcegui4-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=
+ dev-libs/glib:2=
+ >=dev-libs/libpcre-5:=
+ dbus? ( >=dev-libs/dbus-glib-0.98:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable dbus)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}