summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/commoncpp2/ChangeLog9
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild31
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild63
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild66
-rw-r--r--dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch29
-rw-r--r--dev-cpp/commoncpp2/files/1.5.7-as-needed.patch22
-rw-r--r--dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch29
-rw-r--r--dev-cpp/commoncpp2/files/ccext2-as-needed.diff22
-rw-r--r--dev-cpp/commoncpp2/files/ccgnu2-as-needed.diff11
9 files changed, 8 insertions, 274 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index c5954c519782..7a24d0e20f65 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.40 2008/02/17 12:46:47 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.41 2008/03/04 07:31:37 dev-zero Exp $
+
+ 04 Mar 2008; Tiziano Müller <dev-zero@gentoo.org>
+ -files/1.5.7-as-needed.patch, -files/1.5.7-ssl_config.patch,
+ -files/1.5.1-ssl_config.patch, -files/ccext2-as-needed.diff,
+ -files/ccgnu2-as-needed.diff, -commoncpp2-1.3.1.ebuild,
+ -commoncpp2-1.5.1-r1.ebuild, -commoncpp2-1.5.7.ebuild:
+ Dropped old versions (including patches).
17 Feb 2008; Christoph Mende <angelos@gentoo.org> commoncpp2-1.6.1.ebuild:
Stable on amd64, bug #207632
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild
deleted file mode 100644
index 88751c4b079a..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild,v 1.3 2006/04/09 04:20:37 halcy0n Exp $
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://sourceforge/cplusplus/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="doc xml"
-
-DEPEND="xml? ( >=dev-libs/libxml2-2.6.19 )"
-
-src_compile() {
- econf $(use_with xml) || die "./configure failed"
-
- emake || die
-}
-
-src_install () {
- einstall || die
-
- dodoc AUTHORS INSTALL NEWS ChangeLog README\
- THANKS TODO COPYING COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
deleted file mode 100644
index 411a275a3bcd..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild,v 1.5 2006/11/05 22:49:57 lu_zero Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://sourceforge/gnutelephony/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="debug doc examples ipv6 gnutls"
-
-RDEPEND="gnutls? ( dev-libs/libgcrypt
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/ccext2-as-needed.diff"
- epatch "${FILESDIR}/ccgnu2-as-needed.diff"
- epatch "${FILESDIR}/${PV}-ssl_config.patch"
- eautoconf
-}
-
-src_compile() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
- if use gnutls ; then
- myconf="--with-gnutls"
- else
- myconf="--with-openssl"
- fi
- econf \
- $(use_enable debug) \
- $(use_with ipv6 ) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild
deleted file mode 100644
index dc5ccba044ac..000000000000
--- a/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.7.ebuild,v 1.5 2007/08/16 09:52:51 dertobi123 Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
-SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/commoncpp/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE="debug doc examples ipv6 gnutls"
-
-RDEPEND="gnutls? ( dev-libs/libgcrypt
- net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}-as-needed.patch"
- epatch "${FILESDIR}/${PV}-ssl_config.patch"
- AT_M4DIR="m4"
- eautoreconf
-}
-
-src_compile() {
- use doc || \
- sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
-
- local myconf
- use gnutls || myconf="--with-openssl"
-
- econf \
- $(use_enable debug) \
- $(use_with ipv6 ) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
-
- # Only install html docs
- # man and latex available, but seems a little wasteful
- use doc && dohtml doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- cd demo
- doins *.cpp *.h *.xml README
- fi
-}
-
-# Some of the tests hang forever
-#src_test() {
-# cd "${S}/tests"
-# emake || die "emake tests failed"
-# ./test.sh || die "tests failed"
-#}
diff --git a/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch b/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch
deleted file mode 100644
index 675e99960721..000000000000
--- a/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.ac.orig 2006-10-22 18:02:57.000000000 +0200
-+++ configure.ac 2006-10-22 18:06:17.000000000 +0200
-@@ -247,6 +247,7 @@
- ost_cv_extras=yes
- AC_DEFINE(HAVE_EXTRAS, [1], [Enable extras])
-
-+ AC_ARG_WITH(gnutls, [ --with-gnutls Enable gnutls support], [
- AC_CHECK_HEADER(gnutls/gnutls.h,[
- AC_CHECK_LIB(gnutls, gnutls_init, [
- SSL_LIBS="-lgnutls -lgcrypt"
-@@ -254,13 +255,12 @@
- AC_DEFINE(CCXX_SSL, [GNUTLS], [defines ssl])
- AC_DEFINE(CCXX_GNUTLS, [1], [define gnutls])
- ])
--
-- ],[
-- AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
-- [OST_LIB_SSL],
-- [OST_LIB_NOSSL])
-+ ],[])
-+ ], [
-+ AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
-+ [OST_LIB_SSL],
-+ [OST_LIB_NOSSL])
- ])
--
- AC_ARG_WITH(compression, [ --without-compression Disable libz compression],
- [OST_LIB_NOZLIB],
- [OST_LIB_ZLIB])
diff --git a/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch b/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch
deleted file mode 100644
index db59ff6e9c44..000000000000
--- a/dev-cpp/commoncpp2/files/1.5.7-as-needed.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur commoncpp2-1.5.7.orig/src/Makefile.am commoncpp2-1.5.7/src/Makefile.am
---- commoncpp2-1.5.7.orig/src/Makefile.am 2007-06-16 15:23:05.000000000 +0200
-+++ commoncpp2-1.5.7/src/Makefile.am 2007-06-16 15:23:32.000000000 +0200
-@@ -32,7 +32,7 @@
- scriptdir = $(bindir)
- script_DATA = ccgnu2-config
-
--libccgnu2_la_LIBADD = @THREAD_LIBS@
-+libccgnu2_la_LIBADD = @THREAD_LIBS@ @DYN_LOADER@
- libccgnu2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
- noinst_DATA = @STAGE2@
-
-@@ -45,7 +45,8 @@
- cidr.cpp private.h nat.h
-
- if EXTRAS
--libccext2_la_LDFLAGS = @BASE_LIB@ @THREAD_LIBS@ @SSL_LIBS@ @ZSTREAM_LIBS@ $(RELEASE) $(SHARED_FLAGS)
-+libccext2_la_LIBADD = @THREAD_LIBS@ @BASE_LIB@ @SSL_LIBS@ @ZSTREAM_LIBS@ libccgnu2.la
-+libccext2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
-
- if GETOPT_LONG
- optincludedir=$(includedir)/cc++2
diff --git a/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch b/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch
deleted file mode 100644
index 675e99960721..000000000000
--- a/dev-cpp/commoncpp2/files/1.5.7-ssl_config.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.ac.orig 2006-10-22 18:02:57.000000000 +0200
-+++ configure.ac 2006-10-22 18:06:17.000000000 +0200
-@@ -247,6 +247,7 @@
- ost_cv_extras=yes
- AC_DEFINE(HAVE_EXTRAS, [1], [Enable extras])
-
-+ AC_ARG_WITH(gnutls, [ --with-gnutls Enable gnutls support], [
- AC_CHECK_HEADER(gnutls/gnutls.h,[
- AC_CHECK_LIB(gnutls, gnutls_init, [
- SSL_LIBS="-lgnutls -lgcrypt"
-@@ -254,13 +255,12 @@
- AC_DEFINE(CCXX_SSL, [GNUTLS], [defines ssl])
- AC_DEFINE(CCXX_GNUTLS, [1], [define gnutls])
- ])
--
-- ],[
-- AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
-- [OST_LIB_SSL],
-- [OST_LIB_NOSSL])
-+ ],[])
-+ ], [
-+ AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
-+ [OST_LIB_SSL],
-+ [OST_LIB_NOSSL])
- ])
--
- AC_ARG_WITH(compression, [ --without-compression Disable libz compression],
- [OST_LIB_NOZLIB],
- [OST_LIB_ZLIB])
diff --git a/dev-cpp/commoncpp2/files/ccext2-as-needed.diff b/dev-cpp/commoncpp2/files/ccext2-as-needed.diff
deleted file mode 100644
index 72e0d48f4e4c..000000000000
--- a/dev-cpp/commoncpp2/files/ccext2-as-needed.diff
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Makefile.am.orig 2006-06-04 15:45:19.000000000 +0200
-+++ src/Makefile.am 2006-06-04 15:46:10.000000000 +0200
-@@ -45,7 +45,7 @@
- private.h nat.h
-
- if EXTRAS
--libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@
-+libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@ @ZSTREAM_LIBS@ $(SSL_LIBS)
- libccext2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
-
- if GETOPT_LONG
---- src/Makefile.in.orig 2006-06-04 15:45:26.000000000 +0200
-+++ src/Makefile.in 2006-06-04 15:46:36.000000000 +0200
-@@ -327,7 +327,7 @@
- nat.cpp runlist.cpp assoc.cpp pointer.cpp linked.cpp map.cpp \
- private.h nat.h
-
--@EXTRAS_TRUE@libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@
-+@EXTRAS_TRUE@libccext2_la_LIBADD = @BASE_LIB@ @THREAD_LIBS@ @ZSTREAM_LIBS@ $(SSL_LIBS)
- @EXTRAS_TRUE@libccext2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
- @EXTRAS_TRUE@@GETOPT_LONG_TRUE@optincludedir = $(includedir)/cc++2
- @EXTRAS_TRUE@@GETOPT_LONG_TRUE@optinclude_HEADERS = getopt.h
diff --git a/dev-cpp/commoncpp2/files/ccgnu2-as-needed.diff b/dev-cpp/commoncpp2/files/ccgnu2-as-needed.diff
deleted file mode 100644
index cb97431587cd..000000000000
--- a/dev-cpp/commoncpp2/files/ccgnu2-as-needed.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2006-11-05 20:29:10.000000000 +0100
-+++ src/Makefile.in 2006-11-05 20:29:25.000000000 +0100
-@@ -313,7 +313,7 @@
- aclocal_DATA = ost_check2.m4
- scriptdir = $(bindir)
- script_DATA = ccgnu2-config
--libccgnu2_la_LIBADD = @THREAD_LIBS@
-+libccgnu2_la_LIBADD = @THREAD_LIBS@ @DYN_LOADER@
- libccgnu2_la_LDFLAGS = $(RELEASE) $(SHARED_FLAGS)
- noinst_DATA = @STAGE2@
- libccgnu2_la_SOURCES = thread.cpp mutex.cpp semaphore.cpp threadkey.cpp \