summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/libpq/ChangeLog8
-rw-r--r--dev-db/libpq/files/libpq-8.3.1-gentoo.patch45
-rw-r--r--dev-db/libpq/libpq-8.3.1.ebuild112
3 files changed, 6 insertions, 159 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index 6a3af87970d7..9c9839241297 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libpq
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.148 2008/08/05 16:19:03 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.149 2009/04/09 22:48:37 caleb Exp $
+
+ 09 Apr 2009; Caleb Tennis <caleb@gentoo.org>
+ -files/libpq-8.3.1-gentoo.patch, -libpq-8.3.1.ebuild:
+ remove 8.3, use postgresql-{base,server} if you want it instead
05 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/dev-db/libpq/files/libpq-8.3.1-gentoo.patch b/dev-db/libpq/files/libpq-8.3.1-gentoo.patch
deleted file mode 100644
index 0b87648626b8..000000000000
--- a/dev-db/libpq/files/libpq-8.3.1-gentoo.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- postgresql-8.3RC1.orig/src/interfaces/libpq/Makefile 2006-12-28 01:01:12.000000000 +0100
-+++ postgresql-8.3RC1/src/interfaces/libpq/Makefile 2007-03-29 10:24:27.000000000 +0200
-@@ -20,6 +20,8 @@
- SO_MINOR_VERSION= 0
- DLTYPE= library
-
-+NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
-+
- override CPPFLAGS := -DFRONTEND -I$(srcdir) $(CPPFLAGS) -I$(top_builddir)/src/port
- ifneq ($(PORTNAME), win32)
- override CFLAGS += $(PTHREAD_CFLAGS)
-@@ -160,7 +162,7 @@
- $(INSTALL_DATA) $(srcdir)/libpq-fe.h '$(DESTDIR)$(includedir)'
- $(INSTALL_DATA) $(srcdir)/libpq-int.h '$(DESTDIR)$(includedir_internal)'
- $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h '$(DESTDIR)$(includedir_internal)'
-- $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample '$(DESTDIR)$(datadir)/pg_service.conf.sample'
-+ $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample '$(DESTDIR)$(datadir)/pg_service-$(SO_MAJOR_VERSION).conf.sample'
-
- installdirs:
- $(mkinstalldirs) '$(DESTDIR)$(libdir)' '$(DESTDIR)$(includedir)' '$(DESTDIR)$(includedir_internal)'
---- postgresql-8.3RC1.orig/src/interfaces/libpq/nls.mk 2005-01-14 09:57:06.000000000 +0100
-+++ postgresql-8.3RC1/src/interfaces/libpq/nls.mk 2007-03-29 10:24:55.000000000 +0200
-@@ -1,5 +1,5 @@
- # $PostgreSQL: pgsql/src/interfaces/libpq/nls.mk,v 1.21 2007/10/27 00:13:43 petere Exp $
--CATALOG_NAME := libpq
-+CATALOG_NAME := libpq-4
- AVAIL_LANGUAGES := af cs de es fr hr it ko nb pl pt_BR ru sk sl sv ta tr zh_CN zh_TW
- GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-protocol2.c fe-protocol3.c fe-secure.c
- GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
---- postgresql-8.3RC1.orig/src/Makefile.shlib 2006-09-19 17:36:07.000000000 +0200
-+++ postgresql-8.3RC1/src/Makefile.shlib 2007-03-29 10:28:42.000000000 +0200
-@@ -346,10 +346,10 @@
- install-lib: install-lib-static install-lib-shared
-
- install-lib-static: lib$(NAME).a
-- $(INSTALL_STLIB) $< '$(DESTDIR)$(libdir)/lib$(NAME).a'
-+ $(INSTALL_STLIB) $< '$(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a'
- ifeq ($(PORTNAME), darwin)
- cd '$(DESTDIR)$(libdir)' && \
-- ranlib lib$(NAME).a
-+ ranlib lib$(NAME_STATIC_LIB).a
- endif
-
- ifeq ($(enable_shared), yes)
-
diff --git a/dev-db/libpq/libpq-8.3.1.ebuild b/dev-db/libpq/libpq-8.3.1.ebuild
deleted file mode 100644
index fcb73304f182..000000000000
--- a/dev-db/libpq/libpq-8.3.1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-8.3.1.ebuild,v 1.3 2008/05/19 19:19:30 dev-zero Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-DESCRIPTION="PostgreSQL libraries."
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-SLOT="4"
-IUSE="debug kerberos nls pam pg-intdatetime readline ssl threads zlib"
-
-RDEPEND="!<=dev-db/postgresql-8.1.4
- kerberos? ( virtual/krb5 )
- pam? ( virtual/pam )
- readline? ( >=sys-libs/readline-4.1 )
- ssl? ( >=dev-libs/openssl-0.9.6-r1 )
- zlib? ( >=sys-libs/zlib-1.1.3 )
- !dev-db/postgresql-base"
-DEPEND="${RDEPEND}
- sys-devel/autoconf
- >=sys-devel/bison-1.875
- nls? ( sys-devel/gettext )"
-
-S="${WORKDIR}/postgresql-${PV}"
-
-pkg_preinst() {
- # Removing wrong symlink created by previous ebuild
- if [[ -L "${ROOT}/usr/include/libpq" ]] ; then
- rm -f "${ROOT}/usr/include/libpq"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-${PV}-gentoo.patch"
-}
-
-src_compile() {
- filter-flags -ffast-math -feliminate-dwarf2-dups
-
- econf --prefix=/usr \
- --includedir=/usr/include/postgresql/libpq-${SLOT} \
- --sysconfdir=/etc/postgresql \
- --mandir=/usr/share/man \
- --host=${CHOST} \
- --with-docdir=/usr/share/doc/${PF} \
- --libdir=/usr/$(get_libdir) \
- --enable-depend \
- $(use_enable debug) \
- $(use_with kerberos krb5) \
- $(use_enable nls ) \
- $(use_with pam) \
- --without-perl \
- $(use_enable pg-intdatetime integer-datetimes ) \
- --without-python \
- $(use_with readline) \
- $(use_with ssl openssl) \
- --without-tcl \
- $(use_enable threads thread-safety ) \
- $(use_with zlib) \
- || die "configure failed"
-
- cd "${S}/src/interfaces/libpq"
- emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake libpq failed"
-
- cd "${S}/src/bin/pg_config"
- emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake pg_config failed"
-}
-
-src_install() {
- cd "${S}/src/interfaces/libpq"
- emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "emake install libpq failed"
-
- cd "${S}/src/include"
- emake DESTDIR="${D}" install || die "emake install headers failed"
-
- cd "${S}/src/bin/pg_config"
- emake DESTDIR="${D}" install || die "emake install pg_config failed"
-
- cd "${S}"
- dodoc README HISTORY
-
- dosym libpq-${SLOT}.a /usr/$(get_libdir)/libpq.a
-
- for f in $(ls -1 "${D}"/usr/include/postgresql/libpq-${SLOT}/*.h) ; do
- dosym postgresql/libpq-${SLOT}/$(basename ${f}) /usr/include/
- done
-
- dodir /usr/include/libpq
- for f in $(ls -1 "${D}"/usr/include/postgresql/libpq-${SLOT}/libpq/*.h) ; do
- dosym ../postgresql/libpq-${SLOT}/libpq/$(basename ${f}) /usr/include/libpq/
- done
-
- cd "${D}/usr/include/postgresql/libpq-${SLOT}"
- for f in $(find * -name '*.h' -print) ; do
- destdir=$(dirname ${f})
- if [[ ! -d "${D}/usr/include/postgresql/${destdir}" ]] ; then
- dodir "/usr/include/postgresql/${destdir}"
- fi
- dosym /usr/include/postgresql/libpq-${SLOT}/${f} "/usr/include/postgresql/${destdir}/"
- done
-}
-
-src_test() {
- einfo "No tests available for libpq."
-}