summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass13
2 files changed, 11 insertions, 8 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index e6ec78b646ce..7c501163b8c1 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.783 2013/04/10 15:38:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.784 2013/04/13 14:01:10 mgorny Exp $
+
+ 13 Apr 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Unmask the egg_info block for further testing. Feel free to comment it out if
+ you can reproduce the earlier issues.
10 Apr 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
Move the egg_info code into a more realistic location for future testing.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index c50784625c1f..c3d15cdaeb6a 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.67 2013/04/10 15:38:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.68 2013/04/13 14:01:10 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -242,12 +242,11 @@ esetup.py() {
)
# if setuptools is used, adjust egg_info path as well
- # (disabled since it causes build not to install scripts)
-# if "${PYTHON:-python}" setup.py --help egg_info &>/dev/null; then
-# add_args+=(
-# egg_info --egg-base "${BUILD_DIR}"
-# )
-# fi
+ if "${PYTHON:-python}" setup.py --help egg_info &>/dev/null; then
+ add_args+=(
+ egg_info --egg-base "${BUILD_DIR}"
+ )
+ fi
elif [[ ! ${DISTUTILS_IN_SOURCE_BUILD} ]]; then
die 'Out-of-source build requested, yet BUILD_DIR unset.'
fi