summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/calise/ChangeLog11
-rw-r--r--x11-misc/calise/calise-0.4.2.ebuild58
-rw-r--r--x11-misc/calise/metadata.xml9
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/calise/ChangeLog b/x11-misc/calise/ChangeLog
new file mode 100644
index 000000000000..e5a057162a99
--- /dev/null
+++ b/x11-misc/calise/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/calise
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/calise/ChangeLog,v 1.1 2014/05/14 14:17:10 tomwij Exp $
+
+*calise-0.4.2 (14 May 2014)
+
+ 14 May 2014; Tom Wijsman <TomWij@gentoo.org> +calise-0.4.2.ebuild,
+ +metadata.xml:
+ New ebuild for x11-misc/calise, computes ambient brightness and sets screen's
+ correct backlight using a webcam; fixes bug #501088, contributed by Hello71
+ who will proxy maintain this package.
diff --git a/x11-misc/calise/calise-0.4.2.ebuild b/x11-misc/calise/calise-0.4.2.ebuild
new file mode 100644
index 000000000000..aa4e2c5ad2bc
--- /dev/null
+++ b/x11-misc/calise/calise-0.4.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/calise/calise-0.4.2.ebuild,v 1.1 2014/05/14 14:17:10 tomwij Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+inherit distutils-r1 linux-info systemd
+
+DESCRIPTION="Computes ambient brightness and sets screen's correct backlight using a webcam"
+HOMEPAGE="http://calise.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/${PN}/files/${PN}-beta/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="${RDEPEND}
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sci-astronomy/pyephem[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme"
+DEPEND="${CDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+ sys-kernel/linux-headers
+ x11-libs/libX11"
+RDEPEND="${CDEPEND}"
+
+CONFIG_CHECK="~BACKLIGHT_CLASS_DEVICE"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Add missing trailing ; to desktop file.
+ sed -i 's/^\(Categories=Utility\)$/\1;/' \
+ share/applications/calise.desktop.in || die
+
+ # Fix up bashisms.
+ sed -i 's:&>/dev/null:2>\&1 >/dev/null:' \
+ other/init_scripts/init.d/${PN}d || die
+}
+
+src_install() {
+ doconfd other/init_scripts/conf.d/${PN}d
+ doinitd other/init_scripts/init.d/${PN}d
+ systemd_dounit other/systemd_scripts/${PN}d.service
+
+ install -D -m755 other/pm-utils_scripts/53${PN}d "${D}"/usr/lib/pm-utils/sleep.d/53${PN}d
+
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ einfo "Optional runtime dependency: dev-python/PyQt4 for GUI"
+}
diff --git a/x11-misc/calise/metadata.xml b/x11-misc/calise/metadata.xml
new file mode 100644
index 000000000000..b6a99d12873d
--- /dev/null
+++ b/x11-misc/calise/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ </maintainer>
+</pkgmetadata>