summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/grub/ChangeLog10
-rw-r--r--sys-boot/grub/files/1.99-call_proper_grub_probe.patch12
-rw-r--r--sys-boot/grub/grub-1.99-r1.ebuild (renamed from sys-boot/grub/grub-1.99.ebuild)5
-rw-r--r--sys-boot/grub/grub-9999.ebuild5
4 files changed, 29 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index be6a3aca03d9..a0d48a06dc98 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.160 2011/08/28 10:30:23 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.161 2011/08/28 10:50:33 scarabeus Exp $
+
+*grub-1.99-r1 (28 Aug 2011)
+
+ 28 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.99-call_proper_grub_probe.patch, -grub-1.99.ebuild,
+ +grub-1.99-r1.ebuild, grub-9999.ebuild:
+ Fix hardcoded grub-probe call. Fixes bug #380879. Revision bump so everyone
+ gets the update.
28 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org> grub-1.99.ebuild,
grub-9999.ebuild, metadata.xml:
diff --git a/sys-boot/grub/files/1.99-call_proper_grub_probe.patch b/sys-boot/grub/files/1.99-call_proper_grub_probe.patch
new file mode 100644
index 000000000000..6d65b5f85d3b
--- /dev/null
+++ b/sys-boot/grub/files/1.99-call_proper_grub_probe.patch
@@ -0,0 +1,12 @@
+diff -urN grub-1.99/util/grub.d/30_os-prober.in grub-1.99.new/util/grub.d/30_os-prober.in
+--- grub-1.99/util/grub.d/30_os-prober.in 2010-12-25 18:13:57.000000000 +0100
++++ grub-1.99.new/util/grub.d/30_os-prober.in 2011-08-28 12:35:40.965038455 +0200
+@@ -168,7 +168,7 @@
+ done
+ ;;
+ macosx)
+- OSXUUID="`grub-probe --target=fs_uuid --device ${DEVICE} 2> /dev/null`"
++ OSXUUID="`${grub_probe} --target=fs_uuid --device ${DEVICE} 2> /dev/null`"
+ osx_entry xnu_kernel 32
+ osx_entry xnu_kernel64 64
+ ;;
diff --git a/sys-boot/grub/grub-1.99.ebuild b/sys-boot/grub/grub-1.99-r1.ebuild
index f0a4f6585ae4..f6142f833214 100644
--- a/sys-boot/grub/grub-1.99.ebuild
+++ b/sys-boot/grub/grub-1.99-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99.ebuild,v 1.2 2011/08/28 10:30:23 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r1.ebuild,v 1.1 2011/08/28 10:50:33 scarabeus Exp $
EAPI=4
@@ -156,6 +156,9 @@ grub_src_install() {
src_prepare() {
local i j archs
+ epatch \
+ "${FILESDIR}/1.99-call_proper_grub_probe.patch"
+
epatch_user
# autogen.sh does more than just run autotools
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index ba66a77dfe06..d379c1baca06 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.38 2011/08/28 10:30:23 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.39 2011/08/28 10:50:33 scarabeus Exp $
EAPI=4
@@ -156,6 +156,9 @@ grub_src_install() {
src_prepare() {
local i j archs
+ epatch \
+ "${FILESDIR}/1.99-call_proper_grub_probe.patch"
+
epatch_user
# autogen.sh does more than just run autotools