summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-apps/xedit/ChangeLog5
-rw-r--r--x11-apps/xedit/xedit-0.99.0.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/x11-apps/xedit/ChangeLog b/x11-apps/xedit/ChangeLog
index c2b8babed41a..6eb5031a028a 100644
--- a/x11-apps/xedit/ChangeLog
+++ b/x11-apps/xedit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-apps/xedit
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.2 2005/08/08 20:14:19 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.3 2005/08/22 06:12:45 spyderous Exp $
+
+ 22 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; xedit-0.99.0.ebuild:
+ Broken without xprint.
08 Aug 2005; Ferris McCormick <fmccor@gentoo.org> xedit-0.99.0.ebuild:
Add ~sparc keyword (Modular X testing).
diff --git a/x11-apps/xedit/xedit-0.99.0.ebuild b/x11-apps/xedit/xedit-0.99.0.ebuild
index 5c0c38aad145..eaf48586d442 100644
--- a/x11-apps/xedit/xedit-0.99.0.ebuild
+++ b/x11-apps/xedit/xedit-0.99.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-0.99.0.ebuild,v 1.2 2005/08/08 20:14:19 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-0.99.0.ebuild,v 1.3 2005/08/22 06:12:45 spyderous Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -9,15 +9,22 @@ inherit x-modular
DESCRIPTION="X.Org xedit application"
KEYWORDS="~sparc ~x86"
-IUSE="xprint"
-RDEPEND="xprint? ( x11-libs/libXprintUtil )
+#IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
x11-libs/libXaw"
+#xprint? ( x11-libs/libXprintUtil )
DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable xprint)"
+#CONFIGURE_OPTIONS="$(use_enable xprint)"
pkg_setup() {
- if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+# if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ if ! built_with_use x11-libs/libXaw xprint; then
die "Build x11-libs/libXaw with USE=xprint."
fi
}
+
+src_compile() {
+ x-modular_src_configure
+ emake -j1 || die "emake failed"
+}