summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-dotnet/ipod-sharp/ChangeLog9
-rw-r--r--dev-dotnet/ipod-sharp/ipod-sharp-0.8.5.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-dotnet/ipod-sharp/ChangeLog b/dev-dotnet/ipod-sharp/ChangeLog
index 8dc8c07417f3..6f2efaf592fa 100644
--- a/dev-dotnet/ipod-sharp/ChangeLog
+++ b/dev-dotnet/ipod-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/ipod-sharp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ChangeLog,v 1.26 2009/07/19 14:28:58 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ChangeLog,v 1.27 2010/01/16 22:12:26 pacho Exp $
+
+*ipod-sharp-0.8.5 (16 Jan 2010)
+
+ 16 Jan 2010; Pacho Ramos <pacho@gentoo.org> +ipod-sharp-0.8.5.ebuild:
+ Version bump, bug fixes and needed by latest Banshee
*ipod-sharp-0.8.2-r1 (19 Jul 2009)
diff --git a/dev-dotnet/ipod-sharp/ipod-sharp-0.8.5.ebuild b/dev-dotnet/ipod-sharp/ipod-sharp-0.8.5.ebuild
new file mode 100644
index 000000000000..cf51e9390024
--- /dev/null
+++ b/dev-dotnet/ipod-sharp/ipod-sharp-0.8.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ipod-sharp/ipod-sharp-0.8.5.ebuild,v 1.1 2010/01/16 22:12:26 pacho Exp $
+
+EAPI=2
+inherit eutils mono
+
+DESCRIPTION="ipod-sharp provides high-level feature support for Apple's iPod and binds libipoddevice."
+HOMEPAGE="http://banshee-project.org/Ipod-sharp"
+SRC_URI="http://banshee-project.org/files/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-2
+ dev-dotnet/dbus-glib-sharp
+ >=dev-dotnet/podsleuth-0.6.4
+ >=dev-dotnet/gtk-sharp-2.12"
+DEPEND="${RDEPEND}
+ doc? ( >=virtual/monodoc-1.1.8 )
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+ mono_multilib_comply
+}