summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/bashburn/ChangeLog6
-rw-r--r--app-cdr/bashburn/bashburn-1.3.ebuild19
-rw-r--r--net-misc/aria/ChangeLog6
-rw-r--r--net-misc/aria/aria-0.10.0.ebuild23
-rw-r--r--net-misc/aria/aria-0.10.2_beta7.ebuild26
-rw-r--r--net-misc/aria/aria-1.0.0.ebuild11
6 files changed, 44 insertions, 47 deletions
diff --git a/app-cdr/bashburn/ChangeLog b/app-cdr/bashburn/ChangeLog
index 6d67f6ce536e..1e60e6af3a8c 100644
--- a/app-cdr/bashburn/ChangeLog
+++ b/app-cdr/bashburn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-cdr/bashburn
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/bashburn/ChangeLog,v 1.2 2004/03/14 22:11:28 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/bashburn/ChangeLog,v 1.3 2004/03/17 08:12:46 seemant Exp $
+
+ 17 Mar 2004; Seemant Kulleen <seemant@gentoo.org> bashburn-1.3.ebuild:
+ fix for bug #44712 by Michael Sterret <mr_bones_@gentoo.org> and also switch
+ to econf and einstall and actually USE the USE flags
14 Mar 2004; Jason Wever <weeve@gentoo.org> bashburn-1.3.ebuild:
Added ~sparc keyword.
diff --git a/app-cdr/bashburn/bashburn-1.3.ebuild b/app-cdr/bashburn/bashburn-1.3.ebuild
index f1b4c62ab7b9..f061908dba2b 100644
--- a/app-cdr/bashburn/bashburn-1.3.ebuild
+++ b/app-cdr/bashburn/bashburn-1.3.ebuild
@@ -1,17 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/bashburn/bashburn-1.3.ebuild,v 1.2 2004/03/14 22:11:28 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/bashburn/bashburn-1.3.ebuild,v 1.3 2004/03/17 08:12:46 seemant Exp $
-P=${P/bashburn/BashBurn}
-S=${WORKDIR}/BashBurn
+IUSE=""
+
+MY_P=${P//b/B}
+S=${WORKDIR}/${PN//b/B}
DESCRIPTION="cd burning shell script"
HOMEPAGE="http://bashburn.sourceforge.net"
-SRC_URI="mirror://sourceforge/bashburn/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~sparc"
-IUSE=""
-DEPEND=""
-SLOT="0"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="app-shells/bash"
src_compile() {
echo "Skipping Compile"
diff --git a/net-misc/aria/ChangeLog b/net-misc/aria/ChangeLog
index 45c37c86488a..1645d07c29db 100644
--- a/net-misc/aria/ChangeLog
+++ b/net-misc/aria/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-misc/aria
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/ChangeLog,v 1.11 2004/03/01 21:34:08 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/ChangeLog,v 1.12 2004/03/17 08:08:12 seemant Exp $
+ 17 Mar 2004; Seemant Kulleen <seemant@gentoo.org> aria-0.10.0.ebuild,
+ aria-0.10.2_beta7.ebuild, aria-1.0.0.ebuild:
+ fix for bug #44712 by Michael Sterret <mr_bones_@gentoo.org> and also switch
+ to econf and einstall and actually USE the USE flags
09 Feb 2004; root <root@gentoo.org> aria-0.10.0.ebuild,
aria-0.10.2_beta7.ebuild, aria-1.0.0.ebuild, metadata.xml,
diff --git a/net-misc/aria/aria-0.10.0.ebuild b/net-misc/aria/aria-0.10.0.ebuild
index ccbfde596cdf..d6de1a89a3b4 100644
--- a/net-misc/aria/aria-0.10.0.ebuild
+++ b/net-misc/aria/aria-0.10.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-0.10.0.ebuild,v 1.9 2004/02/09 06:39:48 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-0.10.0.ebuild,v 1.10 2004/03/17 08:08:12 seemant Exp $
IUSE="nls"
S=${WORKDIR}/${P}
-
DESCRIPTION="Aria is a download manager with a GTK+ GUI, it downloads files from Internet via HTTP/HTTPS or FTP."
-SRC_URI="http://aria.rednoah.com/storage/sources/${P}.tar.bz2"
HOMEPAGE="http://aria.rednoah.com"
+SRC_URI="http://aria.rednoah.com/storage/sources/${P}.tar.bz2"
+
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc "
-SLOT="0"
RDEPEND="=dev-libs/glib-1.2*
=x11-libs/gtk+-1.2*
@@ -21,23 +21,14 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext
>=dev-util/intltool-0.11 )"
-
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf \
+ `use_enable nls` || die
emake || die
}
src_install () {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
+ einstall || die
dodoc AUTHORS README* NEWS ChangeLog TODO COPYING
}
-
diff --git a/net-misc/aria/aria-0.10.2_beta7.ebuild b/net-misc/aria/aria-0.10.2_beta7.ebuild
index a34aad82fe76..570d63995251 100644
--- a/net-misc/aria/aria-0.10.2_beta7.ebuild
+++ b/net-misc/aria/aria-0.10.2_beta7.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-0.10.2_beta7.ebuild,v 1.6 2004/02/09 06:39:48 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-0.10.2_beta7.ebuild,v 1.7 2004/03/17 08:08:12 seemant Exp $
IUSE="nls"
-P=`echo ${P} | sed s/_beta/test/g`
-S=${WORKDIR}/${P}
-#A=`echo ${P}.tar.bz2 | sed s/_beta/test/g`
+MY_P=${P/_beta/test}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Aria is a download manager with a GTK+ GUI, it downloads files from Internet via HTTP/HTTPS or FTP."
-SRC_URI="http://aria.rednoah.com/storage/sources/${P}.tar.bz2"
HOMEPAGE="http://aria.rednoah.com"
+SRC_URI="http://aria.rednoah.com/storage/sources/${MY_P}.tar.bz2"
+
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc "
-SLOT="0"
RDEPEND="=dev-libs/glib-1.2*
=x11-libs/gtk+-1.2*
@@ -25,21 +25,13 @@ DEPEND="${RDEPEND}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf \
+ `use_enable nls` || die
emake || die
}
src_install () {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
+ einstall || die
dodoc AUTHORS README* NEWS ChangeLog TODO COPYING
}
-
diff --git a/net-misc/aria/aria-1.0.0.ebuild b/net-misc/aria/aria-1.0.0.ebuild
index 870d9f23fe57..1a97c3a40527 100644
--- a/net-misc/aria/aria-1.0.0.ebuild
+++ b/net-misc/aria/aria-1.0.0.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-1.0.0.ebuild,v 1.2 2004/02/09 06:39:48 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria/aria-1.0.0.ebuild,v 1.3 2004/03/17 08:08:12 seemant Exp $
+IUSE="nls"
+
+S=${WORKDIR}/${P}
DESCRIPTION="Aria is a download manager with a GTK+ GUI, it downloads files from the Internet via HTTP/HTTPS or FTP."
HOMEPAGE="http://aria.rednoah.com"
SRC_URI="http://aria.rednoah.com/storage/sources/${P}.tar.bz2"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="~x86 ~sparc"
-IUSE="nls"
DEPEND="nls? ( sys-devel/gettext dev-util/intltool )
dev-libs/glib
x11-libs/gtk+"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/aria-1.0.0-xgettext-gentoo.diff