summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/chm2pdf/ChangeLog11
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1.ebuild30
-rw-r--r--app-text/chm2pdf/files/tempdir.patch71
-rw-r--r--app-text/chm2pdf/metadata.xml12
4 files changed, 124 insertions, 0 deletions
diff --git a/app-text/chm2pdf/ChangeLog b/app-text/chm2pdf/ChangeLog
new file mode 100644
index 000000000000..76122b67b728
--- /dev/null
+++ b/app-text/chm2pdf/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/chm2pdf
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.1 2009/02/26 11:50:49 hwoarang Exp $
+
+*chm2pdf-0.9.1 (26 Feb 2009)
+
+ 26 Feb 2009; Markos Chandras <hwoarang@gentoo.org> +files/tempdir.patch,
+ +metadata.xml, +chm2pdf-0.9.1.ebuild:
+ Initial import of chm2pdf program. Fixes bug #205208 . Thanks to Milan
+ Nikolic <gen2brain@gmail.com> for the patch
+
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
new file mode 100644
index 000000000000..a2c5a2f5f9c7
--- /dev/null
+++ b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1.ebuild,v 1.1 2009/02/26 11:50:49 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A script that converts a CHM file into a single PDF file."
+HOMEPAGE="http://code.google.com/p/chm2pdf/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pychm
+ app-text/htmldoc
+ dev-libs/chmlib
+ dev-lang/python"
+
+src_prepare(){
+ epatch "${FILESDIR}/tempdir.patch"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to create executable"
+ dodoc README || die "dodoc failed"
+}
diff --git a/app-text/chm2pdf/files/tempdir.patch b/app-text/chm2pdf/files/tempdir.patch
new file mode 100644
index 000000000000..6bb5fe55d00d
--- /dev/null
+++ b/app-text/chm2pdf/files/tempdir.patch
@@ -0,0 +1,71 @@
+--- chm2pdf-0.9.1.orig/chm2pdf 2008-07-09 12:42:26.000000000 +0200
++++ chm2pdf-0.9.1/chm2pdf 2009-02-25 20:58:53.000000000 +0100
+@@ -27,6 +27,8 @@
+ import os, os.path
+ import re, glob
+ import getopt
++import tempfile
++import shutil
+ # from BeautifulSoup import BeautifulSoup
+
+ global version
+@@ -39,8 +41,8 @@
+ global filename #the input filename
+
+ version = '0.9.1'
+-CHM2PDF_TEMP_WORK_DIR='/tmp/chm2pdf/work'
+-CHM2PDF_TEMP_ORIG_DIR='/tmp/chm2pdf/orig'
++CHM2PDF_TEMP_WORK_DIR=tempfile.mkdtemp()
++CHM2PDF_TEMP_ORIG_DIR=tempfile.mkdtemp()
+
+
+
+@@ -299,16 +301,6 @@
+ # ########################### File extraction and correction: START ############################
+ #
+ if options['dontextract'] == '':
+-
+- try:
+- os.mkdir(CHM2PDF_TEMP_WORK_DIR)
+- except OSError: # The directory already exists.
+- pass
+-
+- try:
+- os.mkdir(CHM2PDF_TEMP_ORIG_DIR)
+- except OSError: # The directory already exists.
+- pass
+
+ try:
+ os.mkdir(CHM2PDF_ORIG_DIR)
+@@ -620,7 +612,7 @@
+ print '\t--continuous\n\t\tSpecifies that the HTML sources are unstructured (plain web pages).\n\t\tNo page breaks are inserted between each file or URL in the output.'
+ print '\t--cookies \'name="value with space"; name=value\'\n\t\t'
+ print '\t--datadir directory\n\t\tSpecifies the location of the HTMLDOC data files, usually /usr/share/htmldoc or C:\Program Files\HTMLDOC '
+- print "\t--dontextract \n\t\tIf given, %s will not extract the HTML files from the given CHM file, but will use previously extracted copies from the temporary directory " %name + '(i.e. ' + CHM2PDF_TEMP_ORIG_DIR + ' and ' + CHM2PDF_TEMP_WORK_DIR + '). Usually you will use this option after you have used the \'--extract-only\' option to extract the files in order to correct them manually (in ' + CHM2PDF_TEMP_WORK_DIR + '). After the correction, a call with \'--dontextract\' will not overwrite your changes, but will use the corrected files instead.'
++# print "\t--dontextract \n\t\tIf given, %s will not extract the HTML files from the given CHM file, but will use previously extracted copies from the temporary directory " %name + '(i.e. ' + CHM2PDF_TEMP_ORIG_DIR + ' and ' + CHM2PDF_TEMP_WORK_DIR + '). Usually you will use this option after you have used the \'--extract-only\' option to extract the files in order to correct them manually (in ' + CHM2PDF_TEMP_WORK_DIR + '). After the correction, a call with \'--dontextract\' will not overwrite your changes, but will use the corrected files instead.'
+ print '\t--duplex\n\t\tSpecifies that the output should be formatted for double-sided printing.'
+ print '\t--effectduration {0.1..10.0}\n\t\tSpecifies the duration in seconds of PDF page transition effects.'
+ print '\t--embedfonts\n\t\tSpecifies that fonts should be embedded in PDF output.'
+@@ -1084,13 +1076,6 @@
+ print 'CHM file "' + filename + '" not found!'
+ return
+
+- #remove temporary files
+- if options['dontextract'] == '':
+- if options['verbose']=='--verbose' and options['verbositylevel']=='high':
+- print 'Removing any previous temporary files...'
+- os.system('rm -r '+CHM2PDF_ORIG_DIR+'/*')
+- os.system('rm -r '+CHM2PDF_WORK_DIR+'/*')
+-
+ cfile = chm.CHMFile()
+ cfile.LoadCHM(filename)
+
+@@ -1105,6 +1090,8 @@
+ os.system('extract_chmLib ' + filename + ' ' + CHM2PDF_ORIG_DIR + '&> /dev/null')
+
+ convert_to_pdf(cfile, filename, outputfilename, options)
++ shutil.rmtree(CHM2PDF_TEMP_WORK_DIR)
++ shutil.rmtree(CHM2PDF_TEMP_ORIG_DIR)
+
+
+ if __name__ == '__main__':
diff --git a/app-text/chm2pdf/metadata.xml b/app-text/chm2pdf/metadata.xml
new file mode 100644
index 000000000000..3d43c690d0f6
--- /dev/null
+++ b/app-text/chm2pdf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+