summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/diffutils/ChangeLog10
-rw-r--r--sys-apps/diffutils/diffutils-2.9-r1.ebuild43
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index 712108ad75d6..30cc9847117b 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/diffutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.55 2010/02/14 00:36:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.56 2010/03/31 11:42:40 flameeyes Exp $
+
+*diffutils-2.9-r1 (31 Mar 2010)
+
+ 31 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +diffutils-2.9-r1.ebuild:
+ Disable automagic dependency over libsigsegv (bug #312351); use parallel
+ make in src_test as it works and cuts in half the build time when using
+ highly parallel make.
*diffutils-2.9 (14 Feb 2010)
diff --git a/sys-apps/diffutils/diffutils-2.9-r1.ebuild b/sys-apps/diffutils/diffutils-2.9-r1.ebuild
new file mode 100644
index 000000000000..12ffcf6c3684
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.9-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.9-r1.ebuild,v 1.1 2010/03/31 11:42:40 flameeyes Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="http://www.gnu.org/software/diffutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz
+ mirror://gnu/diffutils/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND=""
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="http://bugs.gentoo.org/" \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_test() {
+ # explicitly allow parallel testing
+ emake check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}