summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.1.19
-rw-r--r--dev-util/git/git-1.4.1.1.ebuild148
3 files changed, 163 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 2ca95cea070c..f9350e76d88b 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.102 2006/07/11 14:15:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.103 2006/07/25 20:02:53 flameeyes Exp $
+
+*git-1.4.1.1 (25 Jul 2006)
+
+ 25 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> +git-1.4.1.1.ebuild:
+ Version bump.
11 Jul 2006; Aron Griffis <agriffis@gentoo.org> git-1.4.0-r1.ebuild,
git-1.4.1.ebuild:
diff --git a/dev-util/git/files/digest-git-1.4.1.1 b/dev-util/git/files/digest-git-1.4.1.1
new file mode 100644
index 000000000000..4bc145c23dbb
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.1.1
@@ -0,0 +1,9 @@
+MD5 cde57291a326b958802e453b48a0e0bf git-1.4.1.1.tar.bz2 752419
+RMD160 1e8c8cc2ee0685fb0ece9e0ee0720cb608140c05 git-1.4.1.1.tar.bz2 752419
+SHA256 e4a9ef8403c3716f7494d4865ee6c3e862b93012df41522237ace91f68a6d6ce git-1.4.1.1.tar.bz2 752419
+MD5 687ecfa370c4407e0504fd84083e92a1 git-htmldocs-1.4.1.1.tar.bz2 263120
+RMD160 4a50c2cec7ecd612690ee5dd0f7fbe69f11fe1bf git-htmldocs-1.4.1.1.tar.bz2 263120
+SHA256 8e4ccf995645fe08f7644b62535c4054515355942b5f3551fcbebd3f5ec36d1d git-htmldocs-1.4.1.1.tar.bz2 263120
+MD5 252b85ac0ffb73d8f13fa1f45dd745b5 git-manpages-1.4.1.1.tar.bz2 83956
+RMD160 894b8717e9e4099f7aacb97a3673e81c09e23daf git-manpages-1.4.1.1.tar.bz2 83956
+SHA256 2b2759a15eb9432e972743846c7299518e542e99a23a7318c540f0086e746ee4 git-manpages-1.4.1.1.tar.bz2 83956
diff --git a/dev-util/git/git-1.4.1.1.ebuild b/dev-util/git/git-1.4.1.1.ebuild
new file mode 100644
index 000000000000..07047ab34537
--- /dev/null
+++ b/dev-util/git/git-1.4.1.1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.1.1.ebuild,v 1.1 2006/07/25 20:02:53 flameeyes Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 webdav X"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ X? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+ emake -C contrib/git-svn/ git-svn || die "make git-svn failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use X || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/git-svn/git-svn
+ dodoc contrib/git-svn/git-svn.txt
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before"
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before"
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion before"
+ einfo
+ einfo "If you want to import a quilt series into git, donsider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before"
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}