summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/bluefish/ChangeLog9
-rw-r--r--app-editors/bluefish/bluefish-1.0.5.ebuild39
-rw-r--r--app-editors/bluefish/files/digest-bluefish-1.0.53
3 files changed, 49 insertions, 2 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 75326f89287c..2971cbd7b649 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/bluefish
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.52 2005/12/20 22:34:51 hanno Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.53 2006/02/19 23:08:33 hanno Exp $
+
+*bluefish-1.0.5 (19 Feb 2006)
+
+ 19 Feb 2006; Hanno Boeck <hanno@gentoo.org> +bluefish-1.0.5.ebuild:
+ Version bump.
*bluefish-1.0.4-r1 (20 Dec 2005)
diff --git a/app-editors/bluefish/bluefish-1.0.5.ebuild b/app-editors/bluefish/bluefish-1.0.5.ebuild
new file mode 100644
index 000000000000..89fe3bbdb1af
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.5.ebuild,v 1.1 2006/02/19 23:08:33 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell gnome"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ gnome? ( gnome-base/libgnomeui )"
+
+src_compile() {
+ econf --disable-update-databases \
+ `use_enable nls` \
+ `use_with gnome libgnomeui` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ update-mime-database /usr/share/mime
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-1.0.5 b/app-editors/bluefish/files/digest-bluefish-1.0.5
new file mode 100644
index 000000000000..3d2c27518992
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-1.0.5
@@ -0,0 +1,3 @@
+MD5 26701c09d41e5dea987155cdc9d0ac94 bluefish-1.0.5.tar.bz2 1492532
+RMD160 5cb388e2f4d1193a9d51ebed26ab523bf6809208 bluefish-1.0.5.tar.bz2 1492532
+SHA256 dc957c1af2f272c7d518c68c1c5d3beb693e02dd538f0641ef58d7eeccd41221 bluefish-1.0.5.tar.bz2 1492532