summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/atk/ChangeLog7
-rw-r--r--dev-libs/atk/atk-1.32.0-r1.ebuild14
-rw-r--r--dev-libs/atk/atk-2.2.0.ebuild44
-rw-r--r--dev-libs/atk/atk-2.4.0.ebuild14
-rw-r--r--dev-libs/atk/atk-2.6.0.ebuild14
-rw-r--r--dev-libs/atk/metadata.xml4
6 files changed, 18 insertions, 79 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index 15ccb8e67fc5..4bbf2bfa18cb 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.251 2012/10/28 15:39:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.252 2012/12/16 06:01:24 tetromino Exp $
+
+ 16 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ atk-1.32.0-r1.ebuild, -atk-2.2.0.ebuild, atk-2.4.0.ebuild, atk-2.6.0.ebuild,
+ metadata.xml:
+ Modernize the ebuilds. Drop old. Switch to global introspection USE flag.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> atk-2.4.0.ebuild:
ia64/s390/sh/sparc stable wrt #427544
diff --git a/dev-libs/atk/atk-1.32.0-r1.ebuild b/dev-libs/atk/atk-1.32.0-r1.ebuild
index 172d7ee3ba98..693501c898f6 100644
--- a/dev-libs/atk/atk-1.32.0-r1.ebuild
+++ b/dev-libs/atk/atk-1.32.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.32.0-r1.ebuild,v 1.12 2012/09/25 11:52:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.32.0-r1.ebuild,v 1.13 2012/12/16 06:01:24 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -13,22 +13,20 @@ HOMEPAGE="http://projects.gnome.org/accessibility/"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="doc +introspection nls"
+IUSE="+introspection nls"
RDEPEND="dev-libs/glib:2
introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
DEPEND="${RDEPEND}
>=dev-lang/perl-5
+ dev-util/gtk-doc-am
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1 )
nls? ( sys-devel/gettext )"
-pkg_setup() {
+src_prepare() {
G2CONF="${G2CONF} $(use_enable introspection)"
DOCS="AUTHORS ChangeLog NEWS README"
-}
-src_prepare() {
gnome2_src_prepare
if ! use test; then
@@ -36,8 +34,4 @@ src_prepare() {
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed failed"
fi
-
- # Remove DEPRECATED flags
- sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
- tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
}
diff --git a/dev-libs/atk/atk-2.2.0.ebuild b/dev-libs/atk/atk-2.2.0.ebuild
deleted file mode 100644
index f26b70b72101..000000000000
--- a/dev-libs/atk/atk-2.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.2.0.ebuild,v 1.11 2012/09/25 11:52:11 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
-HOMEPAGE="http://projects.gnome.org/accessibility/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="doc +introspection nls"
-
-RDEPEND="dev-libs/glib:2
- introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5
- virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.13 )
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable introspection)"
- DOCS="AUTHORS ChangeLog NEWS README"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- if ! use test; then
- # don't waste time building tests (bug #226353)
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
- || die "sed failed"
- fi
-
- # Remove DEPRECATED flags
- sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
- tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
-}
diff --git a/dev-libs/atk/atk-2.4.0.ebuild b/dev-libs/atk/atk-2.4.0.ebuild
index e2c0bdbce17a..1e670f081363 100644
--- a/dev-libs/atk/atk-2.4.0.ebuild
+++ b/dev-libs/atk/atk-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.4.0.ebuild,v 1.13 2012/10/28 15:39:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.4.0.ebuild,v 1.14 2012/12/16 06:01:24 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -14,22 +14,20 @@ HOMEPAGE="http://projects.gnome.org/accessibility/"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="doc +introspection nls"
+IUSE="+introspection nls"
RDEPEND=">=dev-libs/glib-2.31.2:2
introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
DEPEND="${RDEPEND}
>=dev-lang/perl-5
+ dev-util/gtk-doc-am
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.13 )
nls? ( sys-devel/gettext )"
-pkg_setup() {
+src_prepare() {
G2CONF="${G2CONF} $(use_enable introspection)"
DOCS="AUTHORS ChangeLog NEWS README"
-}
-src_prepare() {
gnome2_src_prepare
if ! use test; then
@@ -37,8 +35,4 @@ src_prepare() {
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed failed"
fi
-
- # Remove DEPRECATED flags
- sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
- tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
}
diff --git a/dev-libs/atk/atk-2.6.0.ebuild b/dev-libs/atk/atk-2.6.0.ebuild
index d12d0bcd8aad..c037224e46a1 100644
--- a/dev-libs/atk/atk-2.6.0.ebuild
+++ b/dev-libs/atk/atk-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.6.0.ebuild,v 1.1 2012/09/25 11:52:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.6.0.ebuild,v 1.2 2012/12/16 06:01:24 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -14,22 +14,20 @@ HOMEPAGE="http://projects.gnome.org/accessibility/"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="doc +introspection nls"
+IUSE="+introspection nls"
RDEPEND=">=dev-libs/glib-2.31.2:2
introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
DEPEND="${RDEPEND}
>=dev-lang/perl-5
+ dev-util/gtk-doc-am
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.13 )
nls? ( sys-devel/gettext )"
-pkg_setup() {
+src_prepare() {
G2CONF="${G2CONF} $(use_enable introspection)"
DOCS="AUTHORS ChangeLog NEWS README"
-}
-src_prepare() {
gnome2_src_prepare
if ! use test; then
@@ -37,8 +35,4 @@ src_prepare() {
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed failed"
fi
-
- # Remove DEPRECATED flags
- sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
- tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
}
diff --git a/dev-libs/atk/metadata.xml b/dev-libs/atk/metadata.xml
index d984e97ecd63..d9f21e6a89de 100644
--- a/dev-libs/atk/metadata.xml
+++ b/dev-libs/atk/metadata.xml
@@ -2,8 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome-accessibility</herd>
- <use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
- </use>
</pkgmetadata>