summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/tagunit/ChangeLog11
-rw-r--r--dev-java/tagunit/Manifest3
-rw-r--r--dev-java/tagunit/files/digest-tagunit-1.0.11
-rw-r--r--dev-java/tagunit/metadata.xml5
-rw-r--r--dev-java/tagunit/tagunit-1.0.1.ebuild34
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/tagunit/ChangeLog b/dev-java/tagunit/ChangeLog
new file mode 100644
index 000000000000..1dee5812e76c
--- /dev/null
+++ b/dev-java/tagunit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/tagunit
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.1 2004/04/05 04:44:37 zx Exp $
+
+*tagunit-1.0.1 (04 Apr 2004)
+
+ 04 Apr 2004; Chris Aniszczyk <zx@gentoo.org> metadata.xml,
+ tagunit-1.0.1.ebuild:
+ Initial Import. Closes #46629.
+ Thanks to Pavel <hlobil@sympatico.ca> for the initial ebuild.
+
diff --git a/dev-java/tagunit/Manifest b/dev-java/tagunit/Manifest
new file mode 100644
index 000000000000..4b0f89476d4e
--- /dev/null
+++ b/dev-java/tagunit/Manifest
@@ -0,0 +1,3 @@
+MD5 d80c41e5989872f2313198d7dde01e7b tagunit-1.0.1.ebuild 940
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 093a30f20c5f98ded756bced1a87cf9e files/digest-tagunit-1.0.1 66
diff --git a/dev-java/tagunit/files/digest-tagunit-1.0.1 b/dev-java/tagunit/files/digest-tagunit-1.0.1
new file mode 100644
index 000000000000..9d05b99e5c1a
--- /dev/null
+++ b/dev-java/tagunit/files/digest-tagunit-1.0.1
@@ -0,0 +1 @@
+MD5 1e70fff14c69887cd7ac554c586cf49d tagunit-1.0.1-src.zip 290460
diff --git a/dev-java/tagunit/metadata.xml b/dev-java/tagunit/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/tagunit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/tagunit/tagunit-1.0.1.ebuild b/dev-java/tagunit/tagunit-1.0.1.ebuild
new file mode 100644
index 000000000000..597a15309eea
--- /dev/null
+++ b/dev-java/tagunit/tagunit-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1.ebuild,v 1.1 2004/04/05 04:44:37 zx Exp $
+
+DESCRIPTION="TagUnit is a tag library for testing custom tags within JSP pages."
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}-src.zip"
+HOMEPAGE="http://www.tagunit.org"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.6
+ jikes? ( >=dev-java/jikes-1.17 )
+ >=servletapi-2.4"
+RDEPEND=">=virtual/jdk-1.3"
+IUSE="jikes doc"
+S="${WORKDIR}/${P}-src/tagunit-core"
+
+src_compile() {
+ echo ${PV} > ../version.txt
+ mkdir ../lib
+
+ local antflags="build"
+ antflags="${antflags} -lib `java-config --classpath=servletapi-2.4`"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ dodoc changes.txt readme.txt
+ use doc && dohtml -r doc/api/*
+}