summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/fcitx/ChangeLog8
-rw-r--r--app-i18n/fcitx/fcitx-3.6.2.ebuild16
-rw-r--r--app-i18n/fcitx/files/fcitx-3.6.2-asneeded.patch29
3 files changed, 45 insertions, 8 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 63d23da96444..23eb44b7b1d5 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/fcitx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.28 2009/11/09 07:06:06 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.29 2010/02/06 15:36:35 ssuominen Exp $
+
+ 06 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> fcitx-3.6.2.ebuild,
+ +files/fcitx-3.6.2-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #276302 by Kacper Kowalik.
*fcitx-3.6.2 (07 Nov 2009)
diff --git a/app-i18n/fcitx/fcitx-3.6.2.ebuild b/app-i18n/fcitx/fcitx-3.6.2.ebuild
index 61e8d5740305..41ddf3d09235 100644
--- a/app-i18n/fcitx/fcitx-3.6.2.ebuild
+++ b/app-i18n/fcitx/fcitx-3.6.2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.6.2.ebuild,v 1.1 2009/11/07 07:07:25 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.6.2.ebuild,v 1.2 2010/02/06 15:36:35 ssuominen Exp $
EAPI=2
-
-inherit flag-o-matic
+inherit autotools eutils
DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
HOMEPAGE="http://www.fcitx.org/"
@@ -19,13 +18,18 @@ RDEPEND="x11-libs/libX11
x11-libs/libXpm
x11-libs/libXrender
x11-libs/libXt
+ x11-libs/libXtst
+ x11-libs/libXext
x11-libs/libXft"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_configure() {
- append-ldflags $(no-as-needed)
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+src_configure() {
# --disable-xft doesn't work
# econf $(use_enable xft) || die
econf || die
diff --git a/app-i18n/fcitx/files/fcitx-3.6.2-asneeded.patch b/app-i18n/fcitx/files/fcitx-3.6.2-asneeded.patch
new file mode 100644
index 000000000000..d83f4773d58d
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-3.6.2-asneeded.patch
@@ -0,0 +1,29 @@
+http://bugs.gentoo.org/show_bug.cgi?id=276302
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,7 +1,7 @@
+ DEFS = -DPKGDATADIR=\"$(pkgdatadir)\"
+
+ INCLUDES = -I. -I$(top_srcdir)/lib -I$(top_srcdir)/xpm
+-AM_CFLAGS = -O2 -fno-strength-reduce
++AM_CFLAGS = -fno-strength-reduce
+
+
+ bin_PROGRAMS = fcitx
+@@ -34,5 +34,4 @@
+ fcitx.h extra.c extra.h \
+ internalVersion.c
+
+-fcitx_LDADD = ../lib/libXimd.a
+-fcitx_LDFLAGS = -lXpm -lXtst
++fcitx_LDADD = ../lib/libXimd.a -lXpm -lXtst -lXext
+--- lib/Makefile.am
++++ lib/Makefile.am
+@@ -1,5 +1,5 @@
+ noinst_LIBRARIES = libXimd.a
+-AM_CFLAGS = -c -O2 -fno-strength-reduce -fno-strict-aliasing
++AM_CFLAGS = -fno-strength-reduce -fno-strict-aliasing
+ libXimd_a_SOURCES = \
+ FrameMgr.c FrameMgr.h i18nAttr.c i18nClbk.c i18nIc.c \
+ i18nIMProto.c i18nMethod.c i18nPtHdr.c i18nUtil.c i18nX.c \