summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/laptop-mode-tools/ChangeLog6
-rw-r--r--app-laptop/laptop-mode-tools/files/digest-laptop-mode-tools-1.04-r11
-rw-r--r--app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.04.init25
-rw-r--r--app-laptop/laptop-mode-tools/laptop-mode-tools-1.04-r1.ebuild74
-rw-r--r--net-wireless/hostapd/ChangeLog5
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.4.02
-rw-r--r--net-wireless/hostapd/hostapd-0.4.0.ebuild83
7 files changed, 9 insertions, 187 deletions
diff --git a/app-laptop/laptop-mode-tools/ChangeLog b/app-laptop/laptop-mode-tools/ChangeLog
index b196b5abf56c..a74e8155c04f 100644
--- a/app-laptop/laptop-mode-tools/ChangeLog
+++ b/app-laptop/laptop-mode-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/laptop-mode-tools
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/ChangeLog,v 1.6 2005/05/08 12:23:27 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/ChangeLog,v 1.7 2005/05/11 11:19:30 brix Exp $
+
+ 11 May 2005; <brix@gentoo.org> -files/laptop-mode-tools-1.04.init,
+ -laptop-mode-tools-1.04-r1.ebuild:
+ Removed old ebuild
08 May 2005; <brix@gentoo.org> laptop-mode-tools-1.05.ebuild:
Stable on x86.
diff --git a/app-laptop/laptop-mode-tools/files/digest-laptop-mode-tools-1.04-r1 b/app-laptop/laptop-mode-tools/files/digest-laptop-mode-tools-1.04-r1
deleted file mode 100644
index 1dbed76c46c5..000000000000
--- a/app-laptop/laptop-mode-tools/files/digest-laptop-mode-tools-1.04-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b26fcc4df2b38da17e4f09872a1cfeda laptop-mode-tools_1.04.tar.gz 30908
diff --git a/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.04.init b/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.04.init
deleted file mode 100644
index ba3a7b70488b..000000000000
--- a/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.04.init
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.04.init,v 1.2 2005/03/25 19:05:33 brix Exp $
-
-checkconfig() {
- if [ ! -f /proc/sys/vm/laptop_mode ]; then
- eerror "Kernel does not support laptop_mode"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting laptop_mode"
- touch /var/run/laptop-mode-enabled && /usr/sbin/laptop_mode auto &> /dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping laptop_mode"
- /usr/sbin/laptop_mode stop &> /dev/null && rm -f /var/run/laptop-mode-enabled
- eend $?
-}
diff --git a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.04-r1.ebuild b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.04-r1.ebuild
deleted file mode 100644
index 787177df1693..000000000000
--- a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.04-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/laptop-mode-tools-1.04-r1.ebuild,v 1.2 2005/04/24 16:11:18 brix Exp $
-
-inherit linux-info
-
-MY_P=${PN}_${PV}
-
-DESCRIPTION="Linux kernel laptop_mode user-space utilities"
-
-HOMEPAGE="http://www.xs4all.nl/~bsamwel/laptop_mode/tools/"
-SRC_URI="http://www.xs4all.nl/~bsamwel/laptop_mode/tools/downloads/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-IUSE="acpi apm"
-
-DEPEND="acpi? ( sys-power/acpid )
- apm? ( sys-apps/apmd )"
-
-pkg_setup() {
- linux-info_pkg_setup
-
- if [ ${KV_MAJOR} -eq 2 -a ${KV_MINOR} -eq 6 -a ${KV_PATCH} -lt 6 ]; then
- eerror "${P} requires kernel version 2.6.6 or newer."
- die "${P} requires kernel version 2.6.6 or newer"
- elif [ ${KV_MAJOR} -eq 2 -a ${KV_MINOR} -eq 4 -a ${KV_PATCH} -lt 23 ]; then
- eerror "${P} requires kernel version 2.4.23 or newer."
- die "${P} requires kernel version 2.4.23 or newer"
- fi
-}
-
-src_install() {
- dosbin usr/sbin/laptop_mode
-
- insinto /etc/laptop-mode
- doins etc/laptop-mode/laptop-mode.conf
-
- newinitd ${FILESDIR}/${P}.init laptop_mode
-
- doman man/*
-
- dodoc Documentation/laptop-mode.txt README
-
- if useq acpi; then
- insinto /etc/acpi/events/
- doins etc/acpi/events/*
-
- exeinto /etc/acpi/actions/
- doexe etc/acpi/actions/*
- fi
-
- if useq apm; then
- exeinto /etc/apm/event.d/
- doexe etc/apm/event.d/*
- fi
-}
-
-pkg_postinst() {
- if ! useq acpi && ! useq apm; then
- ewarn
- ewarn "Without USE=\"acpi\" or USE=\"apm\" ${PN} can not"
- ewarn "automatically disable laptop_mode on low battery."
- ewarn
- ewarn "This means you can lose up to 10 minutes of work if running"
- ewarn "out of battery while laptop_mode is enabled."
- ewarn
- ewarn "Please see /usr/share/doc/${PF}/laptop-mode.txt.gz for further"
- ewarn "information."
- ewarn
- fi
-}
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 92e595b015b8..26d1442142ad 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.27 2005/04/29 19:49:37 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.28 2005/05/11 11:21:22 brix Exp $
+
+ 11 May 2005; <brix@gentoo.org> -hostapd-0.4.0.ebuild:
+ Removed old ebuild
*hostapd-0.4.0-r1 (29 Apr 2005)
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.4.0 b/net-wireless/hostapd/files/digest-hostapd-0.4.0
deleted file mode 100644
index cbd70657b20a..000000000000
--- a/net-wireless/hostapd/files/digest-hostapd-0.4.0
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 e94731593b492bfad7a6b341c0514266 hostapd-0.4.0.tar.gz 257771
-MD5 efb9130cf1dcb829caa43af4e0bee2fb madwifi-cvs-snapshot-2005-04-20.tar.bz2 1968548
diff --git a/net-wireless/hostapd/hostapd-0.4.0.ebuild b/net-wireless/hostapd/hostapd-0.4.0.ebuild
deleted file mode 100644
index e5aa0b156154..000000000000
--- a/net-wireless/hostapd/hostapd-0.4.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.0.ebuild,v 1.1 2005/04/27 09:59:26 brix Exp $
-
-inherit toolchain-funcs
-
-MADWIFI_VERSION="2005-04-20"
-
-DESCRIPTION="HostAP wireless daemon"
-HOMEPAGE="http://hostap.epitest.fi"
-SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz
- mirror://gentoo/madwifi-cvs-snapshot-${MADWIFI_VERSION}.tar.bz2"
-
-LICENSE="|| ( GPL-2 BSD )"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
-IUSE="ipv6 ssl"
-
-DEPEND="ssl? ( dev-libs/openssl )"
-
-src_unpack() {
- local CONFIG=${S}/.config
-
- unpack ${A}
-
- # toolchain setup
- echo "CC = $(tc-getCC)" > ${CONFIG}
-
- # authentication methods
- echo "CONFIG_EAP=y" >> ${CONFIG}
- echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
- echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
- echo "CONFIG_IAPP=y" >> ${CONFIG}
- echo "CONFIG_PKCS12=y" >> ${CONFIG}
- echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
- echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
- echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
-
- if use ssl; then
- # SSL authentication methods
- echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
- echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
- echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
- echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
- fi
-
- if use ipv6; then
- echo "CONFIG_IPV6=y" >> ${CONFIG}
- fi
-
- # Linux specific drivers
- echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
- echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
- echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
-
- # Add include path for madwifi-driver headers
- echo "CFLAGS += -I${WORKDIR}/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- insinto /etc/hostapd
- doins hostapd.conf hostapd.accept hostapd.deny
-
- dosed 's:\(accept_mac_file=\)/etc/hostapd.accept:\1/etc/hostapd/hostapd.accept:g' \
- /etc/hostapd/hostapd.conf
- dosed 's:\(deny_mac_file=\)/etc/hostapd.deny:\1/etc/hostapd/hostapd.deny:g' \
- /etc/hostapd/hostapd.conf
-
- dosbin hostapd
-
- newinitd ${FILESDIR}/hostapd.init.d hostapd
-
- dodoc ChangeLog developer.txt README
-
- docinto examples
- dodoc madwifi.conf wired.conf
-}