summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/i3/ChangeLog10
-rw-r--r--x11-wm/i3/files/i3-4.0.1-gentoo-r1.diff (renamed from x11-wm/i3/files/i3-4.0.1-gentoo.diff)15
-rw-r--r--x11-wm/i3/i3-4.0.1-r1.ebuild (renamed from x11-wm/i3/i3-4.0.1.ebuild)4
3 files changed, 18 insertions, 11 deletions
diff --git a/x11-wm/i3/ChangeLog b/x11-wm/i3/ChangeLog
index 926a02bc95d5..3865b10713ce 100644
--- a/x11-wm/i3/ChangeLog
+++ b/x11-wm/i3/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/i3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.5 2011/08/02 04:55:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/ChangeLog,v 1.6 2011/08/03 20:42:45 xarthisius Exp $
+
+*i3-4.0.1-r1 (03 Aug 2011)
+
+ 03 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> -i3-4.0.1.ebuild,
+ +i3-4.0.1-r1.ebuild, -files/i3-4.0.1-gentoo.diff,
+ +files/i3-4.0.1-gentoo-r1.diff:
+ Fix man installation wrt bug 377453 by Lasse Lindner
+ <gentoo@lasse-lindner.de>
*i3-4.0.1 (02 Aug 2011)
diff --git a/x11-wm/i3/files/i3-4.0.1-gentoo.diff b/x11-wm/i3/files/i3-4.0.1-gentoo-r1.diff
index 5d3c6ec082af..26189cb7b056 100644
--- a/x11-wm/i3/files/i3-4.0.1-gentoo.diff
+++ b/x11-wm/i3/files/i3-4.0.1-gentoo-r1.diff
@@ -97,29 +97,28 @@
for dir in $(SUBDIRS); do \
$(MAKE) -C $$dir install; \
done
-+ $(MAKE) -C man
++ $(MAKE) -C man install
dist: distclean
[ ! -d i3-${VERSION} ] || rm -rf i3-${VERSION}
--- a/man/Makefile
+++ b/man/Makefile
-@@ -1,6 +1,8 @@
+@@ -1,6 +1,9 @@
A2M:=a2x -f manpage --asciidoc-opts="-f asciidoc.conf"
++include ../common.mk
-all: i3.1 i3-msg.1 i3-input.1 i3-nagbar.1 i3-wsbar.1 i3-config-wizard.1 i3-migrate-config-to-v4.1
-+mans=i3.1 i3-msg.1 i3-input.1 i3-nagbar.1 i3-wsbar.1 i3-config-wizard.1 i3-migrate-config-to-v4.1
++MANS=i3.1 i3-msg.1 i3-input.1 i3-nagbar.1 i3-wsbar.1 i3-config-wizard.1 i3-migrate-config-to-v4.1
+
-+all: $(mans)
++all: $(MANS)
%.1: %.man asciidoc.conf
${A2M} $<
-@@ -16,3 +18,9 @@
+@@ -16,3 +19,7 @@
distclean: clean
rm -f *.1
+
+install:
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man1
-+ for man in $(mans); do \
-+ $(INSTALL) -m 0644 $$man $(DESTDIR)$(PREFIX)/share/man/man1
-+ done
++ $(INSTALL) -m 0644 *.1 $(DESTDIR)$(PREFIX)/share/man/man1
diff --git a/x11-wm/i3/i3-4.0.1.ebuild b/x11-wm/i3/i3-4.0.1-r1.ebuild
index 33a59f68176e..0378d7ace556 100644
--- a/x11-wm/i3/i3-4.0.1.ebuild
+++ b/x11-wm/i3/i3-4.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/i3-4.0.1.ebuild,v 1.1 2011/08/02 04:55:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/i3/i3-4.0.1-r1.ebuild,v 1.1 2011/08/03 20:42:45 xarthisius Exp $
EAPI=4
@@ -34,7 +34,7 @@ RDEPEND="${CDEPEND}
x11-apps/xmessage"
DOCS=( GOALS TODO RELEASE-NOTES-${PV} )
-PATCHES=( "${FILESDIR}"/${P}-gentoo.diff )
+PATCHES=( "${FILESDIR}"/${P}-gentoo-r1.diff )
pkg_setup() {
tc-export CC