summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.27-r1.ebuild106
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.27.ebuild100
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.29-r1.ebuild113
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.29.ebuild101
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.32-r1.ebuild113
-rw-r--r--sys-apps/e2fsprogs/e2fsprogs-1.32.ebuild107
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.271
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27-r11
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.291
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29-r11
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.321
-rw-r--r--sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32-r11
-rw-r--r--sys-apps/shadow/shadow-4.0.2-r5.ebuild132
-rw-r--r--sys-apps/shadow/shadow-4.0.3-r2.ebuild166
-rw-r--r--sys-apps/shadow/shadow-4.0.3.ebuild147
15 files changed, 0 insertions, 1091 deletions
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.27-r1.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.27-r1.ebuild
deleted file mode 100644
index a08731ea9bd1..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.27-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.27-r1.ebuild,v 1.16 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls acl"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-KEYWORDS="~x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use acl && patch -p1 < ${FILESDIR}/e2fsprogs-1.27ea-0.8.21.diff
-}
-
-src_compile() {
- local myconf
- if [ "`use nls`" ]
- then
- myconf="--enable-nls"
- else
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} libdir=zapme install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib
- local x
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L $x ]&& continue
- mylib=`readlink $x`
- mylib=`basename $mylib`
- ln -sf $mylib $x
- done
- mv ${D}/usr/bin/* ${D}/bin
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../usr/bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.27.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.27.ebuild
deleted file mode 100644
index 0750ec1f2399..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.27.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.27.ebuild,v 1.17 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-RDEPEND="virtual/glibc"
-
-src_compile() {
- local myconf
- if [ "`use nls`" ]
- then
- myconf="--enable-nls"
- else
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} libdir=zapme install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib
- local x
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L $x ]&& continue
- mylib=`readlink $x`
- mylib=`basename $mylib`
- ln -sf $mylib $x
- done
- mv ${D}/usr/bin/* ${D}/bin
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../usr/bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.29-r1.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.29-r1.ebuild
deleted file mode 100644
index 0f32d3380120..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.29-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.29-r1.ebuild,v 1.5 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls"
-
-inherit eutils
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
- local myconf=""
-
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} \
- libdir=zapme \
- install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/lib
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/bin/* ${D}/bin
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../usr/bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
-
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.29.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.29.ebuild
deleted file mode 100644
index b837127dc080..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.29.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.29.ebuild,v 1.7 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
- local myconf=""
-
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} libdir=zapme install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib=""
- local x=""
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib=`readlink ${x}`
- mylib=`basename ${mylib}`
- ln -sf ${mylib} ${x}
- done
- mv ${D}/usr/bin/* ${D}/bin
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../usr/bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
-
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.32-r1.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.32-r1.ebuild
deleted file mode 100644
index 624e53941fa3..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.32-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.32-r1.ebuild,v 1.3 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls"
-
-inherit eutils
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
-
- # Fix a cosmetic error in mk_cmds's help output.
- cd ${S}; epatch ${FILESDIR}/${P}-mk_cmds-cosmetic.patch
-}
-
-src_compile() {
- local myconf=""
-
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
- econf --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- MAKEOPTS="-j1" emake || die
-}
-
-src_install() {
- einstall libdir=zapme || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/lib
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../../bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
-
diff --git a/sys-apps/e2fsprogs/e2fsprogs-1.32.ebuild b/sys-apps/e2fsprogs/e2fsprogs-1.32.ebuild
deleted file mode 100644
index ab5579fc346e..000000000000
--- a/sys-apps/e2fsprogs/e2fsprogs-1.32.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/e2fsprogs/e2fsprogs-1.32.ebuild,v 1.6 2003/02/25 18:58:08 lostlogic Exp $
-
-IUSE="nls"
-
-inherit eutils
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-
-KEYWORDS="x86 ppc sparc alpha mips"
-SLOT="0"
-LICENSE="GPL-2"
-
-#debianutils is for 'readlink'
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- sys-apps/debianutils
- sys-apps/texinfo"
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
- local myconf=""
-
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
- econf --enable-dynamic-e2fsck \
- --enable-elf-shlibs \
- ${myconf} || die
-
- # Parallel make sometimes fails
- MAKEOPTS="-j1" emake || die
-}
-
-src_install() {
- einstall libdir=zapme || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- if [ "`use nls`" ]
- then
- ( cd po; make DESTDIR=${D} install ) || die
- fi
-
- dodoc COPYING ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/lib
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/bin/* ${D}/bin
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../usr/bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
-
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27
deleted file mode 100644
index 49f077eb9d73..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27
+++ /dev/null
@@ -1 +0,0 @@
-MD5 485b43875becc98dd11ac4c2a30dd734 e2fsprogs-1.27.tar.gz 1376698
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27-r1 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27-r1
deleted file mode 100644
index 49f077eb9d73..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.27-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 485b43875becc98dd11ac4c2a30dd734 e2fsprogs-1.27.tar.gz 1376698
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29
deleted file mode 100644
index c82fd38c3c67..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7a468aaa995202e2a365c7e7be462bc9 e2fsprogs-1.29.tar.gz 2279693
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29-r1 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29-r1
deleted file mode 100644
index c82fd38c3c67..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.29-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7a468aaa995202e2a365c7e7be462bc9 e2fsprogs-1.29.tar.gz 2279693
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32
deleted file mode 100644
index 36577bde405a..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7ced9d6edaba3a000ccc5200e09b90d e2fsprogs-1.32.tar.gz 2894603
diff --git a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32-r1 b/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32-r1
deleted file mode 100644
index 36577bde405a..000000000000
--- a/sys-apps/e2fsprogs/files/digest-e2fsprogs-1.32-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7ced9d6edaba3a000ccc5200e09b90d e2fsprogs-1.32.tar.gz 2894603
diff --git a/sys-apps/shadow/shadow-4.0.2-r5.ebuild b/sys-apps/shadow/shadow-4.0.2-r5.ebuild
deleted file mode 100644
index 8a683afafa2c..000000000000
--- a/sys-apps/shadow/shadow-4.0.2-r5.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.2-r5.ebuild,v 1.11 2003/02/13 16:14:23 vapier Exp $
-
-IUSE=""
-
-inherit libtool
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utilities to deal with user accounts"
-SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
-HOMEPAGE="http://shadow.pld.org.pl/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ppc sparc "
-
-DEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3
- sys-devel/gettext"
-
-RDEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3"
-
-
-pkg_preinst() {
- rm -f ${ROOT}/etc/pam.d/system-auth.new
-}
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use nls || myconf="${myconf} --disable-nls"
-
- ./configure --disable-desrpc \
- --with-libcrypt \
- --with-libcrack \
- --with-libpam \
- --enable-shared=no \
- --enable-static=yes \
- --host=${CHOST} \
- ${myconf} || die "bad configure"
-
- # Parallel make fails sometimes
- make || die "compile problem"
-}
-
-src_install() {
- dodir /etc/default /etc/skel
-
- make prefix=${D}/usr \
- exec_prefix=${D} \
- mandir=${D}/usr/share/man \
- install || die "install problem"
-
- #do not install this login, but rather the one from
- #util-linux, as this one have a serious root exploit
- #with pam_limits in use.
- rm ${D}/bin/login
-
- mv ${D}/lib ${D}/usr
- dosed "s:/lib':/usr/lib':g" /usr/lib/libshadow.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libshadow.la
- dosed "s:/lib':/usr/lib':g" /usr/lib/libmisc.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libmisc.la
- dosym /usr/bin/newgrp /usr/bin/sg
- dosym /usr/sbin/useradd /usr/sbin/adduser
- dosym /usr/sbin/vipw /usr/sbin/vigr
- # remove dead links
- rm -f ${D}/bin/{sg,vipw}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins ${FILESDIR}/securetty
- insopts -m0600 ; doins ${S}/etc/login.access
- insopts -m0644 ; doins ${S}/etc/limits
-# From sys-apps/pam-login now
-# insopts -m0644 ; doins ${FILESDIR}/login.defs
- insinto /etc/pam.d ; insopts -m0644
- cd ${FILESDIR}/pam.d
- doins *
- newins system-auth system-auth.new
- newins shadow chage
- newins shadow chsh
- newins shadow chfn
- newins shadow useradd
- newins shadow groupadd
- cd ${S}
-
- # the manpage install is beyond my comprehension, and also broken.
- # just do it over.
- rm -rf ${D}/usr/share/man/*
- for q in man/*.[0-9]
- do
- local dir="${D}/usr/share/man/man${q##*.}"
- mkdir -p $dir
- cp $q $dir
- done
-
- #dont install the manpage, since we dont use
- #login with shadow
- rm ${D}/usr/share/man/man1/login.*
-
- cd ${S}/doc
- dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
- docinto txt
- dodoc HOWTO LSM README.* *.txt
-}
-
-pkg_postinst() {
- ewarn "Due to a security issue, ${ROOT}etc/pam.d/system-auth "
- ewarn "is being updated automatically. Your old "
- ewarn "system-auth will be backed up as:"
- ewarn "${ROOT}etc/pam.d/system-auth.bak"
- echo
-
- local CHECK1=`md5sum ${ROOT}/etc/pam.d/system-auth | cut -d ' ' -f 1`
- local CHECK2=`md5sum ${ROOT}/etc/pam.d/system-auth.new | cut -d ' ' -f 1`
-
- if [ "$CHECK1" != "$CHECK2" ];
- then
- cp -a ${ROOT}/etc/pam.d/system-auth \
- ${ROOT}/etc/pam.d/system-auth.bak;
- mv -f ${ROOT}/etc/pam.d/system-auth.new \
- ${ROOT}/etc/pam.d/system-auth
- else
- rm -f ${ROOT}/etc/pam.d/system-auth.new
- fi
-}
-
diff --git a/sys-apps/shadow/shadow-4.0.3-r2.ebuild b/sys-apps/shadow/shadow-4.0.3-r2.ebuild
deleted file mode 100644
index 957ea7f3b7b9..000000000000
--- a/sys-apps/shadow/shadow-4.0.3-r2.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3-r2.ebuild,v 1.9 2003/02/13 16:14:32 vapier Exp $
-
-IUSE=""
-
-inherit libtool
-
-FORCE_SYSTEMAUTH_UPDATE="no"
-
-S="${WORKDIR}/${P}"
-HOMEPAGE="http://shadow.pld.org.pl/"
-DESCRIPTION="Utilities to deal with user accounts"
-SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-
-DEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3
- sys-devel/gettext"
-
-RDEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3"
-
-
-pkg_preinst() {
- rm -f ${ROOT}/etc/pam.d/system-auth.new
-}
-
-src_unpack() {
- unpack ${A}
-
- # Get su to call pam_open_session(), and also set DISPLAY and XAUTHORITY,
- # else the session entries in /etc/pam.d/su never get executed, and
- # pam_xauth for one, is then never used. This should close bug #8831.
- #
- # <azarah@gentoo.org> (19 Oct 2002)
- cd ${S}; patch -p1 < ${FILESDIR}/${P}-su-pam_open_session.patch-v2 || die
-}
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use nls || myconf="${myconf} --disable-nls"
-
- ./configure --disable-desrpc \
- --with-libcrypt \
- --with-libcrack \
- --with-libpam \
- --enable-shared=no \
- --enable-static=yes \
- --host=${CHOST} \
- ${myconf} || die "bad configure"
-
- # Parallel make fails sometimes
- make || die "compile problem"
-}
-
-src_install() {
- dodir /etc/default /etc/skel
-
- make prefix=${D}/usr \
- exec_prefix=${D} \
- mandir=${D}/usr/share/man \
- install || die "install problem"
-
- # Do not install this login, but rather the one from
- # pam-login, as this one have a serious root exploit
- # with pam_limits in use.
- rm ${D}/bin/login
-
- mv ${D}/lib ${D}/usr
- dosed "s:/lib':/usr/lib':g" /usr/lib/libshadow.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libshadow.la
- dosed "s:/lib':/usr/lib':g" /usr/lib/libmisc.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libmisc.la
- dosym /usr/bin/newgrp /usr/bin/sg
- dosym /usr/sbin/useradd /usr/sbin/adduser
- dosym /usr/sbin/vipw /usr/sbin/vigr
- # Remove dead links
- rm -f ${D}/bin/{sg,vipw}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins ${FILESDIR}/securetty
- insopts -m0600 ; doins ${S}/etc/login.access
- insopts -m0644 ; doins ${S}/etc/limits
-
- # needed for 'adduser -D'
- keepdir /etc/default
-
-# From sys-apps/pam-login now
-# insopts -m0644 ; doins ${FILESDIR}/login.defs
- insinto /etc/pam.d ; insopts -m0644
- cd ${FILESDIR}/pam.d
- for x in *
- do
- [ -f ${x} ] && doins ${x}
- done
- newins system-auth system-auth.new
- newins shadow chage
- newins shadow chsh
- newins shadow chfn
- newins shadow useradd
- newins shadow groupadd
- cd ${S}
-
- # The manpage install is beyond my comprehension, and
- # also broken. Just do it over.
- rm -rf ${D}/usr/share/man/*
- for x in man/*.[0-9]
- do
- [ -f ${x} ] || continue
- local dir="${D}/usr/share/man/man${x##*.}"
- mkdir -p ${dir}
- cp ${x} ${dir}
- done
-
- # Dont install the manpage, since we dont use
- # login with shadow
- rm -f ${D}/usr/share/man/man1/login.*
- # We use pam, so this is not applicable.
- rm -f ${D}/usr/share/man/man5/suauth.*
-
- cd ${S}/doc
- dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
- docinto txt
- dodoc HOWTO LSM README.* *.txt
-
- # Fix sparc serial console
- if [ "${ARCH}" = "sparc" -o "${ARCH}" = "" ]
- then
- # ttyS0 and its devfsd counterpart (Sparc serial port "A")
- dosed 's:\(vc/1\)$:tts/0\n\1:' /etc/securetty
- dosed 's:\(tty1\)$:ttyS0\n\1:' /etc/securetty
- fi
-}
-
-pkg_postinst() {
-
- local CHECK1="$(md5sum ${ROOT}/etc/pam.d/system-auth | cut -d ' ' -f 1)"
- local CHECK2="$(md5sum ${ROOT}/etc/pam.d/system-auth.new | cut -d ' ' -f 1)"
-
- if [ "${CHECK1}" != "${CHECK2}" -a "${FORCE_SYSTEMAUTH_UPDATE}" = "yes" ]
- then
- ewarn "Due to a security issue, ${ROOT}etc/pam.d/system-auth "
- ewarn "is being updated automatically. Your old "
- ewarn "system-auth will be backed up as:"
- ewarn
- ewarn " ${ROOT}etc/pam.d/system-auth.bak"
- echo
-
- cp -a ${ROOT}/etc/pam.d/system-auth \
- ${ROOT}/etc/pam.d/system-auth.bak;
- mv -f ${ROOT}/etc/pam.d/system-auth.new \
- ${ROOT}/etc/pam.d/system-auth
- rm -f ${ROOT}/etc/pam.d/._cfg????_system-auth
- else
- rm -f ${ROOT}/etc/pam.d/system-auth.new
- fi
-}
-
diff --git a/sys-apps/shadow/shadow-4.0.3.ebuild b/sys-apps/shadow/shadow-4.0.3.ebuild
deleted file mode 100644
index 00cfb3b929fa..000000000000
--- a/sys-apps/shadow/shadow-4.0.3.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3.ebuild,v 1.17 2003/02/13 16:14:42 vapier Exp $
-
-IUSE=""
-
-inherit libtool
-
-S="${WORKDIR}/${P}"
-HOMEPAGE="http://shadow.pld.org.pl/"
-DESCRIPTION="Utilities to deal with user accounts"
-SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 sparc alpha"
-
-DEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3
- sys-devel/gettext"
-
-RDEPEND=">=sys-libs/pam-0.75-r4
- >=sys-libs/cracklib-2.7-r3"
-
-
-pkg_preinst() {
- rm -f ${ROOT}/etc/pam.d/system-auth.new
-}
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use nls || myconf="${myconf} --disable-nls"
-
- ./configure --disable-desrpc \
- --with-libcrypt \
- --with-libcrack \
- --with-libpam \
- --enable-shared=no \
- --enable-static=yes \
- --host=${CHOST} \
- ${myconf} || die "bad configure"
-
- # Parallel make fails sometimes
- make || die "compile problem"
-}
-
-src_install() {
- dodir /etc/default /etc/skel
-
- make prefix=${D}/usr \
- exec_prefix=${D} \
- mandir=${D}/usr/share/man \
- install || die "install problem"
-
- #do not install this login, but rather the one from
- #util-linux, as this one have a serious root exploit
- #with pam_limits in use.
- rm ${D}/bin/login
-
- mv ${D}/lib ${D}/usr
- dosed "s:/lib':/usr/lib':g" /usr/lib/libshadow.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libshadow.la
- dosed "s:/lib':/usr/lib':g" /usr/lib/libmisc.la
- dosed "s:/lib/:/usr/lib/:g" /usr/lib/libmisc.la
- dosym /usr/bin/newgrp /usr/bin/sg
- dosym /usr/sbin/useradd /usr/sbin/adduser
- dosym /usr/sbin/vipw /usr/sbin/vigr
- # remove dead links
- rm -f ${D}/bin/{sg,vipw}
-
- insinto /etc
- # Using a securetty with devfs device names added
- # (compat names kept for non-devfs compatibility)
- insopts -m0600 ; doins ${FILESDIR}/securetty
- insopts -m0600 ; doins ${S}/etc/login.access
- insopts -m0644 ; doins ${S}/etc/limits
-
- # needed for 'adduser -D'
- keepdir /etc/default
-
-# From sys-apps/pam-login now
-# insopts -m0644 ; doins ${FILESDIR}/login.defs
- insinto /etc/pam.d ; insopts -m0644
- cd ${FILESDIR}/pam.d
- doins *
- newins system-auth system-auth.new
- newins shadow chage
- newins shadow chsh
- newins shadow chfn
- newins shadow useradd
- newins shadow groupadd
- cd ${S}
-
- # the manpage install is beyond my comprehension, and also broken.
- # just do it over.
- rm -rf ${D}/usr/share/man/*
- for q in man/*.[0-9]
- do
- local dir="${D}/usr/share/man/man${q##*.}"
- mkdir -p $dir
- cp $q $dir
- done
-
- #dont install the manpage, since we dont use
- #login with shadow
- rm ${D}/usr/share/man/man1/login.*
-
- cd ${S}/doc
- dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
- docinto txt
- dodoc HOWTO LSM README.* *.txt
-
- # Fix sparc serial console
- if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
- cd ${D}/etc
- cp securetty securetty.orig
- # ttyS0 and its devfsd counterpart (Sparc serial port "A")
- sed -e 's:\(vc/1\)$:tts/0\n\1:' \
- -e 's:\(tty1\)$:ttyS0\n\1:' \
- securetty.orig > securetty || die
- rm securetty.orig
- fi
-}
-
-pkg_postinst() {
- ewarn "Due to a security issue, ${ROOT}etc/pam.d/system-auth "
- ewarn "is being updated automatically. Your old "
- ewarn "system-auth will be backed up as:"
- ewarn "${ROOT}etc/pam.d/system-auth.bak"
- echo
-
- local CHECK1=`md5sum ${ROOT}/etc/pam.d/system-auth | cut -d ' ' -f 1`
- local CHECK2=`md5sum ${ROOT}/etc/pam.d/system-auth.new | cut -d ' ' -f 1`
-
- if [ "$CHECK1" != "$CHECK2" ];
- then
- cp -a ${ROOT}/etc/pam.d/system-auth \
- ${ROOT}/etc/pam.d/system-auth.bak;
- mv -f ${ROOT}/etc/pam.d/system-auth.new \
- ${ROOT}/etc/pam.d/system-auth
- else
- rm -f ${ROOT}/etc/pam.d/system-auth.new
- fi
-}
-