summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/gtk-theme-switch/ChangeLog8
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-themes/gtk-theme-switch/ChangeLog b/x11-themes/gtk-theme-switch/ChangeLog
index 681a5ee7ff31..d43907cdc5b5 100644
--- a/x11-themes/gtk-theme-switch/ChangeLog
+++ b/x11-themes/gtk-theme-switch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-theme-switch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.38 2010/01/06 19:37:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.39 2010/04/02 17:47:21 ssuominen Exp $
+
+*gtk-theme-switch-2.1.0 (02 Apr 2010)
+
+ 02 Apr 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +gtk-theme-switch-2.1.0.ebuild:
+ Version bump.
06 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
gtk-theme-switch-2.0.0_rc2-r2.ebuild:
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild
new file mode 100644
index 000000000000..bd542201bdc8
--- /dev/null
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0.ebuild,v 1.1 2010/04/02 17:47:21 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to switch and preview GTK+ theme"
+HOMEPAGE="http://packages.qa.debian.org/g/gtk-theme-switch.html"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd
+~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ !${CATEGORY}/${PN}:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:${GCC}:$(CC) $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} -Wall" || die
+}
+
+src_install() {
+ newbin ${PN}2 ${PN} || die
+ newman ${PN}2.1 ${PN}.1 || die
+ dodoc ChangeLog readme todo
+}