summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libvorbis/ChangeLog7
-rw-r--r--media-libs/libvorbis/files/digest-libvorbis-1.0.1-r23
-rw-r--r--media-libs/libvorbis/files/digest-libvorbis-1.1.13
-rw-r--r--media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild70
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.0.ebuild6
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.1.ebuild76
6 files changed, 9 insertions, 156 deletions
diff --git a/media-libs/libvorbis/ChangeLog b/media-libs/libvorbis/ChangeLog
index 0f0726c80571..b763c934831f 100644
--- a/media-libs/libvorbis/ChangeLog
+++ b/media-libs/libvorbis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libvorbis
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.71 2007/02/05 12:18:48 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.72 2007/04/15 18:07:32 drac Exp $
+
+ 15 Apr 2007; Samuli Suominen <drac@gentoo.org> -libvorbis-1.0.1-r2.ebuild,
+ libvorbis-1.1.0.ebuild, -libvorbis-1.1.1.ebuild:
+ Remove old versions and leave only mips with no working vorbis support. Bug
+ 155258.
05 Feb 2007; Simon Stelling <blubb@gentoo.org> libvorbis-1.1.2.ebuild:
stable on amd64; bug 155258
diff --git a/media-libs/libvorbis/files/digest-libvorbis-1.0.1-r2 b/media-libs/libvorbis/files/digest-libvorbis-1.0.1-r2
deleted file mode 100644
index 7cbdad53a028..000000000000
--- a/media-libs/libvorbis/files/digest-libvorbis-1.0.1-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4d6726fd02ce02f6e24824e594b0949a libvorbis-1.0.1.tar.gz 1218076
-RMD160 2015bfb9631076862e577e1cab0a8ca20f88780e libvorbis-1.0.1.tar.gz 1218076
-SHA256 20b3cbdb4b05322d470404a7d2e8cdae1e0ce5372113218ae3cada3b29da70f7 libvorbis-1.0.1.tar.gz 1218076
diff --git a/media-libs/libvorbis/files/digest-libvorbis-1.1.1 b/media-libs/libvorbis/files/digest-libvorbis-1.1.1
deleted file mode 100644
index 7062661fcf94..000000000000
--- a/media-libs/libvorbis/files/digest-libvorbis-1.1.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b77270c24840af4de54bea5ad1c0b252 libvorbis-1.1.1.tar.gz 1307726
-RMD160 3454f3f2d5641ba17dd99de0923d7b00ffe891ee libvorbis-1.1.1.tar.gz 1307726
-SHA256 fca2c35d8f1d10e93b80171cae26da1dd03b99fe854a1698d3c47d3b28a40b0f libvorbis-1.1.1.tar.gz 1307726
diff --git a/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild b/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
deleted file mode 100644
index 861be7dd0cc7..000000000000
--- a/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1-r2.ebuild,v 1.18 2006/10/04 17:40:32 grobian Exp $
-
-inherit libtool flag-o-matic toolchain-funcs
-
-DESCRIPTION="the Ogg Vorbis sound file format library"
-HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
-SRC_URI="http://www.vorbis.com/files/${PV}/unix/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=">=media-libs/libogg-1.0"
-DEPEND="${RDEPEND}
- sys-apps/sed"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Fix a gcc crash. With the new atexit patch to gcc, it
- # seems it does not handle -mno-ieee-fp very well.
- sed -i -e "s:-mno-ieee-fp::g" configure
-}
-
-src_compile() {
- elibtoolize
-
- # Cannot compile with sse2 support it would seem #36104
- use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
-
- # take out -fomit-frame-pointer from CFLAGS if k6-2
- is-flag -march=k6-3 && filter-flags -fomit-frame-pointer
- is-flag -march=k6-2 && filter-flags -fomit-frame-pointer
- is-flag -march=k6 && filter-flags -fomit-frame-pointer
-
- # over optimization causes horrible audio artifacts #26463
- filter-flags -march=pentium?
-
- # gcc-3.4 and k6 with -ftracer causes code generation problems #49472
- if [ $(gcc-major-version) -eq 3 -a $(gcc-minor-version) -eq 4 ];
- then
- is-flag -march=k6* && filter-flags -ftracer
- is-flag -mtune=k6* && filter-flags -ftracer
- fi
-
- # gcc on hppa causes issues when assembling
- use hppa && replace-flags -march=2.0 -march=1.0
-
- # Make prelink work properly
- append-flags -fPIC
- append-ldflags -fPIC
-
- econf || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dosym /usr/lib/libvorbisfile.so.3.1.0 /usr/lib/libvorbisfile.so.0
- dosym /usr/lib/libvorbisenc.so.2.0.0 /usr/lib/libvorbisenc.so.0
-
- rm -rf ${D}/usr/share/doc
- dodoc AUTHORS README todo.txt
- docinto txt
- dodoc doc/*.txt
- dohtml -r doc
-}
diff --git a/media-libs/libvorbis/libvorbis-1.1.0.ebuild b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
index fa8b2665ef89..24dbfbd3f67a 100644
--- a/media-libs/libvorbis/libvorbis-1.1.0.ebuild
+++ b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.21 2006/10/04 17:40:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.22 2007/04/15 18:07:32 drac Exp $
inherit libtool flag-o-matic eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
+KEYWORDS="mips"
IUSE="aotuv"
RDEPEND=">=media-libs/libogg-1.0"
diff --git a/media-libs/libvorbis/libvorbis-1.1.1.ebuild b/media-libs/libvorbis/libvorbis-1.1.1.ebuild
deleted file mode 100644
index 0f8750c26396..000000000000
--- a/media-libs/libvorbis/libvorbis-1.1.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.1.ebuild,v 1.4 2006/10/04 17:40:32 grobian Exp $
-
-inherit libtool flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="the Ogg Vorbis sound file format library"
-HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
-SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=media-libs/libogg-1.0"
-DEPEND="${RDEPEND}
- sys-apps/sed"
-
-S=${WORKDIR}/${P/_*/}
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
-
- # Fix a gcc crash. With the new atexit patch to gcc, it
- # seems it does not handle -mno-ieee-fp very well.
- sed -i -e "s:-mno-ieee-fp::g" configure
-
- elibtoolize
-
- epunt_cxx #74493
-}
-
-src_compile() {
- # Cannot compile with sse2 support it would seem #36104
- use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
- [ "`gcc-version`" == "3.4" ] && replace-flags -Os -O2
-
- # take out -fomit-frame-pointer from CFLAGS if k6-2
- is-flag -march=k6-3 && filter-flags -fomit-frame-pointer
- is-flag -march=k6-2 && filter-flags -fomit-frame-pointer
- is-flag -march=k6 && filter-flags -fomit-frame-pointer
-
- # over optimization causes horrible audio artifacts #26463
- filter-flags -march=pentium?
-
- # gcc-3.4 and k6 with -ftracer causes code generation problems #49472
- if [ $(gcc-major-version) -eq 3 -a $(gcc-minor-version) -eq 4 ];
- then
- is-flag -march=k6* && filter-flags -ftracer
- is-flag -mtune=k6* && filter-flags -ftracer
- fi
-
- # gcc on hppa causes issues when assembling
- use hppa && replace-flags -march=2.0 -march=1.0
-
- # Make prelink work properly
- append-flags -fPIC
- append-ldflags -fPIC
-
- econf || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dosym libvorbisfile.so.3.1.0 /usr/$(get_libdir)/libvorbisfile.so.3
- dosym libvorbisenc.so.2.0.1 /usr/$(get_libdir)/libvorbisenc.so.2
-
- rm -rf ${D}/usr/share/doc
- dodoc AUTHORS README todo.txt
- docinto txt
- dodoc doc/*.txt
- dohtml -r doc
-}