summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/arts/ChangeLog7
-rw-r--r--kde-base/arts/arts-1.3.2-r1.ebuild87
-rw-r--r--kde-base/arts/files/digest-arts-1.3.2-r11
-rw-r--r--kde-base/kdebase/ChangeLog10
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.3.2-r21
-rw-r--r--kde-base/kdebase/kdebase-3.3.2-r2.ebuild131
6 files changed, 235 insertions, 2 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index dacb3d1a3a47..a9c2afa5ff7b 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.140 2005/02/05 11:39:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.141 2005/02/07 19:59:15 greg_g Exp $
+
+*arts-1.3.2-r1 (07 Feb 2005)
+
+ 07 Feb 2005; Gregorio Guidi <greg_g@gentoo.org> +arts-1.3.2-r1.ebuild:
+ Remove KDEDIR form the environment (#33079).
*arts-3.4.0_beta2 (05 Feb 2005)
diff --git a/kde-base/arts/arts-1.3.2-r1.ebuild b/kde-base/arts/arts-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..95e20abf4095
--- /dev/null
+++ b/kde-base/arts/arts-1.3.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2-r1.ebuild,v 1.1 2005/02/07 19:59:15 greg_g Exp $
+
+inherit kde flag-o-matic eutils
+set-kdedir 3.3
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV/1.3.2/3.3.2}/src/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~alpha"
+IUSE="alsa oggvorbis esd artswrappersuid jack mad hardened"
+
+DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ esd? ( media-sound/esound )
+ jack? ( media-sound/jack-audio-connection-kit )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ media-libs/audiofile
+ >=dev-libs/glib-2
+ >=x11-libs/qt-3.3"
+
+# patch to configure.in.in that makes the vorbis, libmad deps optional
+# has no version number in its filename because it's the same for all
+# arts versions - the patched file hasn't changed in a year's time
+# PATCHES="$FILESDIR/optional-deps.diff"
+
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/1.3.0-jack-configure.in.in.patch
+ epatch ${FILESDIR}/${P}-alsa-bigendian.patch
+
+ if (is-flag -fstack-protector || is-flag -fstack-protector-all || use hardened); then
+ epatch ${FILESDIR}/arts-1.3.2-mcopidl.patch
+ fi
+
+ kde_sandbox_patch ${S}/soundserver
+ # for the configure.in.in patch, for some reason it's not automatically picked up
+ # rm -f $S/configure
+
+ cd ${S} && make -f admin/Makefile.common
+ # use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
+ # this patch fixes the high cpu usage of mp3 and vorbis
+ # epatch ${FILESDIR}/arts-vorbis-fix.dif
+}
+
+src_compile() {
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ #fix bug 41980
+ use sparc && filter-flags -fomit-frame-pointer
+
+ myconf="$myconf $(use_enable alsa) $(use_enable oggvorbis vorbis) $(use_enable mad libmad) $(use_enable jack)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=\"${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown\"" > ${D}/etc/env.d/47kdepaths-3.3.1 # number goes down with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s ${D}/${PREFIX}/bin/artswrapper
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ einfo "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/digest-arts-1.3.2-r1 b/kde-base/arts/files/digest-arts-1.3.2-r1
new file mode 100644
index 000000000000..0c4a34c7c80d
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.3.2-r1
@@ -0,0 +1 @@
+MD5 a3d22f7cc5c641204a28d3f77e441a84 arts-1.3.2.tar.bz2 968368
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 558a5562fd36..5b26e0c44cec 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.176 2005/02/02 11:16:00 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.177 2005/02/07 20:00:13 greg_g Exp $
+
+*kdebase-3.3.2-r2 (07 Feb 2005)
+
+ 07 Feb 2005; Gregorio Guidi <greg_g@gentoo.org> +kdebase-3.3.2-r2.ebuild:
+ Remove KDEDIR from the environment (#33079). Depend on kdebase-pam as a
+ provider for files in /etc/pam.d (#16022). Set proper permissions on
+ agent-startup.sh and agent-shutdown.sh (#76719, #76720). Make kdm use
+ /usr/share/xsessions to list available sessions.
02 Feb 2005; Heinrich Wendel <lanius@gentoo.org> kdebase-3.4.0_beta1.ebuild:
mark ~amd64
diff --git a/kde-base/kdebase/files/digest-kdebase-3.3.2-r2 b/kde-base/kdebase/files/digest-kdebase-3.3.2-r2
new file mode 100644
index 000000000000..2455650231b9
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.3.2-r2
@@ -0,0 +1 @@
+MD5 edbd721a2a4970977dfe5f45d9e38923 kdebase-3.3.2.tar.bz2 19995043
diff --git a/kde-base/kdebase/kdebase-3.3.2-r2.ebuild b/kde-base/kdebase/kdebase-3.3.2-r2.ebuild
new file mode 100644
index 000000000000..a30848e1079e
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.3.2-r2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.3.2-r2.ebuild,v 1.1 2005/02/07 20:00:13 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~alpha"
+IUSE="ldap pam cups ssl opengl samba java arts"
+
+DEPEND="arts? ( ~kde-base/arts-${PV//3.3/1.3} )
+ pam? ( kde-base/kdebase-pam )
+ ldap? ( net-nds/openldap )
+ cups? ( net-print/cups )
+ ssl? ( dev-libs/openssl )
+ opengl? ( virtual/opengl )
+ samba? ( >=net-fs/samba-3.0.1 )
+ java? ( || ( virtual/jdk virtual/jre ) )"
+
+RDEPEND="${DEPEND}
+ sys-apps/eject"
+
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/konsole-${PV}.patch
+ epatch ${FILESDIR}/post-3.3.2-kdebase-htmlframes2.patch
+ epatch ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff
+}
+
+src_compile() {
+ myconf="$myconf --with-dpms"
+ myconf="$myconf `use_with ldap` `use_with cups`"
+ myconf="$myconf `use_with opengl gl` `use_with ssl`"
+ myconf="$myconf `use_with arts`"
+
+ use pam \
+ && myconf="$myconf --with-pam=yes" \
+ || myconf="$myconf --with-pam=no --with-shadow"
+
+ if use java ; then
+ if has_version virtual/jdk ; then
+ myconf="$myconf --with-java=$(java-config --jdk-home)"
+ else
+ myconf="$myconf --with-java=$(java-config --jre-home)"
+ fi
+ else
+ myconf="$myconf --without-java"
+ fi
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+}
+
+src_install() {
+ kde_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+ # startkde script
+ sed -i -e "s:_KDEDIR_:${KDEDIR}:" ${D}/${KDEDIR}/bin/startkde
+
+ # startup and shutdown scripts
+ dodir ${KDEDIR}/env
+ dodir ${KDEDIR}/shutdown
+
+ insinto ${KDEDIR}/env
+ insopts -m 644
+ doins ${FILESDIR}/agent-startup.sh
+
+ insinto ${KDEDIR}/shutdown
+ insopts -m 755
+ doins ${FILESDIR}/agent-shutdown.sh
+
+ # kcontrol modules
+ cd ${D}/${KDEDIR}/etc/xdg/menus
+ ln -s default_kde-settings.menu kde-settings.menu
+ ln -s default_kde-information.menu kde-information.menu
+ ln -s default_kde-screensavers.menu kde-screensavers.menu
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ sed -e "s:_PREFIX_:${PREFIX}:g" \
+ -e "s:_RANDOM_:${RANDOM}${RANDOM}:g" \
+ ${FILESDIR}/${PVR}/kdmrc > kdmrc
+
+ cp ${FILESDIR}/${PVR}/backgroundrc .
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ dodir /usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+ # Create a kde.desktop file so that a KDE entry will be present in gdm
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ newins ${FILESDIR}/kde.desktop kde-${PV}.desktop
+ sed -i -e "s:_PREFIX_:${KDEDIR}:;s:_VERSION_:${PV}:" \
+ ${D}/usr/share/xsessions/kde-${PV}.desktop
+
+ dodir ${D}/${KDEDIR}/share/services/searchprovider
+ insinto ${D}/${KDEDIR}/share/services/searchprovider
+ newins ${FILESDIR}/pgo.desktop
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+
+ einfo "To enable gpg-agent and/or ssh-agent in KDE sessions,"
+ einfo "edit $KDEDIR/env/agent-startup.sh and $KDEDIR/shutdown/agent-shutdown.sh"
+}