summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libgdata/ChangeLog8
-rw-r--r--dev-libs/libgdata/files/libgdata-0.8.1-gdata-symbols.patch33
-rw-r--r--dev-libs/libgdata/libgdata-0.8.1-r1.ebuild67
3 files changed, 107 insertions, 1 deletions
diff --git a/dev-libs/libgdata/ChangeLog b/dev-libs/libgdata/ChangeLog
index cda0db6734eb..b4285a944d34 100644
--- a/dev-libs/libgdata/ChangeLog
+++ b/dev-libs/libgdata/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgdata
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/ChangeLog,v 1.37 2011/11/08 21:54:10 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/ChangeLog,v 1.38 2011/11/15 22:54:00 tetromino Exp $
+
+*libgdata-0.8.1-r1 (15 Nov 2011)
+
+ 15 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libgdata-0.8.1-r1.ebuild, +files/libgdata-0.8.1-gdata-symbols.patch:
+ Fix building with gobject-introspection-1.30.
*libgdata-0.10.1 (08 Nov 2011)
diff --git a/dev-libs/libgdata/files/libgdata-0.8.1-gdata-symbols.patch b/dev-libs/libgdata/files/libgdata-0.8.1-gdata-symbols.patch
new file mode 100644
index 000000000000..0477b5678101
--- /dev/null
+++ b/dev-libs/libgdata/files/libgdata-0.8.1-gdata-symbols.patch
@@ -0,0 +1,33 @@
+From 60330e8a42e80c4dd647c55a4b99c44d67cedfc0 Mon Sep 17 00:00:00 2001
+From: Philip Withnall <philip@tecnocode.co.uk>
+Date: Mon, 15 Aug 2011 22:15:57 +0100
+Subject: [PATCH] core: Add missing symbols to symbols file
+
+Closes: bgo#656529
+---
+ gdata/gdata.symbols | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/gdata/gdata.symbols b/gdata/gdata.symbols
+index 1220ce9..a2d0590 100644
+--- a/gdata/gdata.symbols
++++ b/gdata/gdata.symbols
+@@ -94,6 +94,7 @@ gdata_query_get_etag
+ gdata_query_set_etag
+ gdata_youtube_standard_feed_type_get_type
+ gdata_youtube_service_error_get_type
++gdata_youtube_service_error_quark
+ gdata_youtube_service_get_type
+ gdata_youtube_service_new
+ gdata_youtube_service_query_standard_feed
+@@ -646,6 +647,7 @@ gdata_documents_query_get_reader_addresses
+ gdata_documents_query_add_reader
+ gdata_documents_query_add_collaborator
+ gdata_documents_service_error_get_type
++gdata_documents_service_error_quark
+ gdata_download_stream_get_type
+ gdata_download_stream_new
+ gdata_download_stream_get_service
+--
+1.7.8.rc1
+
diff --git a/dev-libs/libgdata/libgdata-0.8.1-r1.ebuild b/dev-libs/libgdata/libgdata-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..6be7dde7fe00
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.8.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgdata/libgdata-0.8.1-r1.ebuild,v 1.1 2011/11/15 22:54:00 tetromino Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="http://live.gnome.org/libgdata"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome +introspection"
+
+# gtk+ is needed for gdk
+RDEPEND=">=dev-libs/glib-2.19:2
+ || (
+ >=x11-libs/gdk-pixbuf-2.14:2
+ >=x11-libs/gtk+-2.14:2 )
+ >=dev-libs/libxml2-2:2
+ >=net-libs/libsoup-2.26.1:2.4[introspection?]
+ gnome? ( >=net-libs/libsoup-gnome-2.26.1:2.4[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable gnome)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Disable tests requiring network access, bug #307725
+ sed -e '/^TEST_PROGS = / s:\(.*\):TEST_PROGS = general perf\nOLD_\1:' \
+ -i gdata/tests/Makefile.in || die "network test disable failed"
+
+ # Allow Google Contacts' user defined fields to have empty names, upstream bug #648058
+ epatch "${FILESDIR}/${P}-empty-names.patch"
+
+ # Fix building with gobject-introspection-1.30; fixed in 0.10.x
+ epatch "${FILESDIR}/${P}-gdata-symbols.patch"
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-launch emake check || die "emake check failed"
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgdata.so.7
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libgdata.so.7
+}