summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/qemacs/ChangeLog7
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch10
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r1.ebuild3
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild3
4 files changed, 20 insertions, 3 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 232ac6dc39b7..d77b333450a0 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.12 2005/02/20 11:45:33 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.13 2005/03/06 02:49:03 josejx Exp $
+
+ 06 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+ +files/qemacs-0.3.1-gcc-3.4.patch, qemacs-0.3.1-r1.ebuild,
+ qemacs-0.3.1.ebuild:
+ Added patch to fix compiling on gcc 3.4.
*qemacs-0.3.1-r1 (20 Feb 2005)
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
new file mode 100644
index 000000000000..121988feec24
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
@@ -0,0 +1,10 @@
+--- unicode_join.c 2005-03-06 13:20:10.849453136 +1100
++++ unicode_join.c.new 2005-03-06 13:20:05.472270592 +1100
+@@ -182,6 +182,7 @@
+ *q++ = l1;
+ i++;
+ found:
++ ;
+ }
+ }
+ return q - buf_out;
diff --git a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
index 1a3da3a8c127..dbc68c98b1fc 100644
--- a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.1 2005/02/20 11:45:33 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.2 2005/03/06 02:49:03 josejx Exp $
inherit eutils
@@ -22,6 +22,7 @@ src_unpack() {
epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
epatch ${FILESDIR}/${P}-configure-gentoo.patch
epatch ${FILESDIR}/${P}-make_backup.patch
+ epatch ${FILESDIR}/${PN}-0.3.1-gcc-3.4.patch
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
index 327c61367aff..9a71686a97b3 100644
--- a/app-editors/qemacs/qemacs-0.3.1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.14 2005/01/01 13:33:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.15 2005/03/06 02:49:03 josejx Exp $
inherit eutils
@@ -21,6 +21,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
epatch ${FILESDIR}/qemacs-${PV}-configure-gentoo.patch
+ epatch ${FILESDIR}/${P}-gcc-3.4.patch
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}