summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytz/ChangeLog7
-rw-r--r--dev-python/pytz/pytz-2014.4.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pytz/ChangeLog b/dev-python/pytz/ChangeLog
index 1f53fc3f41b3..7394173ce287 100644
--- a/dev-python/pytz/ChangeLog
+++ b/dev-python/pytz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytz
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.176 2014/05/18 02:35:46 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/ChangeLog,v 1.177 2014/06/18 07:40:54 idella4 Exp $
+
+*pytz-2014.4 (18 Jun 2014)
+
+ 18 Jun 2014; Ian Delaney <idella4@gentoo.org> +pytz-2014.4.ebuild:
+ bump
*pytz-2014.3 (18 May 2014)
diff --git a/dev-python/pytz/pytz-2014.4.ebuild b/dev-python/pytz/pytz-2014.4.ebuild
new file mode 100644
index 000000000000..405406b30100
--- /dev/null
+++ b/dev-python/pytz/pytz-2014.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytz/pytz-2014.4.ebuild,v 1.1 2014/06/18 07:40:54 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sys-libs/timezone-data-2014b"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}/${PN}-2009j-zoneinfo.patch"
+ # ...and do not install a copy of it.
+ "${FILESDIR}/${PN}-2009h-zoneinfo-noinstall.patch"
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}