summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/gmrun/ChangeLog10
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch45
-rw-r--r--x11-misc/gmrun/gmrun-0.9.2-r1.ebuild39
3 files changed, 92 insertions, 2 deletions
diff --git a/x11-misc/gmrun/ChangeLog b/x11-misc/gmrun/ChangeLog
index 9123823d0ebf..7d62b31ea804 100644
--- a/x11-misc/gmrun/ChangeLog
+++ b/x11-misc/gmrun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/gmrun
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/ChangeLog,v 1.19 2009/08/09 18:54:05 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/ChangeLog,v 1.20 2010/06/06 13:13:11 ssuominen Exp $
+
+*gmrun-0.9.2-r1 (06 Jun 2010)
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +gmrun-0.9.2-r1.ebuild, +files/gmrun-0.9.2-sysconfdir.patch:
+ Use sysconfdir for gmrunrc wrt #292856 by Łukasz Stelmach.
09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> gmrun-0.9.2.ebuild:
Apply glibc patch only if >= 2.10 since it's not backward compatible.
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
new file mode 100644
index 000000000000..cd6fc1c87577
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/292856
+
+diff -ur gmrun-0.9.2.orig/config/Makefile.am gmrun-0.9.2/config/Makefile.am
+--- gmrun-0.9.2.orig/config/Makefile.am 2001-05-17 09:58:07.000000000 +0300
++++ gmrun-0.9.2/config/Makefile.am 2010-06-06 16:05:16.000000000 +0300
+@@ -1,6 +1,6 @@
+ # $Id: gmrun-0.9.2-sysconfdir.patch,v 1.1 2010/06/06 13:13:11 ssuominen Exp $
+
+-myrcdir = @PACKAGE_DATA_DIR@
++myrcdir = $(sysconfdir)
+ myrc_DATA = gmrunrc
+
+ EXTRA_DIST = gmrunrc
+diff -ur gmrun-0.9.2.orig/config.h.in gmrun-0.9.2/config.h.in
+--- gmrun-0.9.2.orig/config.h.in 2003-11-16 12:47:07.000000000 +0200
++++ gmrun-0.9.2/config.h.in 2010-06-06 16:07:14.000000000 +0300
+@@ -10,7 +10,6 @@
+ #undef HAVE_STPCPY
+ #undef HAVE_LIBSM
+ #undef PACKAGE_LOCALE_DIR
+-#undef PACKAGE_DATA_DIR
+ #undef PACKAGE_SOURCE_DIR
+
+ /* Define if you have the <dirent.h> header file. */
+diff -ur gmrun-0.9.2.orig/src/Makefile.am gmrun-0.9.2/src/Makefile.am
+--- gmrun-0.9.2.orig/src/Makefile.am 2002-06-05 22:39:18.000000000 +0300
++++ gmrun-0.9.2/src/Makefile.am 2010-06-06 16:09:11.000000000 +0300
+@@ -15,3 +15,5 @@
+
+ gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
+
++AM_CPPFLAGS = \
++ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+diff -ur gmrun-0.9.2.orig/src/prefs.cc gmrun-0.9.2/src/prefs.cc
+--- gmrun-0.9.2.orig/src/prefs.cc 2002-08-16 13:48:22.000000000 +0300
++++ gmrun-0.9.2/src/prefs.cc 2010-06-06 16:07:14.000000000 +0300
+@@ -30,7 +30,7 @@
+
+ Prefs::Prefs()
+ {
+- string file_name = PACKAGE_DATA_DIR"/";
++ string file_name = PACKAGE_SYSCONF_DIR"/";
+ file_name += GMRUNRC;
+ init(file_name);
+
diff --git a/x11-misc/gmrun/gmrun-0.9.2-r1.ebuild b/x11-misc/gmrun/gmrun-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..68a5e7041e49
--- /dev/null
+++ b/x11-misc/gmrun/gmrun-0.9.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gmrun/gmrun-0.9.2-r1.ebuild,v 1.1 2010/06/06 13:13:11 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
+HOMEPAGE="http://www.bazon.net/mishoo/gmrun.epl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/sed"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-sysconfdir.patch
+
+ has_version ">=sys-libs/glibc-2.10" && epatch \
+ "${FILESDIR}"/${P}-glibc210.patch
+
+ # Disable check for STLport due to bug #164339
+ sed -i -e 's,^AC_PATH_STLPORT,dnl REMOVED ,g' configure.in
+ sed -i -e 's,@STLPORT_[A-Z]\+@,,g' src/Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}