summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/ttmkfdir/ChangeLog8
-rw-r--r--x11-misc/ttmkfdir/Manifest5
-rw-r--r--x11-misc/ttmkfdir/files/digest-ttmkfdir-3.0.9-r11
-rw-r--r--x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-cpp.patch11
-rw-r--r--x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-zlib.patch80
-rw-r--r--x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild41
6 files changed, 142 insertions, 4 deletions
diff --git a/x11-misc/ttmkfdir/ChangeLog b/x11-misc/ttmkfdir/ChangeLog
index f90141972e11..27fb2bbed9d8 100644
--- a/x11-misc/ttmkfdir/ChangeLog
+++ b/x11-misc/ttmkfdir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/ttmkfdir
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.19 2003/08/04 22:43:35 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.20 2003/11/01 22:45:05 azarah Exp $
+
+*ttmkfdir-3.0.9-r1 (02 Nov 2003)
+
+ 02 Nov 2003; Martin Schlemmer <azarah@gentoo.org> ttmkfdir-3.0.9-r1.ebuild,
+ files/ttmkfdir-3.0.9-cpp.patch, files/ttmkfdir-3.0.9-zlib.patch:
+ Add patches from Redhat to fix my gcc3 patch, and add native gzip support.
21 Jul 2003; Martin Schlemmer <azarah@gentoo.org> ttmkfdir-3.0.4.ebuild,
ttmkfdir-3.0.9.ebuild, files/ttmkfdir-3.0.9-gcc33.patch:
diff --git a/x11-misc/ttmkfdir/Manifest b/x11-misc/ttmkfdir/Manifest
index f9bedcf7dafb..b367a6d063ac 100644
--- a/x11-misc/ttmkfdir/Manifest
+++ b/x11-misc/ttmkfdir/Manifest
@@ -1,8 +1,7 @@
-MD5 0b671b11f88a332139c0296c55ef219e ChangeLog 2505
-MD5 5f2783f7f4559eac77f15b9be5627e81 .ttmkfdir-3.0.9-r1.ebuild.swp 12288
+MD5 f47906fe6e869c71a0f79cf120d0f8dc ChangeLog 2762
MD5 4ccaa4ddc197e8644e2beb8cf00a034e ttmkfdir-3.0.4.ebuild 850
MD5 aa4d89c1cea6130ad879b0367270b33b ttmkfdir-2.0-r1.ebuild 1080
-MD5 d78bf9e9a200577004329de1acef0d4b ttmkfdir-3.0.9-r1.ebuild 894
+MD5 871fd2ea40317da9884ace367a364142 ttmkfdir-3.0.9-r1.ebuild 909
MD5 3dba93d6486b6147f1803b90e1252884 ttmkfdir-3.0.9.ebuild 862
MD5 b0ff26a7aca78ec1f51dfedec0d0aa08 ttmkfdir-2.0.ebuild 918
MD5 2a9b31af99fcc5a47f1a659615c185f3 ttmkfdir-1.0.ebuild 768
diff --git a/x11-misc/ttmkfdir/files/digest-ttmkfdir-3.0.9-r1 b/x11-misc/ttmkfdir/files/digest-ttmkfdir-3.0.9-r1
new file mode 100644
index 000000000000..23c8357a597c
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/digest-ttmkfdir-3.0.9-r1
@@ -0,0 +1 @@
+MD5 7fbf13e432aa519669899b13d00673f3 ttmkfdir-3.0.9.tar.bz2 20160
diff --git a/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-cpp.patch b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-cpp.patch
new file mode 100644
index 000000000000..58839eda9673
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-cpp.patch
@@ -0,0 +1,11 @@
+--- ttmkfdir-3.0.9/ttf.cpp.sopwith Thu Aug 7 12:49:08 2003
++++ ttmkfdir-3.0.9/ttf.cpp Thu Aug 7 12:50:01 2003
+@@ -239,7 +239,7 @@
+ for (i = 0; i < n; i++) {
+ if ((fterror = FT_Get_Sfnt_Name (face, i, &NamePtr)) != FT_Err_Ok) {
+ std::cout << "Warning: Can't SFNT name : " << FileName << "(" << fterror << ")" << std::endl;
+- return;
++ return NULL;
+ };
+ platform = NamePtr.platform_id;
+ encoding = NamePtr.encoding_id;
diff --git a/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-zlib.patch b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-zlib.patch
new file mode 100644
index 000000000000..548a49e3c669
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-zlib.patch
@@ -0,0 +1,80 @@
+--- ttmkfdir-3.0.9/encoding.cpp 2002-12-09 03:52:48.000000000 -0500
++++ ttmkfdir-3.0.9/encoding.cpp 2003-09-12 12:32:29.000000000 -0400
+@@ -2,6 +2,8 @@
+ #include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
++#include <unistd.h>
++#include <zlib.h>
+ #include "freetype/freetype.h"
+
+ #include "ttmkfdir.h"
+@@ -32,9 +34,16 @@
+ NextFile (FILE *f, char *name)
+ {
+ char file_name [1024];
+- char command[1024];
++ char line_buf [1024];
++ char tmp_file_name[] = "/tmp/ttmkfdir_XXXXXX";
++ char inbuf[300000];
++ FILE *od;
++ gzFile fd;
++ int rvalue, tmpfd;
+
+- if (fscanf (f, "%*s %[^\n]\n", file_name) == 1) {
++ if (fgets (line_buf, sizeof(line_buf), f) != NULL) {
++
++ sscanf (line_buf, "%*s %[^\n]\n", file_name);
+
+ if (file_name[0] == '/') {
+ name[0] = 0;
+@@ -44,9 +53,25 @@
+
+ strcat (name, file_name);
+
+- sprintf (command, "exec %s < %s", (toupper(name[strlen (name) - 1]) == 'Z')
+- ? "gzip -d" : "cat", name);
+- return popen (command, "r");
++ bzero(inbuf, sizeof(inbuf));
++
++ fd = gzopen (name,"rb");
++ rvalue = gzread (fd, inbuf, sizeof(inbuf));
++
++ tmpfd = mkstemp (tmp_file_name);
++ if (tmpfd == -1) {
++ return 0;
++ }
++
++ od = fdopen (tmpfd,"w");
++ fputs (inbuf, od);
++ fflush (od);
++ fclose (od);
++
++ od = fopen (tmp_file_name,"r");
++ unlink (tmp_file_name);
++ return od;
++
+ }
+
+ return 0;
+@@ -75,7 +100,7 @@
+ yyrestart (input);
+ yylex (name, *this);
+
+- pclose (input);
++ fclose (input);
+ }
+
+ fclose (f);
+diff -uNr ttmkfdir-3.0.9.orig/Makefile ttmkfdir-3.0.9/Makefile
+--- ttmkfdir-3.0.9.orig/Makefile 2003-08-21 17:43:13.000000000 +1000
++++ ttmkfdir-3.0.9/Makefile 2003-08-21 17:40:16.000000000 +1000
+@@ -28,7 +28,7 @@
+ DEBUG=-ggdb
+ CXX=g++
+ CXXFLAGS=-Wall -pedantic $(FREETYPE_INCL) $(DEBUG) $(OPTFLAGS)
+-LDFLAGS=$(FREETYPE_LIB) $(DEBUG)
++LDFLAGS=$(FREETYPE_LIB) $(DEBUG) -lz
+
+ DESTDIR=
+ PREFIX=/usr
diff --git a/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild b/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..a8a544cc54b8
--- /dev/null
+++ b/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild,v 1.1 2003/11/01 22:45:05 azarah Exp $
+
+IUSE=
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A utility to create a fonts.scale file from a set of TrueType fonts"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.joerg-pommnitz.de/TrueType/xfsft.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~ppc ~alpha ~arm ~hppa ~ia64"
+
+DEPEND=">=media-libs/freetype-2.0.8
+ >=sys-devel/flex-2.5.4a-r5
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-cpp.patch
+ epatch ${FILESDIR}/${P}-zlib.patch
+}
+
+src_compile() {
+ make CXX="${CXX:=g++}" \
+ OPTFLAGS="${CFLAGS}" DEBUG="" || die
+}
+
+src_install() {
+ exeinto /usr/X11R6/bin
+ doexe ${S}/ttmkfdir
+
+ dodoc ${S}/README
+}
+