summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PECL-sqlite/ChangeLog9
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild29
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild6
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild32
-rw-r--r--dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.01
-rw-r--r--dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r11
6 files changed, 10 insertions, 68 deletions
diff --git a/dev-php/PECL-sqlite/ChangeLog b/dev-php/PECL-sqlite/ChangeLog
index 93f7899d43c5..f792513a38eb 100644
--- a/dev-php/PECL-sqlite/ChangeLog
+++ b/dev-php/PECL-sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PECL-sqlite
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/ChangeLog,v 1.14 2004/12/30 20:39:38 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/ChangeLog,v 1.15 2005/07/11 17:40:17 sebastian Exp $
+
+ 11 Jul 2005; Sebastian Bergmann <sebastian@gentoo.org>
+ -PECL-sqlite-1.0.ebuild, -PECL-sqlite-1.0-r1.ebuild,
+ PECL-sqlite-1.0.3.ebuild:
+ Stable on x86. Remove old versions.
30 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild
deleted file mode 100644
index 3d62a143f0ff..000000000000
--- a/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0-r1.ebuild,v 1.3 2004/08/05 23:28:14 arj Exp $
-
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_INI="yes"
-PHP_EXT_PECL_PKG="SQLite"
-
-inherit php-ext-pecl
-
-DEPEND="${DEPEND} =dev-db/sqlite-2* !dev-php/sqlite-php"
-
-IUSE=""
-DESCRIPTION="PHP bindings for the SQLite database engine"
-HOMEPAGE="http://pear.php.net/SQLite"
-SLOT="0"
-LICENSE="PHP"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc"
-
-src_compile() {
- #use the external library, not the bundled one
- myconf="${myconf} --with-sqlite=/usr"
- php-ext-pecl_src_compile
-}
-
-src_install() {
- php-ext-pecl_src_install
- dodoc README TODO
-}
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild
index edaeaef5b57c..56e03dd5f511 100644
--- a/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild
+++ b/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild,v 1.3 2004/11/29 12:26:33 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.3.ebuild,v 1.4 2005/07/11 17:40:17 sebastian Exp $
PHP_EXT_ZENDEXT="no"
PHP_EXT_INI="yes"
@@ -16,7 +16,7 @@ DESCRIPTION="PHP bindings for the SQLite database engine"
HOMEPAGE="http://pear.php.net/SQLite"
SLOT="0"
LICENSE="PHP"
-KEYWORDS="~x86 ~alpha ~sparc ~ppc ~ia64 ~amd64"
+KEYWORDS="x86 ~alpha ~sparc ~ppc ~ia64 ~amd64"
src_compile() {
if has_version ">=virtual/php-5.0.0"; then
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
deleted file mode 100644
index 3fc160ff3663..000000000000
--- a/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild,v 1.5 2004/08/05 23:28:14 arj Exp $
-
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_NAME="sqlite"
-PHP_EXT_INI="yes"
-
-inherit php-ext-source
-
-DEPEND="${DEPEND} =dev-db/sqlite-2* !dev-php/sqlite-php"
-
-IUSE=""
-DESCRIPTION="PHP bindings for the SQLite database engine"
-HOMEPAGE="http://pear.php.net/SQLite"
-SLOT="0"
-MY_PN="SQLite"
-SRC_URI="http://pear.php.net/get/${MY_PN}-${PV}.tgz"
-S=${WORKDIR}/${MY_PN}-${PV}
-LICENSE="PHP"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc"
-
-src_compile() {
- #use the external library, not the bundled one
- myconf="${myconf} --with-sqlite=/usr"
- php-ext-source_src_compile
-}
-
-src_install() {
- php-ext-source_src_install
- dodoc CREDITS README TODO
-}
diff --git a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0 b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0
deleted file mode 100644
index 668759b24fc9..000000000000
--- a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fabecdcdbeecd260cc05f90e4fcc79b8 SQLite-1.0.tgz 354024
diff --git a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1 b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1
deleted file mode 100644
index 668759b24fc9..000000000000
--- a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fabecdcdbeecd260cc05f90e4fcc79b8 SQLite-1.0.tgz 354024