summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/cjk-latex/ChangeLog6
-rw-r--r--dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild11
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-tex/cjk-latex/ChangeLog b/dev-tex/cjk-latex/ChangeLog
index 3b59f7c6b691..d85daeef06f5 100644
--- a/dev-tex/cjk-latex/ChangeLog
+++ b/dev-tex/cjk-latex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tex/cjk-latex
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cjk-latex/ChangeLog,v 1.72 2015/04/29 15:41:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cjk-latex/ChangeLog,v 1.73 2015/07/26 07:32:09 aballier Exp $
+
+ 26 Jul 2015; Alexis Ballier <aballier@gentoo.org> cjk-latex-4.8.4.ebuild:
+ fix build with kpathsea from texlive 2015, add explicit dep on it, bug
+ #555868
29 Apr 2015; Alexis Ballier <aballier@gentoo.org> -cjk-latex-4.8.2.ebuild,
-cjk-latex-4.8.3.ebuild, -files/cjk-latex-4.8.2-kpathsea_version.patch:
diff --git a/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild b/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
index 32860809a877..7a709146c592 100644
--- a/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
+++ b/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild,v 1.1 2015/04/29 15:38:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild,v 1.2 2015/07/26 07:32:09 aballier Exp $
EAPI=4
-inherit latex-package elisp-common toolchain-funcs multilib eutils
+inherit latex-package elisp-common toolchain-funcs multilib eutils flag-o-matic
MY_P="${P/-latex/}"
@@ -20,9 +20,11 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc emacs"
-DEPEND="virtual/latex-base
+RDEPEND="virtual/latex-base
+ dev-libs/kpathsea
emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
app-arch/unzip"
S="${WORKDIR}/${MY_P}"
@@ -38,6 +40,7 @@ src_prepare() {
}
src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
cd utils
for d in *conv; do
cd $d