summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/k3studio/ChangeLog4
-rw-r--r--media-gfx/k3studio/files/digest-k3studio-0.971
-rw-r--r--media-gfx/k3studio/files/digest-k3studio-0.981
-rw-r--r--media-gfx/k3studio/k3studio-0.98.ebuild (renamed from media-gfx/k3studio/k3studio-0.97.ebuild)21
4 files changed, 11 insertions, 16 deletions
diff --git a/media-gfx/k3studio/ChangeLog b/media-gfx/k3studio/ChangeLog
index 620d4716c74d..709c3bcdc394 100644
--- a/media-gfx/k3studio/ChangeLog
+++ b/media-gfx/k3studio/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for media-gfx/k3studio
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/ChangeLog,v 1.2 2002/07/05 00:29:21 verwilst Exp $
+
+*k3studio-0.98 (5 July 2002) Bart Verwilst <verwilst@gentoo.org>
*k3studio-0.97 (1 Feb 2002)
diff --git a/media-gfx/k3studio/files/digest-k3studio-0.97 b/media-gfx/k3studio/files/digest-k3studio-0.97
deleted file mode 100644
index acf673c9a673..000000000000
--- a/media-gfx/k3studio/files/digest-k3studio-0.97
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4142143957fdc5bc47501876af4a2323 k3studio-0.97.tar.gz 1449271
diff --git a/media-gfx/k3studio/files/digest-k3studio-0.98 b/media-gfx/k3studio/files/digest-k3studio-0.98
new file mode 100644
index 000000000000..d3ea1db6902d
--- /dev/null
+++ b/media-gfx/k3studio/files/digest-k3studio-0.98
@@ -0,0 +1 @@
+MD5 c290a1c76fbaa9629784667b98ebd346 k3studio-0.98.tar.gz 1783834
diff --git a/media-gfx/k3studio/k3studio-0.97.ebuild b/media-gfx/k3studio/k3studio-0.98.ebuild
index 4fc31e233a4d..3d6d5cf8ab28 100644
--- a/media-gfx/k3studio/k3studio-0.97.ebuild
+++ b/media-gfx/k3studio/k3studio-0.98.ebuild
@@ -1,34 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/k3studio-0.97.ebuild,v 1.5 2002/07/01 21:33:31 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/k3studio-0.98.ebuild,v 1.1 2002/07/05 00:29:21 verwilst Exp $
inherit kde-base || die
-need-kde 2.1
+need-kde 3
LICENSE="GPL-2"
-newdepend "=dev-lang/python-2.0*
+newdepend "=dev-lang/python-2.2*
>=media-libs/glut-3.7
>=sys-libs/readline-4.1
>=media-libs/freetype-2.0.5
- >=media-libs/qhull-3.1
- "
-# >=media-libs/gle
-# >=media-libs/nurbs++
-# >=media-libs/libvrml97
-# >=media-libs/gltt
+ >=media-libs/qhull-3.1"
DESCRIPTION="KDE universal workbench for 2D/3D modeling, visualization and simulation."
-SRC_URI="mirror://sourceforge/k3studio/k3studio-0.97.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://k3studio.sourceforge.net"
src_compile() {
myconf="--with-qhull-includes=/usr/include/qhull"
myconf="$myconf --with-qhull-libraries=/usr/lib"
- myconf="$myconf --with-python-includes=/usr/include/python2.0"
- myconf="$myconf --with-python-libraries=\\\"-L. -L/usr/lib/python2.0/config `python-config`\\\""
+ myconf="$myconf --with-python-includes=/usr/include/python2.2"
+ myconf="$myconf --with-python-libraries=\\\"-L. -L/usr/lib/python2.2/config `python-config`\\\""
- echo $myconf
kde_src_compile myconf
kde_src_compile configure
kde_src_compile make