summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/alephone/ChangeLog10
-rw-r--r--games-fps/alephone/alephone-20120514.ebuild97
-rw-r--r--games-fps/alephone/files/alephone-20120514-gcc47.patch11
-rw-r--r--games-fps/alephone/files/alephone-20120514-png15.patch11
4 files changed, 127 insertions, 2 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index 2823a51ae4d7..18cd318a7af7 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.41 2012/10/15 08:50:20 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.42 2013/02/18 20:40:12 hasufell Exp $
+
+*alephone-20120514 (18 Feb 2013)
+
+ 18 Feb 2013; Julian Ospald <hasufell@gentoo.org> +alephone-20120514.ebuild,
+ +files/alephone-20120514-gcc47.patch, +files/alephone-20120514-png15.patch:
+ version bump
15 Oct 2012; Tupone Alfredo <tupone@gentoo.org> alephone-20100424.ebuild,
+files/alephone-20100424-gcc47.patch:
diff --git a/games-fps/alephone/alephone-20120514.ebuild b/games-fps/alephone/alephone-20120514.ebuild
new file mode 100644
index 000000000000..1d019b51a8bb
--- /dev/null
+++ b/games-fps/alephone/alephone-20120514.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20120514.ebuild,v 1.1 2013/02/18 20:40:12 hasufell Exp $
+
+EAPI=5
+inherit autotools eutils games
+
+MY_P=AlephOne-${PV}
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa mad mpeg sndfile speex truetype vorbis"
+
+RDEPEND="media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libsdl[video]
+ dev-libs/expat
+ dev-libs/zziplib
+ media-libs/libpng:0
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-libs/libmad )
+ mpeg? ( media-libs/smpeg )
+ virtual/opengl
+ virtual/glu
+ sndfile? ( media-libs/libsndfile )
+ speex? ( media-libs/speex )
+ truetype? ( media-libs/sdl-ttf )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die
+
+ # try using the system expat - bug #251108
+ sed -i \
+ -e '/SUBDIRS/ s/Expat//' \
+ -e 's/Expat\/libexpat.a/-lexpat/' \
+ Source_Files/Makefile.am \
+ || die
+ sed -i \
+ -e '/Expat/d' \
+ configure.ac \
+ || die
+ rm -r Source_Files/Expat || die
+
+ # for automake 1.12 compability - bug #422557
+ sed -i -e 's:AC_PROG_CC:&\nAC_PROG_OBJCXX:' configure.ac || die
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-png15.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --enable-lua \
+ $(use_enable alsa) \
+ $(use_enable mad) \
+ $(use_enable mpeg smpeg) \
+ --enable-opengl \
+ $(use_enable sndfile) \
+ $(use_enable speex) \
+ $(use_enable truetype ttf) \
+ $(use_enable vorbis)
+}
+
+src_install() {
+ default
+ dogamesbin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ dohtml docs/*.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.bungie.org/index.php/Aleph_One_install_guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone-20120514-gcc47.patch b/games-fps/alephone/files/alephone-20120514-gcc47.patch
new file mode 100644
index 000000000000..0f6cac2e94c7
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20120514-gcc47.patch
@@ -0,0 +1,11 @@
+--- AlephOne-20120514/Source_Files/Lua/lua_templates.h
++++ AlephOne-20120514/Source_Files/Lua/lua_templates.h
+@@ -496,7 +496,7 @@
+ static index_t ToIndex(lua_State *L, int index) {
+ index_t to;
+ if(lua_isnil(L, index)) return -1;
+- else if(_lookup(L, index, to)) return to;
++ else if(L_LazyEnum::_lookup(L, index, to)) return to;
+ else {
+ std::string error;
+ if(lua_isnumber(L, index) || lua_isstring(L, index))
diff --git a/games-fps/alephone/files/alephone-20120514-png15.patch b/games-fps/alephone/files/alephone-20120514-png15.patch
new file mode 100644
index 000000000000..bb99d7ed3245
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20120514-png15.patch
@@ -0,0 +1,11 @@
+--- AlephOne-20120514/Source_Files/RenderOther/IMG_savepng.c
++++ AlephOne-20120514/Source_Files/RenderOther/IMG_savepng.c
+@@ -86,7 +86,7 @@ int IMG_SavePNG_RW(SDL_RWops *src, SDL_S
+ goto savedone;
+ }
+ /* setup custom writer functions */
+- png_set_write_fn(png_ptr,(voidp)src,png_write_data,NULL);
++ png_set_write_fn(png_ptr,(png_voidp)src,png_write_data,NULL);
+
+ if (setjmp(png_jmpbuf(png_ptr))){
+ SDL_SetError("Unknown error writing PNG");