summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/esound/ChangeLog9
-rw-r--r--media-sound/esound/esound-0.2.40.ebuild71
2 files changed, 79 insertions, 1 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index dbd8e13eb683..770ae07cd4c5 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.117 2008/07/21 17:07:00 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.118 2008/09/07 18:48:48 eva Exp $
+
+*esound-0.2.40 (07 Sep 2008)
+
+ 07 Sep 2008; Gilles Dartiguelongue <eva@gentoo.org> +esound-0.2.40.ebuild:
+ bump to 0.2.40,
+ * Fixed poll() logic issues for *BSD (Jeffrey Stedfast)
+ * Fixed bug #543239 by including errno.h (Jeffrey Stedfast)
21 Jul 2008; Rémi Cardona <remi@gentoo.org>
+files/esound-0.2.39-fix-errno.patch, esound-0.2.39.ebuild:
diff --git a/media-sound/esound/esound-0.2.40.ebuild b/media-sound/esound/esound-0.2.40.ebuild
new file mode 100644
index 000000000000..ed76c7d26cb2
--- /dev/null
+++ b/media-sound/esound/esound-0.2.40.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.40.ebuild,v 1.1 2008/09/07 18:48:48 eva Exp $
+
+inherit libtool gnome.org eutils flag-o-matic
+
+DESCRIPTION="The Enlightened Sound Daemon"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug doc ipv6 tcpd"
+
+# esound comes with arts support, but it hasn't been tested yet, feel free to
+# submit patches/improvements
+COMMON_DEPEND=">=media-libs/audiofile-0.1.5
+ alsa? ( >=media-libs/alsa-lib-0.5.10b )
+ doc? ( app-text/docbook-sgml-utils )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+# arts? ( kde-base/arts )
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ app-admin/eselect-esd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.2.39-fix-errno.patch"
+}
+
+src_compile() {
+ # Strict aliasing problem
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/esd \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_enable alsa) \
+ $(use_with tcpd libwrap) \
+ --disable-dependency-tracking \
+ || die "Configure failed"
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Installation failed"
+ mv "${D}/usr/bin/"{esd,esound-esd}
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TIPS TODO
+
+ newconfd "${FILESDIR}/esound.conf.d" esound
+
+ extradepend=""
+ use tcpd && extradepend=" portmap"
+ use alsa && extradepend="$extradepend alsasound"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/esound.init.d.2" >"${T}/esound"
+ doinitd "${T}/esound"
+}
+
+pkg_postinst() {
+ eselect esd update --if-unset \
+ || die "eselect failed, try removing /usr/bin/esd and re-emerging."
+}