summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/pymol/ChangeLog8
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.3-prefix.patch57
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.3-web.patch16
-rw-r--r--sci-chemistry/pymol/pymol-1.5.0.3.ebuild120
4 files changed, 200 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 10250bc2c153..3aa6322d350e 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.85 2012/02/27 22:53:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.86 2012/03/10 09:31:31 jlec Exp $
+
+*pymol-1.5.0.3 (10 Mar 2012)
+
+ 10 Mar 2012; Justin Lecher <jlec@gentoo.org> +pymol-1.5.0.3.ebuild,
+ +files/pymol-1.5.0.3-prefix.patch, +files/pymol-1.5.0.3-web.patch:
+ Version BUmp
*pymol-1.5.0.2 (27 Feb 2012)
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.3-prefix.patch b/sci-chemistry/pymol/files/pymol-1.5.0.3-prefix.patch
new file mode 100644
index 000000000000..9b0bad342e19
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.3-prefix.patch
@@ -0,0 +1,57 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 3983)
++++ setup.py (working copy)
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!@GENTOO_PORTAGE_EPREFIX@/usr/bin/env python
+ #
+ # This script only applies if you are performing a Python Distutils-based
+ # installation of PyMOL.
+@@ -35,7 +35,7 @@
+ "modules/cealign/src/tnt" ]
+ libs=["glut32","opengl32","glu32","png"]
+ pyogl_libs = ["glut32","opengl32","glu32"]
+- lib_dirs=["/usr/lib/w32api"]
++ lib_dirs=["@GENTOO_PORTAGE_EPREFIX@/usr/lib/w32api"]
+ def_macros=[("_PYMOL_MODULE",None),
+ ("CYGWIN",None),
+ ("_PYMOL_LIBPNG",None)]
+@@ -87,7 +87,7 @@
+ "/sw/include/freetype2/freetype",
+ "/sw/include/freetype2",
+ "/sw/include",
+- "/usr/X11/include",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/X11/include",
+ "modules/cealign/src",
+ "modules/cealign/src/tnt",
+ #"contrib/uiuc/plugins/include/",
+@@ -114,8 +114,8 @@
+ ext_comp_args=[]
+ ext_link_args=[
+ "-L/sw/lib", "-lpng",
+- "/usr/X11/lib/libGL.dylib",
+- "/usr/X11/lib/libGLU.dylib",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/X11/lib/libGL.dylib",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/X11/lib/libGLU.dylib",
+ "-lfreeglut",
+ "-lglew",
+ "-L/sw/lib/freetype219/lib", "-lfreetype"
+@@ -221,7 +221,7 @@
+ "layer3",
+ "layer4",
+ "layer5",
+- "/usr/include/freetype2",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/include/freetype2",
+ # VMD plugin support
+ # "contrib/uiuc/plugins/include",
+ # "contrib/uiuc/plugins/molfile_plugin/src",
+@@ -242,7 +242,7 @@
+ "GLU",
+ "glut",
+ "GLEW"]
+- lib_dirs = [ "/usr/X11R6/lib64", ]
++ lib_dirs = [ "@GENTOO_PORTAGE_EPREFIX@/usr/X11R6/lib64", ]
+ def_macros = [ ("_PYMOL_MODULE",None),
+ ("_PYMOL_INLINE",None),
+ ("_PYMOL_FREETYPE",None),
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.3-web.patch b/sci-chemistry/pymol/files/pymol-1.5.0.3-web.patch
new file mode 100644
index 000000000000..4f48140169cc
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.3-web.patch
@@ -0,0 +1,16 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 3983)
++++ setup.py (working copy)
+@@ -292,10 +292,7 @@
+ 'pymol/opengl/glu',
+ 'pymol/opengl/glut',
+ 'pymol/wizard',
+- 'pymol2',
+- 'web',
+- 'web/examples',
+- 'web/javascript', ],
++ 'pymol2', ],
+ ext_modules = [
+ Extension("pymol._cmd", [
+ "modules/cealign/src/ccealignmodule.cpp",
diff --git a/sci-chemistry/pymol/pymol-1.5.0.3.ebuild b/sci-chemistry/pymol/pymol-1.5.0.3.ebuild
new file mode 100644
index 000000000000..b79c7aa3e1ce
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.5.0.3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.5.0.3.ebuild,v 1.1 2012/03/10 09:31:31 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.* *-jython 2.7-pypy-*"
+PYTHON_USE_WITH="tk"
+PYTHON_MODNAME="${PN} chempy pmg_tk pmg_wx"
+
+inherit distutils eutils fdo-mime prefix versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz
+ http://dev.gentoo.org/~jlec/distfiles/${PN}.xpm.tar"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="apbs numpy vmd web"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/pmw
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ media-libs/freeglut
+ apbs? (
+ dev-libs/maloc
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin
+ )
+ web? ( !dev-python/webpy )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.5.0.1-setup.py.patch \
+ "${FILESDIR}"/${PN}-1.5.0.1-data-path.patch \
+ "${FILESDIR}"/${PN}-1.5.0.1-flags.patch
+
+ use web || epatch "${FILESDIR}"/${P}-web.patch
+
+ epatch "${FILESDIR}"/${P}-prefix.patch && \
+ eprefixify setup.py
+
+ use vmd && epatch "${FILESDIR}"/${PN}-1.5.0.1-vmd.patch
+
+ if use numpy; then
+ sed \
+ -e '/PYMOL_NUMPY/s:^#::g' \
+ -i setup.py || die
+ fi
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ echo "site_packages = \'$(python_get_sitedir -f)\'" > setup3.py || die
+
+ # python 3.* fix
+ # sed '452,465d' -i setup.py
+ distutils_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ distutils_src_install
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ cat >> "${T}"/pymol <<- EOF
+ #!/bin/sh
+ $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py -q \$*
+ EOF
+
+ dobin "${T}"/pymol
+
+ insinto /usr/share/pymol
+ doins -r test data scripts
+
+ insinto /usr/share/pymol/examples
+ doins -r examples
+
+ dodoc DEVELOPERS README
+
+ doicon "${WORKDIR}"/${PN}.xpm
+ make_desktop_entry pymol PyMol ${PN} "Graphics;Science;Chemistry"
+}
+
+pkg_postinst() {
+ elog "\t USE=shaders was removed,"
+ elog "please use pymol config settings"
+ elog "\t set use_shaders, 1"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}