summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/entity/entity-0.7.2.ebuild69
-rw-r--r--dev-lang/kaffe/kaffe-1.0.6-r1.ebuild5
-rw-r--r--dev-lang/php-4/files/digest-php-4.0.0-r12
-rw-r--r--dev-lang/php-4/files/digest-php-4.0.3_p1-r12
-rw-r--r--dev-lang/php-4/files/digest-php-4.0.3_p1-r22
-rw-r--r--dev-lang/php-4/files/digest-php-4.0.42
-rw-r--r--dev-lang/php-4/php-4.0.0-r1.ebuild63
-rw-r--r--dev-lang/php-4/php-4.0.3_p1-r1.ebuild84
8 files changed, 60 insertions, 169 deletions
diff --git a/dev-lang/entity/entity-0.7.2.ebuild b/dev-lang/entity/entity-0.7.2.ebuild
index 6f411586e69b..bf0bbf5305bc 100644
--- a/dev-lang/entity/entity-0.7.2.ebuild
+++ b/dev-lang/entity/entity-0.7.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-0.7.2.ebuild,v 1.1 2001/04/28 13:02:22 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-0.7.2.ebuild,v 1.2 2001/04/28 18:59:57 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,25 +11,72 @@ HOMEPAGE="http://www.entity.cx"
DEPEND=">=media-libs/imlib-1.9.8.1
>=dev-libs/libpcre-3.2
- >=dev-lang/tcl-tk-8.1.1
- >=sys-devel/perl-5.6"
+ tcltk? ( >=dev-lang/tcl-tk-8.1.1 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ sdl? ( >=media-libs/libsdl-1.1.7 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ gnome? ( >=gnome-base/gnome-libs-1.2.13 )"
src_compile() {
-
- try DEBIAN_ENTITY_MAGIC=voodoo ./configure --prefix=/usr --host=${CHOST} \
+ echo $USE
+ local myconf
+ if [ "`use tcltk`" ]
+ then
+ myconf="--enable-tcl=module --with-tcl=/usr/lib"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --enable-perl=static"
+ fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --enable-python=static"
+ fi
+ if [ "`use ssl`" ]
+ then
+ myconf="$myconf --enable-openssl"
+ fi
+ if [ "`use sdl`" ]
+ then
+ myconf="$myconf --enable-sdl"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="$myconf --enable-gnome"
+ fi
+ try DEBIAN_ENTITY_MAGIC=\"voodoo\" ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
--enable-exec-class=yes \
--enable-gtk=module \
- --enable-perl=static --enable-python=no \
- --enable-tcl=module --with-tcl=/usr/lib \
- --enable-c=module \
- --enable-javascript=yes --with-included-njs
- try make
+ --enable-c=module $myconf \
+ --enable-javascript=yes --with-included-njs --enable-csinc
+ try make LDFLAGS=\"-L/usr/lib/python2.0/config/ -lz\"
+
}
src_install () {
+ make DESTDIR=${D} LD_LIBRARY_PATH=${D}/usr/lib install
+ insinto /usr/share/entity/stembuilder
+ doins stembuilder/*.e
+ chmod +x ${D}/usr/share/entity/stembuilder/stembuilder.e
+ insinto /usr/share/entity/apps
+ doins apps/*.e
+ chmod +x ${D}/usr/share/entity/apps/{enview,ev}.e
+ exeinto /usr/share/entity/examples
+ doexe examples/*.e
+ insinto /usr/share/entity/stembuilder/images
+ doins stembuilder/images/*.xpm
- make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog LICENSE NEWS README TODO
+ docinto txt
+ dodoc docs/README* docs/*.txt docs/*.ascii
+ docinto html
+ dodoc docs/*.html
+ docinto print
+ dodoc docs/*.ps
+ docinto sgml
+ dodoc docs/*.sgml
}
diff --git a/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild b/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild
index 7a75510fda9c..6d1d69c22f56 100644
--- a/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild
+++ b/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild,v 1.1 2001/04/28 15:32:24 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/kaffe/kaffe-1.0.6-r1.ebuild,v 1.2 2001/04/28 18:59:57 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -13,11 +13,10 @@ DEPEND=">=dev-libs/gmp-3.1
>=media-libs/jpeg-6b
>=media-libs/libpng-1.0.7
virtual/glibc
- virtual/xfree"
+ virtual/x11"
src_unpack() {
unpack ${A}
- cd ${S}
patch -p0 <${FILESDIR}/${PF}-gentoo.diff
}
diff --git a/dev-lang/php-4/files/digest-php-4.0.0-r1 b/dev-lang/php-4/files/digest-php-4.0.0-r1
deleted file mode 100644
index 7b8d4cb1e96f..000000000000
--- a/dev-lang/php-4/files/digest-php-4.0.0-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 487ce03c1201aa81138eac47a1fe92af php-4.0.0.tar.gz
-MD5 20c64ba8d79665e9bfab052fa5a85eab number4.tar.gz
diff --git a/dev-lang/php-4/files/digest-php-4.0.3_p1-r1 b/dev-lang/php-4/files/digest-php-4.0.3_p1-r1
deleted file mode 100644
index fd8253693601..000000000000
--- a/dev-lang/php-4/files/digest-php-4.0.3_p1-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 6969bc69588400557f70a014ab1536c1 php-4.0.3pl1.tar.gz
-MD5 20c64ba8d79665e9bfab052fa5a85eab number4.tar.gz
diff --git a/dev-lang/php-4/files/digest-php-4.0.3_p1-r2 b/dev-lang/php-4/files/digest-php-4.0.3_p1-r2
deleted file mode 100644
index fd8253693601..000000000000
--- a/dev-lang/php-4/files/digest-php-4.0.3_p1-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 6969bc69588400557f70a014ab1536c1 php-4.0.3pl1.tar.gz
-MD5 20c64ba8d79665e9bfab052fa5a85eab number4.tar.gz
diff --git a/dev-lang/php-4/files/digest-php-4.0.4 b/dev-lang/php-4/files/digest-php-4.0.4
deleted file mode 100644
index 1c838f47622a..000000000000
--- a/dev-lang/php-4/files/digest-php-4.0.4
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 16e2022a4b05153b3914fc10ddd63d77 php-4.0.4.tar.gz
-MD5 20c64ba8d79665e9bfab052fa5a85eab number4.tar.gz
diff --git a/dev-lang/php-4/php-4.0.0-r1.ebuild b/dev-lang/php-4/php-4.0.0-r1.ebuild
deleted file mode 100644
index 815946bfbf5b..000000000000
--- a/dev-lang/php-4/php-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.0-r1.ebuild,v 1.3 2000/09/15 20:08:47 drobbins Exp $
-
-P=php-4.0.0
-A="php-4.0.0.tar.gz number4.tar.gz"
-S=${WORKDIR}/${P}
-DESCRIPTION="HTML embedded scripting languag"
-SRC_URI="http://www.php.net/distributions/php-4.0.0.tar.gz
- http://www.php.net/extra/number4.tar.gz"
-HOMEPAGE="http://www.php.net"
-
-src_compile() {
-
-# FLAGS="-mpentium -march=pentium -O4 -I/usr/include/freetype"
-# export CFLAGS=$FLAGS
-# export CPPFLAGS=$FLAGS
-# export CXXFLAGS=$FLAGS
- export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- try ./configure --with-mysql=yes --enable-safe-mode \
- --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
- --with-readline --with-gettext --enable-calendar --with-ldap\
- --with-gd --with-ttf --with-jpeg-dir=/usr/lib \
- --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
- --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
- --enable-versioning --enable-inline-optimization --enable-trans-sid --enable-track-vars
- try make
-}
-
-src_unpack() {
- unpack php-4.0.0.tar.gz
- cd ${S}
- unpack number4.tar.gz
-}
-
-src_install() {
- cd ${S}
- dodir /usr/lib/apache
- cp .libs/libphp4.so ${D}/usr/lib/apache
- dodir /etc/httpd
- cp php.ini-dist ${D}/etc/httpd/php.ini
- into /usr
- dodoc CODING_STANDARDS FUNCTION_LIST.txt INSTALL LICENSE
- dodoc MAINTAINERS MODULES_STATUS README.* TODO NEWS
-}
-
-pkg_postinst() {
-
- . ${ROOT}/etc/rc.d/config/functions
-
- # Activate PHP-Extension in httpd.conf
- einfo "Activate PHP in httpd.conf..."
- cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
- sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
- -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
- -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
- -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
- ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
-
-}
-
-
diff --git a/dev-lang/php-4/php-4.0.3_p1-r1.ebuild b/dev-lang/php-4/php-4.0.3_p1-r1.ebuild
deleted file mode 100644
index e7a79fbef44f..000000000000
--- a/dev-lang/php-4/php-4.0.3_p1-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.3_p1-r1.ebuild,v 1.1 2000/12/05 17:04:43 achim Exp $
-
-P=php-4.0.3pl1
-A="${P}.tar.gz number4.tar.gz"
-S=${WORKDIR}/${P}
-DESCRIPTION="HTML embedded scripting language"
-SRC_URI="http://www.php.net/distributions/${P}.tar.gz
- http://www.php.net/extra/number4.tar.gz"
-HOMEPAGE="http://www.php.net/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=sys-libs/gpm-1.19.3
- >=sys-libs/ncurses-5.1
- >=sys-libs/pam-0.72
- >=media-libs/freetype-1.3.1
- >=media-libs/jpeg-6b
- >=media-libs/tiff-3.5.5
- >=media-libs/libpng-1.0.7
- >=media-libs/t1lib-1.0.1
- >=net-www/apache-ssl-1.3
- >=dev-db/mysql-3.23.26
- >=dev-db/unixODBC-1.8.13
- >=net-nds/openldap-1.2.11
- >=x11-base/xfree-4.0.1
- >=app-text/sablotron-0.44"
-
-src_compile() {
-
- export LDFLAGS="$LDFLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- export LIBS="-lxmlparse -lxmltok"
- ./configure --with-mysql=/usr --enable-safe-mode --enable-ftp \
- --enable-dbase --with-unixODBC=/usr --with-gdbm=/usr --with-db3=/usr \
- --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
- --with-readline --with-gettext --enable-calendar --with-ldap\
- --with-sablot=/usr \
- --with-gd --with-ttf --with-t1lib --with-jpeg-dir=/usr/lib \
- --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
- --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
- --enable-versioning --enable-inline-optimization --enable-trans-sid \
- --with-xpm-dir=/usr/X11R6 --enable-track-vars
- try make
-}
-
-src_unpack() {
- unpack php-4.0.3pl1.tar.gz
- cd ${S}
- unpack number4.tar.gz
-}
-
-src_install() {
- cd ${S}
- dodir /usr/lib/apache
- cp .libs/libphp4.so ${D}/usr/lib/apache
- dodir /etc/httpd
- cp php.ini-dist ${D}/etc/httpd/php.ini
- into /usr
- dodoc CODING_STANDARDS FUNCTION_LIST.txt LICENSE
- dodoc README.* TODO NEWS
-}
-
-pkg_config() {
-
- . ${ROOT}/etc/rc.d/config/functions
-
- if [ -f "${ROOT}/etc/httpd/httpd.conf" ]
- then
-
- # Activate PHP-Extension in httpd.conf
- echo "Activate PHP in httpd.conf..."
- cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
- sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
- -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
- -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
- -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
- ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
-
- fi
-}
-
-
-