summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/rasmol/ChangeLog6
-rw-r--r--sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild69
-rw-r--r--sci-chemistry/rasmol/rasmol-2.7.5-r1.ebuild77
3 files changed, 5 insertions, 147 deletions
diff --git a/sci-chemistry/rasmol/ChangeLog b/sci-chemistry/rasmol/ChangeLog
index 53f61a3c961f..f6a9165c935a 100644
--- a/sci-chemistry/rasmol/ChangeLog
+++ b/sci-chemistry/rasmol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/rasmol
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/ChangeLog,v 1.31 2012/03/07 20:52:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/ChangeLog,v 1.32 2012/03/08 08:09:43 jlec Exp $
+
+ 08 Mar 2012; Justin Lecher <jlec@gentoo.org> -rasmol-2.7.2.1.1-r1.ebuild,
+ -rasmol-2.7.5-r1.ebuild:
+ Dropped old
07 Mar 2012; Brent Baude <ranger@gentoo.org> rasmol-2.7.5.1.ebuild:
Marking rasmol-2.7.5.1 ppc for bug 394085
diff --git a/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild b/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild
deleted file mode 100644
index 0f878339f850..000000000000
--- a/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/rasmol-2.7.2.1.1-r1.ebuild,v 1.12 2011/07/01 06:30:47 jlec Exp $
-inherit fortran-2 toolchain-funcs
-
-MY_P="RasMol_${PV}"
-
-DESCRIPTION="Free program that displays molecular structure."
-HOMEPAGE="http://www.openrasmol.org/"
-SRC_URI="http://www.bernstein-plus-sons.com/software/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-RDEPEND="
- virtual/fortran
- x11-libs/libXext
- x11-libs/libXi
- || ( x11-apps/xdpyinfo x11-apps/xwininfo )"
-DEPEND="${RDEPEND}
- x11-proto/inputproto
- x11-proto/xextproto
- app-text/rman
- x11-misc/imake"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Hack required for build
- cd src
- ln -s ../doc
-}
-
-src_compile() {
- cd src
- xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- || die "8-bit make failed"
- mv rasmol rasmol.8
- make clean
- make DEPTHDEF=-DSIXTEENBIT CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- || die "16-bit make failed"
- mv rasmol rasmol.16
- make clean
- make DEPTHDEF=-DTHIRTYTWOBIT CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- || die "32-bit make failed"
- mv rasmol rasmol.32
- make clean
-}
-
-src_install () {
- newbin "${FILESDIR}"/rasmol.sh.debian rasmol
- insinto /usr/lib/${PN}
- doins doc/rasmol.hlp
- exeinto /usr/lib/${PN}
- doexe src/rasmol.{8,16,32}
- dodoc INSTALL PROJECTS README TODO doc/*.{ps,pdf}.gz doc/rasmol.txt.gz
- doman doc/rasmol.1
- insinto /usr/lib/${PN}/databases
- doins data/*
-}
diff --git a/sci-chemistry/rasmol/rasmol-2.7.5-r1.ebuild b/sci-chemistry/rasmol/rasmol-2.7.5-r1.ebuild
deleted file mode 100644
index 6c38a4366b10..000000000000
--- a/sci-chemistry/rasmol/rasmol-2.7.5-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/rasmol/rasmol-2.7.5-r1.ebuild,v 1.8 2011/07/01 06:30:47 jlec Exp $
-
-EAPI=4
-
-inherit eutils fortran-2 prefix toolchain-funcs
-
-MY_P="RasMol_${PV}"
-VERS="23Jul09"
-
-DESCRIPTION="Molecular Graphics Visualisation Tool"
-HOMEPAGE="http://www.openrasmol.org/"
-SRC_URI="http://www.rasmol.org/software/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 RASLIC )"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-libs/cvector
- sci-libs/cbflib
- sci-libs/cqrlib
- sci-libs/neartree
- virtual/fortran
- x11-libs/cairo
- x11-libs/gtk+:2
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/vte:0"
-DEPEND="${RDEPEND}
- app-text/rman
- x11-misc/imake
- x11-proto/inputproto
- x11-proto/xextproto"
-
-S="${WORKDIR}/${P}-${VERS}"
-
-src_prepare() {
- cd src
-
- if use amd64 || use amd64-linux; then
- mv rasmol.h rasmol_amd64_save.h && \
- echo "#define _LONGLONG"|cat - rasmol_amd64_save.h > rasmol.h
- fi
-
- mv Imakefile_base Imakefile
- epatch "${FILESDIR}"/${PV}-bundled-lib.patch
-
- eprefixify Imakefile
-
- xmkmf -DGTKWIN ${myconf}|| die "xmkmf failed with ${myconf}"
-}
-
-src_compile() {
- emake -C src clean
- emake \
- -C src \
- DEPTHDEF=-DTHIRTYTWOBIT \
- CC="$(tc-getCC)" \
- CDEBUGFLAGS="${CFLAGS}" \
- EXTRA_LDOPTIONS="${LDFLAGS}"
-}
-
-src_install () {
- libdir=$(get_libdir)
- insinto /usr/${libdir}/${PN}
- doins doc/rasmol.hlp
- dobin src/rasmol
- dodoc PROJECTS {README,TODO}.txt doc/*.{ps,pdf}.gz doc/rasmol.txt.gz
- doman doc/rasmol.1
- insinto /usr/${libdir}/${PN}/databases
- doins data/*
-
- dohtml -r *html doc/*.html html_graphics
-}