summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/pnp4nagios/ChangeLog7
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.19.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/net-analyzer/pnp4nagios/ChangeLog b/net-analyzer/pnp4nagios/ChangeLog
index a21626db87cd..bf6dbc7e656e 100644
--- a/net-analyzer/pnp4nagios/ChangeLog
+++ b/net-analyzer/pnp4nagios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pnp4nagios
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.44 2012/08/19 15:32:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/ChangeLog,v 1.45 2012/09/11 20:54:59 idl0r Exp $
+
+*pnp4nagios-0.6.19 (11 Sep 2012)
+
+ 11 Sep 2012; Christian Ruppert <idl0r@gentoo.org> +pnp4nagios-0.6.19.ebuild:
+ Version bump to 0.6.19.
19 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Re-assign to sysadmin herd.
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.19.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.19.ebuild
new file mode 100644
index 000000000000..ae0399b89ec6
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.19.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.19.ebuild,v 1.1 2012/09/11 20:54:59 idl0r Exp $
+
+EAPI="4"
+
+inherit depend.apache eutils
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org"
+
+SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/php[json,simplexml,zlib,xml,filter]
+ >=dev-lang/php-5.3
+ >=net-analyzer/rrdtool-1.2[perl]
+ || ( net-analyzer/nagios-core net-analyzer/icinga )"
+RDEPEND="${DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ media-fonts/dejavu
+ apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.14-makefile.patch
+}
+
+src_configure() {
+ local var_dir=
+ local user_group=
+
+ if has_version net-analyzer/nagios-core; then
+ var_dir=/var/nagios/
+ user_group=nagios
+ else
+ var_dir=/var/lib/icinga/
+ user_group=icinga
+ fi
+
+ econf \
+ --sysconfdir=/etc/pnp \
+ --datarootdir=/usr/share/pnp \
+ --mandir=/usr/share/man \
+ --with-perfdata-dir=${var_dir}/perfdata \
+ --with-nagios-user=${user_group} \
+ --with-nagios-group=${user_group} \
+ --with-perfdata-logfile=${var_dir}/perfdata.log \
+ --with-perfdata-spool-dir=/var/spool/pnp
+}
+
+src_compile() {
+ # The default target just shows a help
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-config || die "emake install failed"
+ newinitd "${FILESDIR}/npcd.initd" npcd
+ rm "${D}/usr/share/pnp/install.php"
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/98_pnp4nagios.conf
+ fi
+}
+
+pkg_postinst() {
+ elog "Please make sure to enable URL rewriting in Apache or any other"
+ elog "webserver you're using, to get pnp4nagios running!"
+}