summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/gtkmm/gtkmm-1.2.9.ebuild34
-rw-r--r--x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild8
-rw-r--r--x11-misc/autocutsel/autocutsel-0.6.2.ebuild19
-rw-r--r--x11-misc/docker/docker-1.3.ebuild13
4 files changed, 23 insertions, 51 deletions
diff --git a/x11-libs/gtkmm/gtkmm-1.2.9.ebuild b/x11-libs/gtkmm/gtkmm-1.2.9.ebuild
index 65dda8b446db..ebadb64cab8d 100644
--- a/x11-libs/gtkmm/gtkmm-1.2.9.ebuild
+++ b/x11-libs/gtkmm/gtkmm-1.2.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmm/gtkmm-1.2.9.ebuild,v 1.9 2002/10/17 16:22:06 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmm/gtkmm-1.2.9.ebuild,v 1.10 2002/11/12 07:19:40 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="C++ interface for GTK+"
SRC_URI="http://download.sourceforge.net/gtkmm/${P}.tar.gz"
# ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz
# http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz"
HOMEPAGE="http://gtkmm.sourceforge.net/"
+
LICENSE="GPL-2"
SLOT="1.2"
KEYWORDS="x86 ppc sparc sparc64"
@@ -16,41 +16,23 @@ DEPEND="virtual/glibc
=x11-libs/gtk+-1.2*
>=dev-libs/libsigc++-1.0.4"
-RDEPEND=${DEPEND}
-
src_compile() {
-
local myconf
- if [ "${DEBUG}" ]
- then
+ if [ "${DEBUGBUILD}" ] ; then
myconf="--enable-debug=yes"
else
myconf="--enable-debug=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --sysconfdir=/etc/X11 \
- --with-xinput=xfree \
+ econf --with-xinput=xfree \
--with-x \
- ${myconf} || die
-
+ ${myconf}
+
make || die
}
src_install() {
-
- make DESTDIR=${D} \
- install || die
-
-
- dodoc AUTHORS COPYING ChangeLog* HACKING
- dodoc NEWS* README* TODO
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING NEWS* README* TODO
}
-
-
-
-
diff --git a/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild b/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild
index d044dcb3c72e..083c5f128bac 100644
--- a/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild
+++ b/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild,v 1.4 2002/11/06 15:45:31 stubear Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild,v 1.5 2002/11/12 07:21:33 vapier Exp $
DESCRIPTION="Arphic Fonts"
SRC_URI="ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
@@ -8,17 +8,17 @@ SRC_URI="ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bsmi00lp.ttf.gz
ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gbsn00lp.ttf.gz"
HOMEPAGE="http://www.arphic.com.tw/"
+
LICENSE="Arphic"
SLOT="0"
KEYWORDS="x86"
-S=${WORKDIR}
DEPEND="virtual/x11
x11-misc/ttmkfdir"
-RDEPEND=${DEPEND}
+
+S="${WORKDIR}"
src_install() {
- cd ${S}
insopts -m0644
insinto /usr/share/fonts/ttf/zh_TW
doins b*.ttf
diff --git a/x11-misc/autocutsel/autocutsel-0.6.2.ebuild b/x11-misc/autocutsel/autocutsel-0.6.2.ebuild
index 8b86a0548049..610aad253126 100644
--- a/x11-misc/autocutsel/autocutsel-0.6.2.ebuild
+++ b/x11-misc/autocutsel/autocutsel-0.6.2.ebuild
@@ -1,28 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-S=${WORKDIR}/${P}
-DESCRIPTION="Synchronise the two copy/paste buffers mainly used by X applications."
+DESCRIPTION="Synchronise the two copy/paste buffers mainly used by X applications"
HOMEPAGE="http://www.lepton.fr/tools/autocutsel/"
+SRC_URI="http://www.lepton.fr/tools/autocutsel/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc virtual/x11"
-RDEPEND=${DEPEND}
-
-SRC_URI="http://www.lepton.fr/tools/autocutsel/${P}.tar.gz"
+DEPEND="virtual/glibc
+ virtual/x11"
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
diff --git a/x11-misc/docker/docker-1.3.ebuild b/x11-misc/docker/docker-1.3.ebuild
index 0c4659dd00f1..e43108c3ea43 100644
--- a/x11-misc/docker/docker-1.3.ebuild
+++ b/x11-misc/docker/docker-1.3.ebuild
@@ -1,27 +1,22 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/docker/docker-1.3.ebuild,v 1.2 2002/11/12 07:23:10 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
SRC_URI="http://icculus.org/openbox/docker/${P}.tar.gz"
HOMEPAGE="http://icculus.org/openbox/docker/"
-DEPEND="x11-wm/openbox"
-RDEPEND=${DEPEND}
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
-src_compile() {
+DEPEND="x11-wm/openbox"
+src_compile() {
emake || die
-
}
src_install () {
-
dobin docker
dodoc COPYING README
}