summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/pidgin-festival/ChangeLog10
-rw-r--r--app-accessibility/pidgin-festival/pidgin-festival-2.2-r1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/app-accessibility/pidgin-festival/ChangeLog b/app-accessibility/pidgin-festival/ChangeLog
index 1d7e2f3b80b3..80976eba7114 100644
--- a/app-accessibility/pidgin-festival/ChangeLog
+++ b/app-accessibility/pidgin-festival/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/pidgin-festival
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/ChangeLog,v 1.6 2008/03/05 19:34:03 tester Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/ChangeLog,v 1.7 2009/03/07 14:57:31 patrick Exp $
+
+*pidgin-festival-2.2-r1 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +pidgin-festival-2.2-r1.ebuild:
+ Eapi2ification with use-deps
05 Mar 2008; <tester@gentoo.org> pidgin-festival-2.2.ebuild:
Inherit eutils, bug #212411
diff --git a/app-accessibility/pidgin-festival/pidgin-festival-2.2-r1.ebuild b/app-accessibility/pidgin-festival/pidgin-festival-2.2-r1.ebuild
new file mode 100644
index 000000000000..f9b1d9e867a0
--- /dev/null
+++ b/app-accessibility/pidgin-festival/pidgin-festival-2.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/pidgin-festival/pidgin-festival-2.2-r1.ebuild,v 1.1 2009/03/07 14:57:31 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A plugin for pidgin which enables text-to-speech output of conversations using festival."
+HOMEPAGE="http://pidgin.festival.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE=""
+
+RDEPEND="app-accessibility/festival
+ net-im/pidgin[gtk]
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+#pkg_setup() {
+# if ! built_with_use net-im/pidgin gtk; then
+# eerror "You need to compile net-im/pidgin with USE=gtk"
+# die "Missing gtk USE flag on net-im/pidgin"
+# fi
+#}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README ChangeLog
+}