summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/vdr-radio/ChangeLog8
-rw-r--r--media-plugins/vdr-radio/files/vdr-radio-0.2.4-glibc-2.10.patch30
-rw-r--r--media-plugins/vdr-radio/vdr-radio-0.2.4.ebuild41
3 files changed, 6 insertions, 73 deletions
diff --git a/media-plugins/vdr-radio/ChangeLog b/media-plugins/vdr-radio/ChangeLog
index a7e666b89b0a..f3040279a7f7 100644
--- a/media-plugins/vdr-radio/ChangeLog
+++ b/media-plugins/vdr-radio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-radio
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-radio/ChangeLog,v 1.24 2013/03/31 17:36:04 hd_brummy Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-radio/ChangeLog,v 1.25 2014/01/08 18:27:30 hd_brummy Exp $
+
+ 08 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org> -vdr-radio-0.2.4.ebuild,
+ -files/vdr-radio-0.2.4-glibc-2.10.patch:
+ cleanup old, depended on vdr-plugin.eclass
*vdr-radio-0.9.1 (31 Mar 2013)
diff --git a/media-plugins/vdr-radio/files/vdr-radio-0.2.4-glibc-2.10.patch b/media-plugins/vdr-radio/files/vdr-radio-0.2.4-glibc-2.10.patch
deleted file mode 100644
index 7e80da9612da..000000000000
--- a/media-plugins/vdr-radio/files/vdr-radio-0.2.4-glibc-2.10.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur radio-0.2.4.orig/radioepg.c radio-0.2.4/radioepg.c
---- radio-0.2.4.orig/radioepg.c 2007-10-09 18:45:26.000000000 +0300
-+++ radio-0.2.4/radioepg.c 2009-08-08 22:50:46.000000000 +0300
-@@ -12,7 +12,7 @@
- int epg_premiere(const char *epgtitle, const char *epgdescr, time_t epgstart, time_t epgend)
- {
- int i;
-- char *p;
-+ const char *p;
- char artist[RT_MEL], titel[RT_MEL], album[RT_MEL], jahr[RT_MEL];
- struct tm tm_store;
-
-@@ -143,7 +143,7 @@
- int epg_kdg(const char *epgdescr, time_t epgstart, time_t epgend)
- {
- int i;
-- char *p;
-+ const char *p;
- char artist[RT_MEL], titel[RT_MEL], album[RT_MEL], komp[RT_MEL];
- struct tm tm_store;
-
-@@ -240,7 +240,7 @@
- int epg_unitymedia(const char *epgtitle, const char *epgdescr, time_t epgstart, time_t epgend)
- {
- int i;
-- char *p1, *p2;
-+ const char *p1, *p2;
- char titel[2*RT_MEL], artist[2*RT_MEL];
- struct tm tm_store;
-
diff --git a/media-plugins/vdr-radio/vdr-radio-0.2.4.ebuild b/media-plugins/vdr-radio/vdr-radio-0.2.4.ebuild
deleted file mode 100644
index 85d6eae426a9..000000000000
--- a/media-plugins/vdr-radio/vdr-radio-0.2.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-radio/vdr-radio-0.2.4.ebuild,v 1.4 2009/08/08 19:50:34 ssuominen Exp $
-
-inherit vdr-plugin eutils
-
-DESCRIPTION="VDR plugin: show background image for radio and decode RDS Text"
-HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=58795"
-SRC_URI="http://www.egal-vdr.de/plugins/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE=""
-
-RDEPEND=">=media-video/vdr-1.3.43"
-DEPEND="${RDEPEND}"
-
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon.sh-0.2.0"
-
-src_unpack() {
- vdr-plugin_src_unpack
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
-}
-
-src_install() {
- vdr-plugin_src_install
-
- cd "${S}"/config
-
- insinto /usr/share/vdr/radio
- doins mpegstill/rtext*
- dosym rtextOben-kleo2-live.mpg /usr/share/vdr/radio/radio.mpg
- dosym rtextOben-kleo2-replay.mpg /usr/share/vdr/radio/replay.mpg
-
- exeinto /usr/share/vdr/radio
- doexe scripts/radioinfo*
-
- diropts -m 755 -o vdr -g vdr
- keepdir "/var/cache/vdr-radio"
-}