summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/khotkeys/ChangeLog8
-rw-r--r--kde-base/khotkeys/files/khotkeys-4-parallel.patch22
-rw-r--r--kde-base/khotkeys/khotkeys-4.2.4.ebuild24
3 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/khotkeys/ChangeLog b/kde-base/khotkeys/ChangeLog
index b82036575eb1..debdec75dd19 100644
--- a/kde-base/khotkeys/ChangeLog
+++ b/kde-base/khotkeys/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/khotkeys
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/khotkeys/ChangeLog,v 1.117 2009/06/03 16:08:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/khotkeys/ChangeLog,v 1.118 2009/06/04 12:35:41 alexxy Exp $
+
+*khotkeys-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +khotkeys-4.2.4.ebuild,
+ +files/khotkeys-4-parallel.patch:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -khotkeys-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/khotkeys/files/khotkeys-4-parallel.patch b/kde-base/khotkeys/files/khotkeys-4-parallel.patch
new file mode 100644
index 000000000000..6051c0723ae6
--- /dev/null
+++ b/kde-base/khotkeys/files/khotkeys-4-parallel.patch
@@ -0,0 +1,22 @@
+--- khotkeys/update/CMakeLists.txt.old 2009-06-02 23:06:15.604322396 +0300
++++ khotkeys/update/CMakeLists.txt 2009-06-02 23:06:05.516480905 +0300
+@@ -12,6 +12,8 @@
+
+ kde4_add_executable( khotkeys_update ${khotkeys_update_SRCS})
+
++add_dependencies( khotkeys_update kded_khotkeys )
++
+ target_link_libraries( khotkeys_update khotkeysprivate kworkspace ${KDE4_KDE3SUPPORT_LIBS} )
+ if(X11_XTest_FOUND)
+ target_link_libraries( khotkeys_update ${X11_XTest_LIB} )
+--- khotkeys/kcm_hotkeys/CMakeLists.txt.old 2009-06-02 23:05:32.685403364 +0300
++++ khotkeys/kcm_hotkeys/CMakeLists.txt 2009-06-02 23:05:15.410616052 +0300
+@@ -50,6 +50,8 @@
+ ${kcm_hotkeys_PART_SRCS}
+ )
+
++add_dependencies(kcm_hotkeys kded_khotkeys)
++
+ target_link_libraries(
+ kcm_hotkeys
+ khotkeysprivate
diff --git a/kde-base/khotkeys/khotkeys-4.2.4.ebuild b/kde-base/khotkeys/khotkeys-4.2.4.ebuild
new file mode 100644
index 000000000000..f7c59977d471
--- /dev/null
+++ b/kde-base/khotkeys/khotkeys-4.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/khotkeys/khotkeys-4.2.4.ebuild,v 1.1 2009/06/04 12:35:41 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE: hotkey daemon"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="
+ >=kde-base/libkworkspace-${PV}:${SLOT}[kdeprefix=]
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libs/kworkspace/
+"
+
+PATCHES=( "${FILESDIR}/khotkeys-4-parallel.patch" )