summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/kimera/ChangeLog10
-rw-r--r--app-i18n/kimera/files/kimera-2.11-gentoo.patch10
-rw-r--r--app-i18n/kimera/kimera-2.11.ebuild42
3 files changed, 60 insertions, 2 deletions
diff --git a/app-i18n/kimera/ChangeLog b/app-i18n/kimera/ChangeLog
index 2b30c43b25df..49e1f51853c0 100644
--- a/app-i18n/kimera/ChangeLog
+++ b/app-i18n/kimera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/kimera
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.13 2008/08/31 03:00:07 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/ChangeLog,v 1.14 2009/02/11 01:22:06 matsuu Exp $
+
+*kimera-2.11 (11 Feb 2009)
+
+ 11 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/kimera-2.11-gentoo.patch, +kimera-2.11.ebuild:
+ Version bumped, bug #258022.
*kimera-2.00 (31 Aug 2008)
diff --git a/app-i18n/kimera/files/kimera-2.11-gentoo.patch b/app-i18n/kimera/files/kimera-2.11-gentoo.patch
new file mode 100644
index 000000000000..41272a1589b4
--- /dev/null
+++ b/app-i18n/kimera/files/kimera-2.11-gentoo.patch
@@ -0,0 +1,10 @@
+diff -Naur kimera-2.11.orig/kimera.pro kimera-2.11/kimera.pro
+--- kimera-2.11.orig/kimera.pro 2009-01-26 00:36:40.000000000 +0900
++++ kimera-2.11/kimera.pro 2009-02-11 09:12:00.000000000 +0900
+@@ -1,5 +1,5 @@
+ TEMPLATE = app
+-CONFIG += qt x11 warn_on release
++CONFIG += qt x11 warn_on release nostrip
+ QT += network
+ TARGET = kimera-bin
+ VERSION = 2.11
diff --git a/app-i18n/kimera/kimera-2.11.ebuild b/app-i18n/kimera/kimera-2.11.ebuild
new file mode 100644
index 000000000000..81b78c683063
--- /dev/null
+++ b/app-i18n/kimera/kimera-2.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-2.11.ebuild,v 1.1 2009/02/11 01:22:06 matsuu Exp $
+
+EAPI=1
+inherit eutils multilib qt4
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+SRC_URI="mirror://sourceforge.jp/kimera/37271/${P}.tar.gz"
+HOMEPAGE="http://kimera.sourceforge.jp/"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+anthy"
+
+DEPEND="|| ( x11-libs/qt-core:4 x11-libs/qt:4 )
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ local myconf="target.path=/usr/$(get_libdir)/${P}"
+
+ use anthy || myconf="${myconf} no_anthy=1"
+
+ eqmake4 kimera.pro ${myconf} || die
+ emake || die
+}
+
+src_install(){
+ emake INSTALL_ROOT="${D}" install || die
+
+ dodoc AUTHORS README*
+}